modify cb setting
[platform/core/messaging/msg-service.git] / packaging / msg-service.spec
1 Name:           msg-service
2 Version:        0.9.0
3 Release:        1
4 License:        Samsung
5 Summary:        Messaging Framework Library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8
9 Requires(post): /usr/bin/sqlite3
10 Requires(post): /usr/bin/vconftool
11 Requires(post): /sbin/ldconfig
12 Requires(postun): /sbin/ldconfig
13 BuildRequires: cmake
14 BuildRequires: pkgconfig(alarm-service)
15 BuildRequires: pkgconfig(aul)
16 BuildRequires: pkgconfig(capi-appfw-application)
17 BuildRequires: pkgconfig(contacts-service)
18 BuildRequires: pkgconfig(db-util)
19 BuildRequires: pkgconfig(devman_haptic)
20 BuildRequires: pkgconfig(dlog)
21 BuildRequires: pkgconfig(drm-client)
22 BuildRequires: pkgconfig(glib-2.0)
23 BuildRequires: pkgconfig(libcurl)
24 BuildRequires: pkgconfig(libsystemd-daemon)
25 BuildRequires: pkgconfig(libxml-2.0)
26 BuildRequires: pkgconfig(libwbxml2)
27 BuildRequires: pkgconfig(media-thumbnail)
28 BuildRequires: pkgconfig(mm-fileinfo)
29 BuildRequires: pkgconfig(mm-player)
30 BuildRequires: pkgconfig(mm-session)
31 BuildRequires: pkgconfig(network)
32 BuildRequires: pkgconfig(notification)
33 BuildRequires: pkgconfig(pmapi)
34 BuildRequires: pkgconfig(mmutil-imgp)
35 BuildRequires: pkgconfig(mmutil-jpeg)
36 BuildRequires: pkgconfig(security-server)
37 BuildRequires: pkgconfig(sensor)
38 BuildRequires: pkgconfig(svi)
39 BuildRequires: pkgconfig(tapi)
40 BuildRequires: pkgconfig(vconf)
41
42 %description
43 Description: Messaging Framework Library
44
45
46 %package devel
47 License:        Apache License v2.0
48 Summary:        Messaging Framework Library (development)
49 Requires:       %{name} = %{version}-%{release}
50 Group:          Development/Libraries
51
52 %description devel
53 Description: Messaging Framework Library (development)
54
55
56 %package tools
57 License:        Apache License v2.0
58 Summary:        Messaging server application
59 Requires:       %{name} = %{version}-%{release}
60 Group:          TO_BU / FILL_IN
61 Requires(post): /usr/bin/sqlite3
62 Requires(post): /usr/bin/vconftool
63 Requires(post): /sbin/ldconfig
64 Requires(postun): /sbin/ldconfig
65
66 %description tools
67 Description:  Messaging server application
68
69
70 %package -n sms-plugin
71 License:        Apache License v2.0
72 Summary:        SMS plugin library
73 Requires:       %{name} = %{version}-%{release}
74 Group:          System/Libraries
75 Requires(post): /sbin/ldconfig
76 Requires(postun): /sbin/ldconfig
77
78 %description -n sms-plugin
79 Description: SMS plugin library
80
81 %package -n mms-plugin
82 License:        Apache License v2.0
83 Summary:        MMS plugin library
84 Requires:       %{name} = %{version}-%{release}
85 Group:          System/Libraries
86 Requires(post): /sbin/ldconfig
87 Requires(postun): /sbin/ldconfig
88
89 %description -n mms-plugin
90 Description: MMS plugin library
91
92 %prep
93 %setup -q
94
95
96 %build
97 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
98 make %{?jobs:-j%jobs}
99
100 %install
101
102 rm -rf %{buildroot}
103 %make_install
104
105 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
106 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70msg-server
107 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
108 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70msg-server
109
110
111
112 mkdir -p %{buildroot}/opt/data/msg-service
113
114 %post tools -p /sbin/ldconfig
115 %post -n sms-plugin -p /sbin/ldconfig
116 %post -n mms-plugin -p /sbin/ldconfig
117
118 %post
119 /sbin/ldconfig
120
121 if [ ! -f /opt/dbspace/.msg_service.db ]
122 then
123     sqlite3 /opt/dbspace/.msg_service.db "PRAGMA journal_mode = PERSIST;
124
125     CREATE TABLE MSG_CONVERSATION_TABLE ( CONV_ID INTEGER NOT NULL , UNREAD_CNT INTEGER DEFAULT 0 , SMS_CNT INTEGER DEFAULT 0 , MMS_CNT INTEGER DEFAULT 0 , MAIN_TYPE INTEGER NOT NULL , SUB_TYPE INTEGER NOT NULL , MSG_DIRECTION INTEGER NOT NULL , DISPLAY_TIME INTEGER , DISPLAY_NAME TEXT , MSG_TEXT TEXT );
126     CREATE TABLE MSG_ADDRESS_TABLE ( ADDRESS_ID INTEGER PRIMARY KEY , CONV_ID INTEGER  NOT NULL , ADDRESS_TYPE INTEGER , RECIPIENT_TYPE INTEGER , ADDRESS_VAL TEXT , CONTACT_ID INTEGER , DISPLAY_NAME TEXT , FIRST_NAME TEXT , LAST_NAME TEXT , IMAGE_PATH TEXT , SYNC_TIME DATETIME , FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) );
127     CREATE TABLE MSG_FOLDER_TABLE ( FOLDER_ID INTEGER PRIMARY KEY , FOLDER_NAME TEXT NOT NULL , FOLDER_TYPE INTEGER DEFAULT 0 );
128     CREATE TABLE MSG_MESSAGE_TABLE ( MSG_ID INTEGER PRIMARY KEY , CONV_ID INTEGER NOT NULL , FOLDER_ID INTEGER NOT NULL , STORAGE_ID INTEGER NOT NULL , MAIN_TYPE INTEGER NOT NULL , SUB_TYPE INTEGER NOT NULL , DISPLAY_TIME DATETIME , DATA_SIZE INTEGER DEFAULT 0 , NETWORK_STATUS INTEGER DEFAULT 0 , READ_STATUS INTEGER DEFAULT 0 , PROTECTED INTEGER DEFAULT 0 , PRIORITY INTEGER DEFAULT 0 , MSG_DIRECTION INTEGER NOT NULL , SCHEDULED_TIME DATETIME , BACKUP INTEGER DEFAULT 0 , SUBJECT TEXT , MSG_DATA TEXT , THUMB_PATH TEXT , MSG_TEXT TEXT , DELIVERY_REPORT_STATUS INTEGER DEFAULT 0 , DELIVERY_REPORT_TIME DATETIME , READ_REPORT_STATUS INTEGER DEFAULT 0 , READ_REPORT_TIME DATETIME , ATTACHMENT_COUNT INTEGER DEFAULT 0 , FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) , FOREIGN KEY (FOLDER_ID) REFERENCES MSG_FOLDER_TABLE (FOLDER_ID) );
129     CREATE TABLE MSG_SIM_TABLE ( MSG_ID INTEGER , SIM_ID INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
130     CREATE TABLE MSG_PUSH_TABLE ( MSG_ID INTEGER , ACTION INTEGER , CREATED INTEGER , EXPIRES INTEGER , ID TEXT , HREF TEXT , CONTENT TEXT , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
131     CREATE TABLE MSG_CBMSG_TABLE ( MSG_ID INTEGER , CB_MSG_ID INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
132     CREATE TABLE MSG_SYNCML_TABLE ( MSG_ID INTEGER , EXT_ID INTEGER NOT NULL , PINCODE INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
133     CREATE TABLE MSG_SMS_SENDOPT_TABLE ( MSG_ID INTEGER , DELREP_REQ INTEGER NOT NULL , KEEP_COPY INTEGER NOT NULL , REPLY_PATH INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
134     CREATE TABLE MSG_FILTER_TABLE ( FILTER_ID INTEGER PRIMARY KEY , FILTER_TYPE INTEGER NOT NULL , FILTER_VALUE TEXT NOT NULL );
135     CREATE TABLE MSG_MMS_MESSAGE_TABLE ( MSG_ID INTEGER , TRANSACTION_ID TEXT , MESSAGE_ID TEXT , FWD_MESSAGE_ID TEXT , CONTENTS_LOCATION TEXT , FILE_PATH TEXT , VERSION INTEGER NOT NULL , DATA_TYPE INTEGER DEFAULT -1 , DATE DATETIME , HIDE_ADDRESS INTEGER DEFAULT 0 , ASK_DELIVERY_REPORT INTEGER DEFAULT 0 , REPORT_ALLOWED INTEGER DEFAULT 0 , READ_REPORT_ALLOWED_TYPE INTEGER DEFAULT 0 , ASK_READ_REPLY INTEGER DEFAULT 0 , READ INTEGER DEFAULT 0 , READ_REPORT_SEND_STATUS INTEGER DEFAULT 0 , READ_REPORT_SENT INTEGER DEFAULT 0 , PRIORITY INTEGER DEFAULT 0 , KEEP_COPY INTEGER DEFAULT 0 , MSG_SIZE INTEGER NOT NULL , MSG_CLASS INTEGER DEFAULT -1 , EXPIRY_TIME DATETIME , CUSTOM_DELIVERY_TIME INTEGER DEFAULT 0 , DELIVERY_TIME DATETIME , MSG_STATUS INTEGER DEFAULT -1 , FOREIGN KEY (MSG_ID) REFERENCES MSG_MESSAGE_TABLE (MSG_ID) );
136
137     CREATE INDEX MSG_CONVERSATION_INDEX ON MSG_CONVERSATION_TABLE(CONV_ID);
138     CREATE INDEX MSG_FOLDER_INDEX ON MSG_FOLDER_TABLE(FOLDER_ID);
139     CREATE INDEX MSG_MESSAGE_INDEX ON MSG_MESSAGE_TABLE(MSG_ID, CONV_ID, FOLDER_ID);
140
141     INSERT INTO MSG_FOLDER_TABLE VALUES (1, 'INBOX', 1);
142     INSERT INTO MSG_FOLDER_TABLE VALUES (2, 'OUTBOX', 2);
143     INSERT INTO MSG_FOLDER_TABLE VALUES (3, 'SENTBOX', 2);
144     INSERT INTO MSG_FOLDER_TABLE VALUES (4, 'DRAFT', 3);
145     INSERT INTO MSG_FOLDER_TABLE VALUES (5, 'CBMSGBOX', 1);
146     INSERT INTO MSG_FOLDER_TABLE VALUES (6, 'SPAMBOX', 4);
147     INSERT INTO MSG_FOLDER_TABLE VALUES (7, 'SMS TEMPLATE', 5);
148     INSERT INTO MSG_FOLDER_TABLE VALUES (8, 'MMS TEMPLATE', 5);"
149 fi
150
151 chown :6011 /opt/dbspace/.msg_service.db
152 chown :6011 /opt/dbspace/.msg_service.db-journal
153
154
155 chmod 660 /opt/dbspace/.msg_service.db
156 chmod 660 /opt/dbspace/.msg_service.db-journal
157
158
159 ########## Setting Config Value (Internal keys) ##########
160 # Message Server Status
161 vconftool set -t bool memory/msg/ready 0 -i
162
163 # SMS Send Options
164 vconftool set -t int db/msg/network_mode 2
165
166 # New Message Count
167 vconftool set -t int db/msg/recv_sms 0
168 vconftool set -t int db/msg/recv_mms 0
169
170 ########## Setting Config Value (Private keys) ##########
171 # General Options
172 vconftool set -t bool db/private/msg-service/general/keep_copy 1
173 vconftool set -t bool db/private/msg-service/general/auto_erase 0
174 vconftool set -t bool db/private/msg-service/general/block_msg 0
175 vconftool set -t int db/private/msg-service/general/contact_sync_time 0
176
177 # SMS Send Options
178 vconftool set -t int db/private/msg-service/sms_send/dcs 3
179 vconftool set -t bool db/private/msg-service/sms_send/reply_path 0
180 vconftool set -t bool db/private/msg-service/sms_send/delivery_report 0
181 vconftool set -t int db/private/msg-service/sms_send/save_storage 1
182
183 # SMSC
184 vconftool set -t int db/private/msg-service/smsc/total_count 1
185 vconftool set -t int db/private/msg-service/smsc/selected 0
186
187 vconftool set -t int db/private/msg-service/smsc/pid/0 1
188 vconftool set -t int db/private/msg-service/smsc/val_period/0 255
189 vconftool set -t string db/private/msg-service/smsc/name/0 ""
190 vconftool set -t int db/private/msg-service/smsc/ton/0 1
191 vconftool set -t int db/private/msg-service/smsc/npi/0 1
192 vconftool set -t string db/private/msg-service/smsc/address/0 ""
193
194 vconftool set -t int db/private/msg-service/smsc/pid/1 0
195 vconftool set -t int db/private/msg-service/smsc/val_period/1 0
196 vconftool set -t string db/private/msg-service/smsc/name/1 ""
197 vconftool set -t int db/private/msg-service/smsc/ton/1 0
198 vconftool set -t int db/private/msg-service/smsc/npi/1 0
199 vconftool set -t string db/private/msg-service/smsc/address/1 ""
200
201 vconftool set -t int db/private/msg-service/smsc/pid/2 0
202 vconftool set -t int db/private/msg-service/smsc/val_period/2 0
203 vconftool set -t string db/private/msg-service/smsc/name/2 ""
204 vconftool set -t int db/private/msg-service/smsc/ton/2 0
205 vconftool set -t int db/private/msg-service/smsc/npi/2 0
206 vconftool set -t string db/private/msg-service/smsc/address/2 ""
207
208 # MMS Send Options
209 vconftool set -t int db/private/msg-service/mms_send/msg_class 0
210 vconftool set -t int db/private/msg-service/mms_send/priority 1
211 vconftool set -t int db/private/msg-service/mms_send/expiry_time 0
212 vconftool set -t int db/private/msg-service/mms_send/custom_delivery 0
213 vconftool set -t bool db/private/msg-service/mms_send/sender_visibility 0
214 vconftool set -t bool db/private/msg-service/mms_send/delivery_report 1
215 vconftool set -t bool db/private/msg-service/mms_send/read_reply 1
216 vconftool set -t bool db/private/msg-service/mms_send/keep_copy 0
217 vconftool set -t bool db/private/msg-service/mms_send/body_replying 0
218 vconftool set -t bool db/private/msg-service/mms_send/hide_recipients 0
219 vconftool set -t bool db/private/msg-service/mms_send/report_allowed 1
220 vconftool set -t int db/private/msg-service/mms_send/reply_charging 0
221 vconftool set -t int db/private/msg-service/mms_send/reply_charging_deadline 0
222 vconftool set -t int db/private/msg-service/mms_send/reply_charging_size 0
223 vconftool set -t int db/private/msg-service/mms_send/delivery_time 0
224 vconftool set -t int db/private/msg-service/mms_send/creation_mode 2
225
226 # MMS Receive Options
227 vconftool set -t int db/private/msg-service/mms_recv/home_network 0
228 vconftool set -t int db/private/msg-service/mms_recv/abroad_network 0
229 vconftool set -t bool db/private/msg-service/mms_recv/read_receipt 1
230 vconftool set -t bool db/private/msg-service/mms_recv/delivery_receipt 1
231 vconftool set -t bool db/private/msg-service/mms_recv/reject_unknown 0
232 vconftool set -t bool db/private/msg-service/mms_recv/reject_advertisement 0
233
234 # MMS Receive Options
235 vconftool set -t int db/private/msg-service/mms_style/font_size 30
236 vconftool set -t bool db/private/msg-service/mms_style/font_style/bold 0
237 vconftool set -t bool db/private/msg-service/mms_style/font_style/italic 0
238 vconftool set -t bool db/private/msg-service/mms_style/font_style/underline 0
239 vconftool set -t int db/private/msg-service/mms_style/font_color/red 255
240 vconftool set -t int db/private/msg-service/mms_style/font_color/green 255
241 vconftool set -t int db/private/msg-service/mms_style/font_color/blue 255
242 vconftool set -t int db/private/msg-service/mms_style/font_color/hue 255
243 vconftool set -t int db/private/msg-service/mms_style/bg_color/red 0
244 vconftool set -t int db/private/msg-service/mms_style/bg_color/green 0
245 vconftool set -t int db/private/msg-service/mms_style/bg_color/blue 0
246 vconftool set -t int db/private/msg-service/mms_style/bg_color/hue 255
247 vconftool set -t int db/private/msg-service/mms_style/page_dur 2
248 vconftool set -t int db/private/msg-service/mms_style/page_custom_dur 0
249 vconftool set -t int db/private/msg-service/mms_style/page_dur_manual 0
250
251 # Push Msg Options
252 vconftool set -t bool db/private/msg-service/push_msg/recv_option 1
253 vconftool set -t int db/private/msg-service/push_msg/service_load 1
254
255 # CB Msg Options
256 vconftool set -t bool db/private/msg-service/cb_msg/receive 1 -f
257 vconftool set -t int db/private/msg-service/cb_msg/max_sim_count 0
258 vconftool set -t int db/private/msg-service/cb_msg/channel_count 0
259 vconftool set -t bool db/private/msg-service/cb_msg/language/0 1 -f
260 vconftool set -t bool db/private/msg-service/cb_msg/language/1 0
261 vconftool set -t bool db/private/msg-service/cb_msg/language/2 0
262 vconftool set -t bool db/private/msg-service/cb_msg/language/3 0
263 vconftool set -t bool db/private/msg-service/cb_msg/language/4 0
264 vconftool set -t bool db/private/msg-service/cb_msg/language/5 0
265 vconftool set -t bool db/private/msg-service/cb_msg/language/6 0
266 vconftool set -t bool db/private/msg-service/cb_msg/language/7 0
267 vconftool set -t bool db/private/msg-service/cb_msg/language/8 0
268 vconftool set -t bool db/private/msg-service/cb_msg/language/9 0
269
270 # Voice Mail Options
271 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_number ""
272
273 # MMS Size Options
274 vconftool set -t int db/private/msg-service/size_opt/msg_size 300
275
276 # SIM message count
277 vconftool set -t int db/private/msg-service/sim_count/used_cnt 0
278 vconftool set -t int db/private/msg-service/sim_count/total_cnt 0
279
280 # SIM information
281 vconftool set -t int memory/private/msg-service/sim_changed 0 -i
282 vconftool set -t string memory/private/msg-service/sim_imsi "" -i
283 vconftool set -t bool memory/private/msg-service/national_sim 0 -i
284
285 %postun -p /sbin/ldconfig
286
287 %postun tools -p /sbin/ldconfig
288 %postun -n sms-plugin -p /sbin/ldconfig
289 %postun -n mms-plugin -p /sbin/ldconfig
290
291 %files
292 %defattr(-,root,root,-)
293 %dir /opt/data/msg-service
294 %{_libdir}/libmsg_plugin_manager.so
295 %{_libdir}/libmsg_mapi.so.*
296 %{_libdir}/libmsg_framework_handler.so
297 %{_libdir}/libmsg_transaction_manager.so
298 %{_libdir}/libmsg_utils.so
299 %{_libdir}/libmsg_transaction_proxy.so
300 %{_sysconfdir}/rc.d/init.d/msg-server
301 %{_sysconfdir}/rc.d/rc3.d/S70msg-server
302 %{_sysconfdir}/rc.d/rc5.d/S70msg-server
303
304 %files devel
305 %defattr(-,root,root,-)
306 %{_libdir}/libmsg_mapi.so
307 %{_libdir}/pkgconfig/msg-service.pc
308 %{_includedir}/msg-service/*
309
310 %files tools
311 %defattr(-,root,root,-)
312 %{_bindir}/msg-helper
313 %{_bindir}/msg-server
314 %{_datadir}/media/Sherbet.wav
315 %attr(0644,root,root)/usr/share/msg-service/plugin.cfg
316
317 %files -n sms-plugin
318 %defattr(-,root,root,-)
319 %{_libdir}/libmsg_sms_plugin.so
320
321 %files -n mms-plugin
322 %defattr(-,root,root,-)
323 %{_libdir}/libmsg_mms_plugin.so
324 %{_libdir}/libmsg_mms_language_pack.so
325
326 %changelog
327 * Wed Aug 8 2012 KeeBum Kim <keebum.kim@samsung.com>
328 - Apply New TAPI.
329 - Modify transaction data size of sos recipient list.
330
331 * Tue Aug 7 2012 KeeBum Kim <keebum.kim@samsung.com>
332 - Fix contact sync defect.
333 - New MessageFW API.
334
335 * Fri Jul 27 2012 KeeBum Kim <keebum.kim@samsung.com>
336 - Change devman_haptic.h to devman_managed.h.
337 - Modify to set MSG_SERVER_READY before sim status check.
338 - Fix bug in sim message save related operations.
339 - Limit sim related APIs not to work on sim not available status.
340 - Modify indicator icon image path & related.
341
342 * Tue Jul 17 2012 KeeBum Kim <keebum.kim@samsung.com>
343 - Modify MAX_SEGMENT_NUM to 15.
344 - Modify MMplayer related to support interrupted event.
345 - Fix bug in storage change callback which could cause on submit request.
346
347 * Fri Jun 29 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
348 - Modify vconf key path for sos sending option.
349
350 * Mon Jun 18 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
351 - Storage change callback for scheduled message
352 - code chage to support glib2-2.32
353 - Apply Backup && Restore of Mms Type
354
355 * Fri Jun 15 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
356 - Update display time for scheduled message when it is sent.
357
358 * Thu Jun 14 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
359 - Comment the test app in CMakefile.
360 - Modify MMS BG color of vconf value.
361 - Bug fixed wrong query in MsgStoCheckReadReportIsSent
362 - Add '-i' option for vconf keys of memory type
363 - Add smsc vconf keys(default value).
364 - To avoid msg incoming sound and notification on SOS
365
366 * Fri Jun 8 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
367 - Add '-i' option for vconf keys of memory type.
368 - Add smsc vconf keys(default value).
369 - To avoid msg incoming sound and notification on SOS state.
370 - Change BGcolor to black && font colore to white.
371
372 * Wed May 31 2012 Keebum Kim <keebum.kim@samsung.com>
373 - Apply Mdm policy.
374 - SOS message.
375 - Fix horizontality development problem.
376 - Remove vconf key for new message count. (db/badge/com.samsung.message)
377 - Change vconf key path of "mms_send/msg_class" to private.
378
379 * Thu May 24 2012 Keebum Kim <keebum.kim@samsung.com>
380 - Add new MAPI.
381
382 * Fri May 18 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
383 - Modify to support new DRM service.
384 - Rename private vconf keys.
385 - Modify .postinst and .spec file to pre-install used vconf keys.
386 - Remove compile warnings.
387 - Fix bug in manual retrieve operation.
388
389 * Fri May 11 2012 Jaeyun Jeong <jyjeong@samsung.com>
390 - Fix DB conflict which cause db lock.
391 - Fix bug in Find My Mobile function.
392 - Add '*' and '#' symbol as valid number.
393
394 * Wed May 9 2012 Keebum Kim <keebum.kim@samsung.com>
395 - Change mobile tracker related vconf key define values.
396 - Apply MDM policy for allowing text messaging.
397 - Fix bug for getting thumbnail path.
398 - Enable functionality of scheduled message.
399 - Change alarm setting of scheduled message from volatile type to non-volatile.
400 - Fix error in search query.
401
402 * Thu May 3 2012 Keebum Kim <keebum.kim@samsung.com>
403 - Change some thread list related APIs to support DB change.
404 - DB change to support multiple recipient.
405
406 * Thu Apr 19 2012 Keebum Kim <keebum.kim@samsung.com>
407 - Modify to manage contact sync time by vconf.
408 - Use g_idle_add() routine for updating unread message count(vconf values).
409 - apply try{}catch{} code for handling unexpected exception to avoid thread terminating.
410 - Fix bug for allocated size of replacing string.
411 - Resolve search problem for special characters.
412 - add xmlFree.
413
414 * Tue Apr 10 2012 Keebum Kim <keebum.kim@samsung.com>
415 - Remove unused vconf keys.
416 - Initialize SMSC selected_index.
417 - Remove systemd related.
418
419 * Thu Apr 05 2012 Jaeyun Jeong <jyjeong@samsung.com>
420 - Add notification property(NOTIFICATION_PROP_DISPLAY_ONLY_SIMMODE)
421 - Fix S1-2397/2417/2418/2419.
422 - Remove sent status callback check during submit request.
423 - Modify offset and limit operation on search.
424 - Remove invalid folder and file.
425 - Change browser launching API from aul to service-capi.
426 - Remove unused file.
427 - Invalid type checking is fixed.
428
429 * Fri Mar 16 2012 Jaeyun Jeong <jyjeong@samsung.com>
430 - Add #include <sys/stat.h> to support chmod related defines.
431 - Fix DRM content issue(unregistered mo content)
432
433 * Wed Mar 14 2012 Jaeyun Jeong <jyjeong@samsung.com>
434 - Modify plugin configuration file location for FOTA.
435 - Remove the db query which create sample data.
436
437 * Wed Feb 29 2012 Jaeyun Jeong <jyjeong@samsung.com>
438 - Update msg-service.spec for OBS.
439 - Fix TC execute failure.
440 - Fix S1-1419(Removed mms raw file issue after rebooting)