Merge from private.
[platform/core/messaging/msg-service.git] / packaging / msg-service.spec
1 Name:           msg-service
2 Version:        0.9.2
3 Release:        1
4 License:        Samsung
5 Summary:        Messaging Framework Library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8
9 Requires(post): /usr/bin/sqlite3
10 Requires(post): /usr/bin/vconftool
11 Requires(post): /sbin/ldconfig
12 Requires(postun): /sbin/ldconfig
13 Requires(post): systemd
14 Requires(postun): systemd
15 BuildRequires: cmake
16 BuildRequires: pkgconfig(alarm-service)
17 BuildRequires: pkgconfig(aul)
18 BuildRequires: pkgconfig(capi-appfw-application)
19 BuildRequires: pkgconfig(contacts-service)
20 BuildRequires: pkgconfig(db-util)
21 BuildRequires: pkgconfig(devman_haptic)
22 BuildRequires: pkgconfig(dlog)
23 BuildRequires: pkgconfig(drm-client)
24 BuildRequires: pkgconfig(glib-2.0)
25 BuildRequires: pkgconfig(libcurl)
26 BuildRequires: pkgconfig(libsystemd-daemon)
27 BuildRequires: pkgconfig(libxml-2.0)
28 BuildRequires: pkgconfig(libwbxml2)
29 BuildRequires: pkgconfig(media-thumbnail)
30 BuildRequires: pkgconfig(mm-fileinfo)
31 BuildRequires: pkgconfig(mm-player)
32 BuildRequires: pkgconfig(mm-session)
33 BuildRequires: pkgconfig(network)
34 BuildRequires: pkgconfig(notification)
35 BuildRequires: pkgconfig(pmapi)
36 BuildRequires: pkgconfig(mmutil-imgp)
37 BuildRequires: pkgconfig(mmutil-jpeg)
38 BuildRequires: pkgconfig(security-server)
39 BuildRequires: pkgconfig(sensor)
40 BuildRequires: pkgconfig(svi)
41 BuildRequires: pkgconfig(tapi)
42 BuildRequires: pkgconfig(vconf)
43
44 %description
45 Description: Messaging Framework Library
46
47
48 %package devel
49 License:        Flora License v1.0
50 Summary:        Messaging Framework Library (development)
51 Requires:       %{name} = %{version}-%{release}
52 Group:          Development/Libraries
53
54 %description devel
55 Description: Messaging Framework Library (development)
56
57
58 %package tools
59 License:        Flora License v1.0
60 Summary:        Messaging server application
61 Requires:       %{name} = %{version}-%{release}
62 Group:          TO_BU / FILL_IN
63 Requires(post): /usr/bin/sqlite3
64 Requires(post): /usr/bin/vconftool
65 Requires(post): /sbin/ldconfig
66 Requires(postun): /sbin/ldconfig
67
68 %description tools
69 Description:  Messaging server application
70
71
72 %package -n sms-plugin
73 License:        Flora License v1.0
74 Summary:        SMS plugin library
75 Requires:       %{name} = %{version}-%{release}
76 Group:          System/Libraries
77 Requires(post): /sbin/ldconfig
78 Requires(postun): /sbin/ldconfig
79
80 %description -n sms-plugin
81 Description: SMS plugin library
82
83 %package -n mms-plugin
84 License:        Flora License v1.0
85 Summary:        MMS plugin library
86 Requires:       %{name} = %{version}-%{release}
87 Group:          System/Libraries
88 Requires(post): /sbin/ldconfig
89 Requires(postun): /sbin/ldconfig
90
91 %description -n mms-plugin
92 Description: MMS plugin library
93
94 %prep
95 %setup -q
96
97
98 %build
99 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
100 make %{?jobs:-j%jobs}
101
102 %install
103 rm -rf %{buildroot}
104 mkdir -p %{buildroot}/usr/share/license
105
106 %make_install
107
108 mkdir -p %{buildroot}%{_libdir}/systemd/user/tizen-middleware.target.wants
109 ln -s %{_libdir}/systemd/user/msg-service.service %{buildroot}%{_libdir}/systemd/user/tizen-middleware.target.wants/msg-service.service
110
111 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
112 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70msg-server
113 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
114 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70msg-server
115
116 mkdir -p %{buildroot}/opt/usr/data/msg-service
117
118 %post tools -p /sbin/ldconfig
119 %post -n sms-plugin -p /sbin/ldconfig
120 %post -n mms-plugin -p /sbin/ldconfig
121
122 %post
123 /sbin/ldconfig
124
125 if [ ! -f /opt/usr/dbspace/.msg_service.db ]
126 then
127     mkdir -p %{buildroot}/opt/usr/dbspace/
128     sqlite3 /opt/usr/dbspace/.msg_service.db "PRAGMA journal_mode = PERSIST;
129
130     CREATE TABLE MSG_CONVERSATION_TABLE ( CONV_ID INTEGER NOT NULL , UNREAD_CNT INTEGER DEFAULT 0 , SMS_CNT INTEGER DEFAULT 0 , MMS_CNT INTEGER DEFAULT 0 , MAIN_TYPE INTEGER NOT NULL , SUB_TYPE INTEGER NOT NULL , MSG_DIRECTION INTEGER NOT NULL , DISPLAY_TIME INTEGER , DISPLAY_NAME TEXT , MSG_TEXT TEXT );
131     CREATE TABLE MSG_ADDRESS_TABLE ( ADDRESS_ID INTEGER PRIMARY KEY , CONV_ID INTEGER  NOT NULL , ADDRESS_TYPE INTEGER , RECIPIENT_TYPE INTEGER , ADDRESS_VAL TEXT , CONTACT_ID INTEGER , DISPLAY_NAME TEXT , FIRST_NAME TEXT , LAST_NAME TEXT , IMAGE_PATH TEXT , SYNC_TIME DATETIME , FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) );
132     CREATE TABLE MSG_FOLDER_TABLE ( FOLDER_ID INTEGER PRIMARY KEY , FOLDER_NAME TEXT NOT NULL , FOLDER_TYPE INTEGER DEFAULT 0 );
133     CREATE TABLE MSG_MESSAGE_TABLE ( MSG_ID INTEGER PRIMARY KEY , CONV_ID INTEGER NOT NULL , FOLDER_ID INTEGER NOT NULL , STORAGE_ID INTEGER NOT NULL , MAIN_TYPE INTEGER NOT NULL , SUB_TYPE INTEGER NOT NULL , DISPLAY_TIME DATETIME , DATA_SIZE INTEGER DEFAULT 0 , NETWORK_STATUS INTEGER DEFAULT 0 , READ_STATUS INTEGER DEFAULT 0 , PROTECTED INTEGER DEFAULT 0 , PRIORITY INTEGER DEFAULT 0 , MSG_DIRECTION INTEGER NOT NULL , SCHEDULED_TIME DATETIME , BACKUP INTEGER DEFAULT 0 , SUBJECT TEXT , MSG_DATA TEXT , THUMB_PATH TEXT , MSG_TEXT TEXT , ATTACHMENT_COUNT INTEGER DEFAULT 0 , FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) , FOREIGN KEY (FOLDER_ID) REFERENCES MSG_FOLDER_TABLE (FOLDER_ID) );
134     CREATE TABLE MSG_SIM_TABLE ( MSG_ID INTEGER , SIM_ID INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
135     CREATE TABLE MSG_PUSH_TABLE ( MSG_ID INTEGER , ACTION INTEGER , CREATED INTEGER , EXPIRES INTEGER , ID TEXT , HREF TEXT , CONTENT TEXT , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
136     CREATE TABLE MSG_CBMSG_TABLE ( MSG_ID INTEGER , CB_MSG_ID INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
137     CREATE TABLE MSG_SYNCML_TABLE ( MSG_ID INTEGER , EXT_ID INTEGER NOT NULL , PINCODE INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
138     CREATE TABLE MSG_SMS_SENDOPT_TABLE ( MSG_ID INTEGER , DELREP_REQ INTEGER NOT NULL , KEEP_COPY INTEGER NOT NULL , REPLY_PATH INTEGER NOT NULL , FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
139     CREATE TABLE MSG_FILTER_TABLE ( FILTER_ID INTEGER PRIMARY KEY , FILTER_TYPE INTEGER NOT NULL , FILTER_VALUE TEXT NOT NULL , FILTER_ACTIVE INTEGER DEFAULT 0);
140     CREATE TABLE MSG_MMS_MESSAGE_TABLE ( MSG_ID INTEGER , TRANSACTION_ID TEXT , MESSAGE_ID TEXT , FWD_MESSAGE_ID TEXT , CONTENTS_LOCATION TEXT , FILE_PATH TEXT , VERSION INTEGER NOT NULL , DATA_TYPE INTEGER DEFAULT -1 , DATE DATETIME , HIDE_ADDRESS INTEGER DEFAULT 0 , ASK_DELIVERY_REPORT INTEGER DEFAULT 0 , REPORT_ALLOWED INTEGER DEFAULT 0 , READ_REPORT_ALLOWED_TYPE INTEGER DEFAULT 0 , ASK_READ_REPLY INTEGER DEFAULT 0 , READ INTEGER DEFAULT 0 , READ_REPORT_SEND_STATUS INTEGER DEFAULT 0 , READ_REPORT_SENT INTEGER DEFAULT 0 , PRIORITY INTEGER DEFAULT 0 , KEEP_COPY INTEGER DEFAULT 0 , MSG_SIZE INTEGER NOT NULL , MSG_CLASS INTEGER DEFAULT -1 , EXPIRY_TIME DATETIME , CUSTOM_DELIVERY_TIME INTEGER DEFAULT 0 , DELIVERY_TIME DATETIME , MSG_STATUS INTEGER DEFAULT -1 , FOREIGN KEY (MSG_ID) REFERENCES MSG_MESSAGE_TABLE (MSG_ID) );
141     CREATE TABLE MSG_MMS_PREVIEW_INFO_TABLE ( MSG_ID INTEGER, TYPE INTEGER, VALUE TEXT, COUNT INTEGER, PRIMARY KEY (MSG_ID, TYPE)  ON CONFLICT REPLACE FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) ON DELETE CASCADE);
142     CREATE TABLE MSG_REPORT_TABLE ( MSG_ID INTEGER , ADDRESS_VAL TEXT , STATUS_TYPE INTEGER , STATUS INTEGER DEFAULT 0 , TIME DATETIME);
143     CREATE TABLE MSG_PUSHCFG_TABLE ( PUSH_ID INTEGER , CONTENT_TYPE TEXT, APP_ID TEXT, PKG_NAME TEXT, LAUNCH INTEGER, APPCODE INTEGER, SECURE INTEGER);
144
145     CREATE INDEX MSG_CONVERSATION_INDEX ON MSG_CONVERSATION_TABLE(CONV_ID);
146     CREATE INDEX MSG_FOLDER_INDEX ON MSG_FOLDER_TABLE(FOLDER_ID);
147     CREATE INDEX MSG_MESSAGE_INDEX ON MSG_MESSAGE_TABLE(MSG_ID, CONV_ID, FOLDER_ID);
148
149     INSERT INTO MSG_FOLDER_TABLE VALUES (1, 'INBOX', 1);
150     INSERT INTO MSG_FOLDER_TABLE VALUES (2, 'OUTBOX', 2);
151     INSERT INTO MSG_FOLDER_TABLE VALUES (3, 'SENTBOX', 2);
152     INSERT INTO MSG_FOLDER_TABLE VALUES (4, 'DRAFT', 3);
153     INSERT INTO MSG_FOLDER_TABLE VALUES (5, 'CBMSGBOX', 1);
154     INSERT INTO MSG_FOLDER_TABLE VALUES (6, 'SPAMBOX', 4);
155     INSERT INTO MSG_FOLDER_TABLE VALUES (7, 'SMS TEMPLATE', 5);
156     INSERT INTO MSG_FOLDER_TABLE VALUES (8, 'MMS TEMPLATE', 5);
157
158     INSERT INTO MSG_PUSHCFG_TABLE VALUES (1, 'text/vnd.wap.si', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 1, 0);
159     INSERT INTO MSG_PUSHCFG_TABLE VALUES (2, 'application/vnd.wap.sic', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 2, 0);
160     INSERT INTO MSG_PUSHCFG_TABLE VALUES (3, 'text/vnd.wap.sl', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 3, 0);
161         INSERT INTO MSG_PUSHCFG_TABLE VALUES (4, 'application/vnd.wap.slc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 4, 0);
162     INSERT INTO MSG_PUSHCFG_TABLE VALUES (5, 'text/vnd.wap.co', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 5, 0);
163
164     INSERT INTO MSG_PUSHCFG_TABLE VALUES (6, 'application/vnd.wap.coc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 6, 0);
165     INSERT INTO MSG_PUSHCFG_TABLE VALUES (7, 'application/vnd.wap.mms-message', 'X-Wap-Application-Id: x-wap-application:mms.ua', '', 0, 7, 0);
166     INSERT INTO MSG_PUSHCFG_TABLE VALUES (8, 'application/vnd.wap.sia', 'X-Wap-Application-Id: x-wap-application:push.sia', '', 0, 8, 0);
167     INSERT INTO MSG_PUSHCFG_TABLE VALUES (9, 'application/vnd.syncml.dm+wbxml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 9, 0);
168     INSERT INTO MSG_PUSHCFG_TABLE VALUES (10, 'application/vnd.syncml.dm+xml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 10, 0);
169
170     INSERT INTO MSG_PUSHCFG_TABLE VALUES (11, 'application/vnd.syncml.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 11, 0);
171     INSERT INTO MSG_PUSHCFG_TABLE VALUES (12, 'application/vnd.syncml.ds.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.ds', '', 0, 12, 0);
172     INSERT INTO MSG_PUSHCFG_TABLE VALUES (13, 'application/vnd.syncml+wbxml', 'X-Wap-Application-Id:x-wap-application:push.syncml', '', 0, 13, 0);
173     INSERT INTO MSG_PUSHCFG_TABLE VALUES (14, 'application/vnd.wap.locc+wbxml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 14, 0);
174     INSERT INTO MSG_PUSHCFG_TABLE VALUES (15, 'application/vnd.wap.loc+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 15, 0);
175
176     INSERT INTO MSG_PUSHCFG_TABLE VALUES (16, 'application/vnd.oma.dd+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 16, 0);
177     INSERT INTO MSG_PUSHCFG_TABLE VALUES (17, 'application/vnd.oma.drm.message', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 17, 0);
178     INSERT INTO MSG_PUSHCFG_TABLE VALUES (18, 'application/vnd.oma.drm.content', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 18, 0);
179     INSERT INTO MSG_PUSHCFG_TABLE VALUES (19, 'application/vnd.oma.drm.rights+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 19, 0);
180     INSERT INTO MSG_PUSHCFG_TABLE VALUES (20, 'application/vnd.oma.drm.rights+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 20, 0);
181
182     INSERT INTO MSG_PUSHCFG_TABLE VALUES (21, 'application/vnd.oma.drm.ro+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 21, 0);
183     INSERT INTO MSG_PUSHCFG_TABLE VALUES (22, 'application/vnd.oma.drm.roap-pdu+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 22, 0);
184     INSERT INTO MSG_PUSHCFG_TABLE VALUES (23, 'application/vnd.oma.drm.roap-trigger+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 23, 0);
185     INSERT INTO MSG_PUSHCFG_TABLE VALUES (24, 'application/vnd.oma.drm.roap-trigger+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 24, 0);
186         INSERT INTO MSG_PUSHCFG_TABLE VALUES (25, 'text/vnd.wap.connectivity-xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 26, 0);
187
188         INSERT INTO MSG_PUSHCFG_TABLE VALUES (26, 'application/vnd.wap.connectivity-wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 27, 0);
189         INSERT INTO MSG_PUSHCFG_TABLE VALUES (27, 'application/x-wap-prov.browser-settings', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 28, 0);
190         INSERT INTO MSG_PUSHCFG_TABLE VALUES (28, 'application/x-wap-prov.browser-bookmarks', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 29, 0);
191         INSERT INTO MSG_PUSHCFG_TABLE VALUES (29, 'application/x-wap-prov.syncset+xml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 30, 0);
192         INSERT INTO MSG_PUSHCFG_TABLE VALUES (30, 'application/x-wap-prov.syncset+wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 31, 0);
193
194         INSERT INTO MSG_PUSHCFG_TABLE VALUES (31, 'text/vnd.wap.emn+xml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 32, 0);
195         INSERT INTO MSG_PUSHCFG_TABLE VALUES (32, 'application/vnd.wap.emn+wbxml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 33, 0);
196         INSERT INTO MSG_PUSHCFG_TABLE VALUES (33, 'application/vnd.wv.csp.cir', 'X-Wap-Application-Id: x-wap-application:wv.ua', '', 0, 34, 0);
197         INSERT INTO MSG_PUSHCFG_TABLE VALUES (34, 'application/vnd.omaloc-supl-init', 'X-Wap-Application-Id: x-oma-application:ulp.ua', '', 0, 44, 0);
198         INSERT INTO MSG_PUSHCFG_TABLE VALUES (35, 'application/vnd.wap.emn+wbxml', 'X-oma-docomo:xmd.mail.ua', '', 0, 45, 1);"
199 fi
200
201 chown :6011 /opt/usr/dbspace/.msg_service.db
202 chown :6011 /opt/usr/dbspace/.msg_service.db-journal
203 chmod 660 /opt/usr/dbspace/.msg_service.db
204 chmod 660 /opt/usr/dbspace/.msg_service.db-journal
205 mkdir -p /opt/usr/data/msg-service
206 chgrp db_msg_service /opt/usr/data/msg-service
207
208 ########## Setting Config Value (Internal keys) ##########
209 # Message Server Status
210 vconftool set -t bool memory/msg/ready 0 -i -g 5000
211
212 # SMS Send Options
213 vconftool set -t int db/msg/network_mode 2
214
215 # New Message Count
216 vconftool set -t int db/msg/recv_sms 0
217 vconftool set -t int db/msg/recv_mms 0
218
219 ########## Setting Config Value (Private keys) ##########
220 # General Options
221 vconftool set -t bool db/private/msg-service/general/keep_copy 1
222 vconftool set -t bool db/private/msg-service/general/auto_erase 0
223 vconftool set -t bool db/private/msg-service/general/block_msg 1
224 vconftool set -t int db/private/msg-service/general/contact_sync_time 0
225
226 # SMS Send Options
227 vconftool set -t int db/private/msg-service/sms_send/dcs 3
228 vconftool set -t bool db/private/msg-service/sms_send/reply_path 0
229 vconftool set -t bool db/private/msg-service/sms_send/delivery_report 0
230 vconftool set -t int db/private/msg-service/sms_send/save_storage 1
231
232 # SMSC
233 vconftool set -t int db/private/msg-service/smsc/total_count 1
234 vconftool set -t int db/private/msg-service/smsc/selected 0
235
236 vconftool set -t int db/private/msg-service/smsc/pid/0 1
237 vconftool set -t int db/private/msg-service/smsc/val_period/0 255
238 vconftool set -t string db/private/msg-service/smsc/name/0 ""
239 vconftool set -t int db/private/msg-service/smsc/ton/0 1
240 vconftool set -t int db/private/msg-service/smsc/npi/0 1
241 vconftool set -t string db/private/msg-service/smsc/address/0 ""
242
243 vconftool set -t int db/private/msg-service/smsc/pid/1 0
244 vconftool set -t int db/private/msg-service/smsc/val_period/1 0
245 vconftool set -t string db/private/msg-service/smsc/name/1 ""
246 vconftool set -t int db/private/msg-service/smsc/ton/1 0
247 vconftool set -t int db/private/msg-service/smsc/npi/1 0
248 vconftool set -t string db/private/msg-service/smsc/address/1 ""
249
250 vconftool set -t int db/private/msg-service/smsc/pid/2 0
251 vconftool set -t int db/private/msg-service/smsc/val_period/2 0
252 vconftool set -t string db/private/msg-service/smsc/name/2 ""
253 vconftool set -t int db/private/msg-service/smsc/ton/2 0
254 vconftool set -t int db/private/msg-service/smsc/npi/2 0
255 vconftool set -t string db/private/msg-service/smsc/address/2 ""
256
257 # MMS Send Options
258 vconftool set -t int db/private/msg-service/mms_send/msg_class 0
259 vconftool set -t int db/private/msg-service/mms_send/priority 1
260 vconftool set -t int db/private/msg-service/mms_send/expiry_time 0
261 vconftool set -t int db/private/msg-service/mms_send/custom_delivery 0
262 vconftool set -t bool db/private/msg-service/mms_send/sender_visibility 0
263 vconftool set -t bool db/private/msg-service/mms_send/delivery_report 1
264 vconftool set -t bool db/private/msg-service/mms_send/read_reply 1
265 vconftool set -t bool db/private/msg-service/mms_send/keep_copy 0
266 vconftool set -t bool db/private/msg-service/mms_send/body_replying 0
267 vconftool set -t bool db/private/msg-service/mms_send/hide_recipients 0
268 vconftool set -t bool db/private/msg-service/mms_send/report_allowed 1
269 vconftool set -t int db/private/msg-service/mms_send/reply_charging 0
270 vconftool set -t int db/private/msg-service/mms_send/reply_charging_deadline 0
271 vconftool set -t int db/private/msg-service/mms_send/reply_charging_size 0
272 vconftool set -t int db/private/msg-service/mms_send/delivery_time 0
273 vconftool set -t int db/private/msg-service/mms_send/creation_mode 2
274
275 # MMS Receive Options
276 vconftool set -t int db/private/msg-service/mms_recv/home_network 0
277 vconftool set -t int db/private/msg-service/mms_recv/abroad_network 0
278 vconftool set -t bool db/private/msg-service/mms_recv/read_receipt 1
279 vconftool set -t bool db/private/msg-service/mms_recv/delivery_receipt 1
280 vconftool set -t bool db/private/msg-service/mms_recv/reject_unknown 0
281 vconftool set -t bool db/private/msg-service/mms_recv/reject_advertisement 0
282
283 # MMS Receive Options
284 vconftool set -t int db/private/msg-service/mms_style/font_size 30
285 vconftool set -t bool db/private/msg-service/mms_style/font_style/bold 0
286 vconftool set -t bool db/private/msg-service/mms_style/font_style/italic 0
287 vconftool set -t bool db/private/msg-service/mms_style/font_style/underline 0
288 vconftool set -t int db/private/msg-service/mms_style/font_color/red 255
289 vconftool set -t int db/private/msg-service/mms_style/font_color/green 255
290 vconftool set -t int db/private/msg-service/mms_style/font_color/blue 255
291 vconftool set -t int db/private/msg-service/mms_style/font_color/hue 255
292 vconftool set -t int db/private/msg-service/mms_style/bg_color/red 0
293 vconftool set -t int db/private/msg-service/mms_style/bg_color/green 0
294 vconftool set -t int db/private/msg-service/mms_style/bg_color/blue 0
295 vconftool set -t int db/private/msg-service/mms_style/bg_color/hue 255
296 vconftool set -t int db/private/msg-service/mms_style/page_dur 2
297 vconftool set -t int db/private/msg-service/mms_style/page_custom_dur 0
298 vconftool set -t int db/private/msg-service/mms_style/page_dur_manual 0
299
300 # Push Msg Options
301 vconftool set -t bool db/private/msg-service/push_msg/recv_option 1
302 vconftool set -t int db/private/msg-service/push_msg/service_load 1
303
304 # CB Msg Options
305 vconftool set -t bool db/private/msg-service/cb_msg/receive 1 -f
306 vconftool set -t bool db/private/msg-service/cb_msg/save 1 -f
307 vconftool set -t int db/private/msg-service/cb_msg/max_sim_count 0
308 vconftool set -t int db/private/msg-service/cb_msg/channel_count 0
309 vconftool set -t bool db/private/msg-service/cb_msg/language/0 1 -f
310 vconftool set -t bool db/private/msg-service/cb_msg/language/1 0
311 vconftool set -t bool db/private/msg-service/cb_msg/language/2 0
312 vconftool set -t bool db/private/msg-service/cb_msg/language/3 0
313 vconftool set -t bool db/private/msg-service/cb_msg/language/4 0
314 vconftool set -t bool db/private/msg-service/cb_msg/language/5 0
315 vconftool set -t bool db/private/msg-service/cb_msg/language/6 0
316 vconftool set -t bool db/private/msg-service/cb_msg/language/7 0
317 vconftool set -t bool db/private/msg-service/cb_msg/language/8 0
318 vconftool set -t bool db/private/msg-service/cb_msg/language/9 0
319
320 # Voice Mail Options
321 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_number "5500" -f
322 vconftool set -t int db/private/msg-service/voice_mail/voice_mail_count 0
323
324 # MMS Size Options
325 vconftool set -t int db/private/msg-service/size_opt/msg_size 300
326
327 # SIM message count
328 vconftool set -t int db/private/msg-service/sim_count/used_cnt 0
329 vconftool set -t int db/private/msg-service/sim_count/total_cnt 0
330
331 # SIM information
332 vconftool set -t int memory/private/msg-service/sim_changed 0 -i
333 vconftool set -t string memory/private/msg-service/sim_imsi "" -i
334 vconftool set -t bool memory/private/msg-service/national_sim 0 -i
335
336 /sbin/ldconfig
337 /bin/systemctl daemon-reload
338 if [ "$1" = "1" ]; then
339     systemctl stop msg-service.service
340 fi
341
342 %postun -p /sbin/ldconfig
343
344 %postun tools -p /sbin/ldconfig
345 %postun -n sms-plugin -p /sbin/ldconfig
346 %postun -n mms-plugin -p /sbin/ldconfig
347
348 %files
349 %manifest msg-service.manifest
350 %defattr(-,root,root,-)
351 %dir %attr(775,root,db_msg_service) /opt/usr/data/msg-service
352 %{_libdir}/libmsg_plugin_manager.so
353 %{_libdir}/libmsg_mapi.so.*
354 %{_libdir}/libmsg_framework_handler.so
355 %{_libdir}/libmsg_transaction_manager.so
356 %{_libdir}/libmsg_utils.so
357 %{_libdir}/libmsg_transaction_proxy.so
358 /usr/share/license/msg-service/LICENSE
359
360 %files devel
361 %defattr(-,root,root,-)
362 %{_libdir}/libmsg_mapi.so
363 %{_libdir}/pkgconfig/msg-service.pc
364 %{_includedir}/msg-service/*
365
366 %files tools
367 %manifest msg-service-tools.manifest
368 %defattr(-,root,root,-)
369 %{_bindir}/msg-helper
370 %{_bindir}/msg-server
371 %{_datadir}/media/Sherbet.wav
372 %attr(0644,root,root)/usr/share/msg-service/plugin.cfg
373 %{_sysconfdir}/rc.d/init.d/msg-server
374 %{_sysconfdir}/rc.d/rc3.d/S70msg-server
375 %{_sysconfdir}/rc.d/rc5.d/S70msg-server
376 %{_libdir}/systemd/user/msg-service.service
377 %{_libdir}/systemd/user/tizen-middleware.target.wants/msg-service.service
378 /usr/share/license/msg-service/LICENSE
379
380 %files -n sms-plugin
381 %manifest sms-plugin.manifest
382 %defattr(-,root,root,-)
383 %{_libdir}/libmsg_sms_plugin.so
384 /usr/share/license/msg-service/LICENSE
385
386 %files -n mms-plugin
387 %manifest mms-plugin.manifest
388 %defattr(-,root,root,-)
389 %{_libdir}/libmsg_mms_plugin.so
390 %{_libdir}/libmsg_mms_language_pack.so
391 /usr/share/license/msg-service/LICENSE
392
393 %changelog
394 * Wed Oct 25 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
395 - New release version
396
397 * Wed Aug 8 2012 KeeBum Kim <keebum.kim@samsung.com>
398 - Apply New TAPI.
399 - Modify transaction data size of sos recipient list.
400
401 * Tue Aug 7 2012 KeeBum Kim <keebum.kim@samsung.com>
402 - Fix contact sync defect.
403 - New MessageFW API.
404
405 * Fri Jul 27 2012 KeeBum Kim <keebum.kim@samsung.com>
406 - Change devman_haptic.h to devman_managed.h.
407 - Modify to set MSG_SERVER_READY before sim status check.
408 - Fix bug in sim message save related operations.
409 - Limit sim related APIs not to work on sim not available status.
410 - Modify indicator icon image path & related.
411
412 * Tue Jul 17 2012 KeeBum Kim <keebum.kim@samsung.com>
413 - Modify MAX_SEGMENT_NUM to 15.
414 - Modify MMplayer related to support interrupted event.
415 - Fix bug in storage change callback which could cause on submit request.
416
417 * Fri Jun 29 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
418 - Modify vconf key path for sos sending option.
419
420 * Mon Jun 18 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
421 - Storage change callback for scheduled message
422 - code chage to support glib2-2.32
423 - Apply Backup && Restore of Mms Type
424
425 * Fri Jun 15 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
426 - Update display time for scheduled message when it is sent.
427
428 * Thu Jun 14 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
429 - Comment the test app in CMakefile.
430 - Modify MMS BG color of vconf value.
431 - Bug fixed wrong query in MsgStoCheckReadReportIsSent
432 - Add '-i' option for vconf keys of memory type
433 - Add smsc vconf keys(default value).
434 - To avoid msg incoming sound and notification on SOS
435
436 * Fri Jun 8 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
437 - Add '-i' option for vconf keys of memory type.
438 - Add smsc vconf keys(default value).
439 - To avoid msg incoming sound and notification on SOS state.
440 - Change BGcolor to black && font colore to white.
441
442 * Wed May 31 2012 Keebum Kim <keebum.kim@samsung.com>
443 - Apply Mdm policy.
444 - SOS message.
445 - Fix horizontality development problem.
446 - Remove vconf key for new message count. (db/badge/com.samsung.message)
447 - Change vconf key path of "mms_send/msg_class" to private.
448
449 * Thu May 24 2012 Keebum Kim <keebum.kim@samsung.com>
450 - Add new MAPI.
451
452 * Fri May 18 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
453 - Modify to support new DRM service.
454 - Rename private vconf keys.
455 - Modify .postinst and .spec file to pre-install used vconf keys.
456 - Remove compile warnings.
457 - Fix bug in manual retrieve operation.
458
459 * Fri May 11 2012 Jaeyun Jeong <jyjeong@samsung.com>
460 - Fix DB conflict which cause db lock.
461 - Fix bug in Find My Mobile function.
462 - Add '*' and '#' symbol as valid number.
463
464 * Wed May 9 2012 Keebum Kim <keebum.kim@samsung.com>
465 - Change mobile tracker related vconf key define values.
466 - Apply MDM policy for allowing text messaging.
467 - Fix bug for getting thumbnail path.
468 - Enable functionality of scheduled message.
469 - Change alarm setting of scheduled message from volatile type to non-volatile.
470 - Fix error in search query.
471
472 * Thu May 3 2012 Keebum Kim <keebum.kim@samsung.com>
473 - Change some thread list related APIs to support DB change.
474 - DB change to support multiple recipient.
475
476 * Thu Apr 19 2012 Keebum Kim <keebum.kim@samsung.com>
477 - Modify to manage contact sync time by vconf.
478 - Use g_idle_add() routine for updating unread message count(vconf values).
479 - apply try{}catch{} code for handling unexpected exception to avoid thread terminating.
480 - Fix bug for allocated size of replacing string.
481 - Resolve search problem for special characters.
482 - add xmlFree.
483
484 * Tue Apr 10 2012 Keebum Kim <keebum.kim@samsung.com>
485 - Remove unused vconf keys.
486 - Initialize SMSC selected_index.
487 - Remove systemd related.
488
489 * Thu Apr 05 2012 Jaeyun Jeong <jyjeong@samsung.com>
490 - Add notification property(NOTIFICATION_PROP_DISPLAY_ONLY_SIMMODE)
491 - Fix S1-2397/2417/2418/2419.
492 - Remove sent status callback check during submit request.
493 - Modify offset and limit operation on search.
494 - Remove invalid folder and file.
495 - Change browser launching API from aul to service-capi.
496 - Remove unused file.
497 - Invalid type checking is fixed.
498
499 * Fri Mar 16 2012 Jaeyun Jeong <jyjeong@samsung.com>
500 - Add #include <sys/stat.h> to support chmod related defines.
501 - Fix DRM content issue(unregistered mo content)
502
503 * Wed Mar 14 2012 Jaeyun Jeong <jyjeong@samsung.com>
504 - Modify plugin configuration file location for FOTA.
505 - Remove the db query which create sample data.
506
507 * Wed Feb 29 2012 Jaeyun Jeong <jyjeong@samsung.com>
508 - Update msg-service.spec for OBS.
509 - Fix TC execute failure.
510 - Fix S1-1419(Removed mms raw file issue after rebooting)