update tizen source
[framework/messaging/msg-service.git] / packaging / msg-service.spec
1 Name:           msg-service
2 Version:        0.8.7
3 Release:        5
4 License:        Samsung Proprietary
5 Summary:        Messaging Framework Library 
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8
9 Requires(post): /usr/bin/sqlite3
10 Requires(post): /usr/bin/vconftool
11 Requires(post): /sbin/ldconfig
12 Requires(postun): /sbin/ldconfig
13 BuildRequires: cmake
14 BuildRequires: pkgconfig(alarm-service)
15 BuildRequires: pkgconfig(contacts-service)
16 BuildRequires: pkgconfig(db-util)
17 BuildRequires: pkgconfig(devman_haptic)
18 BuildRequires: pkgconfig(dlog)
19 BuildRequires: pkgconfig(drm-service)
20 BuildRequires: pkgconfig(glib-2.0)
21 BuildRequires: pkgconfig(libcurl)
22 BuildRequires: pkgconfig(libxml-2.0)
23 BuildRequires: pkgconfig(libwbxml2)
24 BuildRequires: pkgconfig(media-thumbnail)
25 BuildRequires: pkgconfig(mm-fileinfo)
26 BuildRequires: pkgconfig(mm-player)
27 BuildRequires: pkgconfig(mm-session)
28 BuildRequires: pkgconfig(network)
29 BuildRequires: pkgconfig(notification)
30 BuildRequires: pkgconfig(pmapi)
31 BuildRequires: pkgconfig(mmutil-imgp)
32 BuildRequires: pkgconfig(mmutil-jpeg)
33 BuildRequires: pkgconfig(security-server)
34 BuildRequires: pkgconfig(sensor)
35 BuildRequires: pkgconfig(svi)
36 BuildRequires: pkgconfig(tapi)
37 BuildRequires: pkgconfig(vconf)
38 BuildRequires: pkgconfig(capi-appfw-application)
39
40 %description 
41 Description: Messaging Framework Library 
42
43
44 %package devel
45 License:        Samsung Proprietary
46 Summary:        Messaging Framework Library (development)
47 Requires:       %{name} = %{version}-%{release}
48 Group:          Development/Libraries
49
50 %description devel
51 Description: Messaging Framework Library (development)
52
53
54 %package tools
55 License:        Samsung Proprietary
56 Summary:        Messaging server application
57 Requires:       %{name} = %{version}-%{release}
58 Group:          TO_BU / FILL_IN
59 Requires(post): /usr/bin/sqlite3
60 Requires(post): /usr/bin/vconftool
61 Requires(post): /sbin/ldconfig
62 Requires(postun): /sbin/ldconfig
63
64 %description tools
65 Description:  Messaging server application
66
67
68 %package -n sms-plugin
69 License:        Samsung Proprietary
70 Summary:        SMS plugin library 
71 Requires:       %{name} = %{version}-%{release}
72 Group:          System/Libraries
73 Requires(post): /sbin/ldconfig
74 Requires(postun): /sbin/ldconfig
75
76 %description -n sms-plugin
77 Description: SMS plugin library  
78
79 %package -n mms-plugin
80 License:        Samsung Proprietary
81 Summary:        MMS plugin library 
82 Requires:       %{name} = %{version}-%{release}
83 Group:          System/Libraries
84 Requires(post): /sbin/ldconfig
85 Requires(postun): /sbin/ldconfig
86
87 %description -n mms-plugin
88 Description: MMS plugin library  
89
90 %prep
91 %setup -q
92
93
94 %build
95 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
96 make %{?jobs:-j%jobs}
97
98 %install
99
100 rm -rf %{buildroot}
101 %make_install
102
103 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
104 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70msg-server
105 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
106 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70msg-server
107
108
109
110 mkdir -p %{buildroot}/opt/data/msg-service
111
112 %post tools -p /sbin/ldconfig
113 %post -n sms-plugin -p /sbin/ldconfig
114 %post -n mms-plugin -p /sbin/ldconfig
115
116 %post 
117 /sbin/ldconfig
118
119 if [ ! -f /opt/dbspace/.msg_service.db ]
120 then
121         sqlite3 /opt/dbspace/.msg_service.db "PRAGMA journal_mode = PERSIST;
122
123         CREATE TABLE MSG_ADDRESS_TABLE(ADDRESS_ID INTEGER PRIMARY KEY, ADDRESS_TYPE INTEGER, RECIPIENT_TYPE INTEGER, ADDRESS_VAL TEXT, CONTACT_ID INTEGER, DISPLAY_NAME TEXT, FIRST_NAME TEXT, LAST_NAME TEXT, IMAGE_PATH TEXT, SYNC_TIME DATETIME, UNREAD_CNT INTEGER DEFAULT 0, SMS_CNT INTEGER DEFAULT 0, MMS_CNT INTEGER DEFAULT 0, MAIN_TYPE INTEGER NOT NULL, SUB_TYPE INTEGER NOT NULL, MSG_DIRECTION INTEGER NOT NULL, MSG_TIME DATETIME, MSG_TEXT TEXT);
124         CREATE TABLE MSG_FOLDER_TABLE(FOLDER_ID INTEGER PRIMARY KEY, FOLDER_NAME TEXT NOT NULL, FOLDER_TYPE INTEGER DEFAULT 0);
125         CREATE TABLE MSG_MESSAGE_TABLE(MSG_ID INTEGER PRIMARY KEY, ADDRESS_ID INTEGER, FOLDER_ID INTEGER, REFERENCE_ID INTEGER, STORAGE_ID INTEGER NOT NULL, MAIN_TYPE INTEGER NOT NULL, SUB_TYPE INTEGER NOT NULL, DISPLAY_TIME DATETIME, DATA_SIZE INTEGER DEFAULT 0, NETWORK_STATUS INTEGER DEFAULT 0, READ_STATUS INTEGER DEFAULT 0, PROTECTED INTEGER DEFAULT 0, PRIORITY INTEGER DEFAULT 0, MSG_DIRECTION INTEGER NOT NULL, SCHEDULED_TIME DATETIME, BACKUP INTEGER DEFAULT 0, SUBJECT TEXT, MSG_DATA TEXT, THUMB_PATH TEXT, MSG_TEXT TEXT, DELIVERY_REPORT_STATUS INTEGER DEFAULT 0, DELIVERY_REPORT_TIME DATETIME, READ_REPORT_STATUS INTEGER DEFAULT 0, READ_REPORT_TIME DATETIME, ATTACHMENT_COUNT INTEGER DEFAULT 0, FOREIGN KEY(ADDRESS_ID) REFERENCES MSG_ADDRESS_TABLE(ADDRESS_ID), FOREIGN KEY(FOLDER_ID) REFERENCES MSG_FOLDER_TABLE(FOLDER_ID));
126         CREATE TABLE MSG_SIM_TABLE(MSG_ID INTEGER, SIM_ID INTEGER NOT NULL, FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID));
127         CREATE TABLE MSG_PUSH_TABLE(MSG_ID INTEGER, ACTION INTEGER, CREATED INTEGER, EXPIRES INTEGER, ID TEXT, HREF TEXT, CONTENT TEXT, FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID));
128         CREATE TABLE MSG_CBMSG_TABLE(MSG_ID INTEGER, CB_MSG_ID INTEGER NOT NULL, FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID));
129         CREATE TABLE MSG_SYNCML_TABLE(MSG_ID INTEGER, EXT_ID INTEGER NOT NULL, PINCODE INTEGER NOT NULL, FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID));
130         CREATE TABLE MSG_SCHEDULED_TABLE(MSG_ID INTEGER, ALARM_ID INTEGER NOT NULL, LISTENER_FD INTEGER NOT NULL, FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID));
131         CREATE TABLE MSG_SMS_SENDOPT_TABLE(MSG_ID INTEGER, DELREP_REQ INTEGER NOT NULL, KEEP_COPY INTEGER NOT NULL, REPLY_PATH INTEGER NOT NULL, FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID));
132         CREATE TABLE MSG_FILTER_TABLE(FILTER_ID INTEGER PRIMARY KEY, FILTER_TYPE INTEGER NOT NULL, FILTER_VALUE TEXT NOT NULL);
133         CREATE TABLE MSG_MMS_MESSAGE_TABLE(REFERENCE_ID INTEGER, TRANSACTION_ID TEXT, MESSAGE_ID TEXT, FWD_MESSAGE_ID TEXT, CONTENTS_LOCATION TEXT, FILE_PATH TEXT, FOREIGN KEY(REFERENCE_ID) REFERENCES MSG_MESSAGE_TABLE(REFERENCE_ID));
134         CREATE TABLE MSG_MMS_ATTR_TABLE(REFERENCE_ID INTEGER, VERSION INTEGER NOT NULL, DATA_TYPE INTEGER DEFAULT -1, DATE DATETIME, HIDE_ADDRESS INTEGER DEFAULT 0, ASK_DELIVERY_REPORT INTEGER DEFAULT 0, REPORT_ALLOWED INTEGER DEFAULT 0, READ_REPORT_ALLOWED_TYPE INTEGER DEFAULT 0, ASK_READ_REPLY INTEGER DEFAULT 0, READ INTEGER DEFAULT 0, READ_REPORT_SEND_STATUS INTEGER DEFAULT 0, READ_REPORT_SENT INTEGER DEFAULT 0, PRIORITY INTEGER DEFAULT 0, KEEP_COPY INTEGER DEFAULT 0, MSG_SIZE INTEGER NOT NULL, MSG_CLASS INTEGER DEFAULT -1, EXPIRY_TIME DATETIME, CUSTOM_DELIVERY_TIME INTEGER DEFAULT 0, DELIVERY_TIME DATETIME, MSG_STATUS INTEGER DEFAULT -1, FOREIGN KEY(REFERENCE_ID) REFERENCES MSG_MESSAGE_TABLE(REFERENCE_ID));
135
136         CREATE INDEX MSG_ADDRESS_INDEX ON MSG_ADDRESS_TABLE(ADDRESS_ID);
137         CREATE INDEX MSG_FOLDER_INDEX ON MSG_FOLDER_TABLE(FOLDER_ID);
138         CREATE INDEX MSG_MESSAGE_INDEX ON MSG_MESSAGE_TABLE(MSG_ID, ADDRESS_ID, FOLDER_ID);
139
140         INSERT INTO MSG_FOLDER_TABLE VALUES (1, 'INBOX', 1);
141         INSERT INTO MSG_FOLDER_TABLE VALUES (2, 'OUTBOX', 2);
142         INSERT INTO MSG_FOLDER_TABLE VALUES (3, 'SENTBOX', 2);
143         INSERT INTO MSG_FOLDER_TABLE VALUES (4, 'DRAFT', 3);
144         INSERT INTO MSG_FOLDER_TABLE VALUES (5, 'CBMSGBOX', 1);
145         INSERT INTO MSG_FOLDER_TABLE VALUES (6, 'SPAMBOX', 4);
146         INSERT INTO MSG_FOLDER_TABLE VALUES (7, 'SMS TEMPLATE', 5);
147         INSERT INTO MSG_FOLDER_TABLE VALUES (8, 'MMS TEMPLATE', 5);
148
149         INSERT INTO MSG_ADDRESS_TABLE VALUES (0, 0, 0, '', 0, '', '', '', '', 0, 0, 0, 0, 0, 0, 0, 0, '');"
150 fi
151
152 chown :6011 /opt/dbspace/.msg_service.db
153 chown :6011 /opt/dbspace/.msg_service.db-journal
154
155
156 chmod 660 /opt/dbspace/.msg_service.db
157 chmod 660 /opt/dbspace/.msg_service.db-journal
158
159
160 ########## Setting Config Value ##########
161 # General Options
162 vconftool set -t bool db/msg/general/keep_copy 1
163 vconftool set -t int db/msg/general/alert_tone 0
164 vconftool set -t bool db/msg/general/auto_erase 0
165 vconftool set -t bool db/msg/general/block_msg 0
166
167 # SMS Send Options
168 vconftool set -t int db/msg/sms_send/dcs 3
169 vconftool set -t int db/msg/network_mode 2
170 vconftool set -t bool db/msg/sms_send/reply_path 0
171 vconftool set -t bool db/msg/sms_send/delivery_report 0
172 vconftool set -t int db/msg/sms_send/save_storage 1
173
174 # MMS Send Options
175 vconftool set -t int db/msg/mms_send/msg_class 0
176 vconftool set -t int db/msg/mms_send/priority 1
177 vconftool set -t int db/msg/mms_send/expiry_time 0
178 vconftool set -t int db/msg/mms_send/custom_delivery 0
179 vconftool set -t bool db/msg/mms_send/sender_visibility 0
180 vconftool set -t bool db/msg/mms_send/delivery_report 1
181 vconftool set -t bool db/msg/mms_send/read_reply 1
182 vconftool set -t bool db/msg/mms_send/keep_copy 0
183 vconftool set -t bool db/msg/mms_send/body_replying 0
184 vconftool set -t bool db/msg/mms_send/hide_recipients 0
185 vconftool set -t bool db/msg/mms_send/report_allowed 1
186 vconftool set -t int db/msg/mms_send/reply_charging 0
187 vconftool set -t int db/msg/mms_send/reply_charging_deadline 0
188 vconftool set -t int db/msg/mms_send/reply_charging_size 0
189 vconftool set -t int db/msg/mms_send/delivery_time 0
190 vconftool set -t int db/msg/mms_send/creation_mode 2
191
192 # MMS Receive Options
193 vconftool set -t int db/msg/mms_recv/home_network 0
194 vconftool set -t int db/msg/mms_recv/abroad_network 0
195 vconftool set -t bool db/msg/mms_recv/read_receipt 1
196 vconftool set -t bool db/msg/mms_recv/delivery_receipt 1
197 vconftool set -t bool db/msg/mms_recv/reject_unknown 0
198 vconftool set -t bool db/msg/mms_recv/reject_advertisement 0
199
200 # MMS Receive Options
201 vconftool set -t int db/msg/mms_style/font_size 30
202 vconftool set -t bool db/msg/mms_style/font_style/bold 0
203 vconftool set -t bool db/msg/mms_style/font_style/italic 0
204 vconftool set -t bool db/msg/mms_style/font_style/underline 0
205 vconftool set -t int db/msg/mms_style/font_color/red 0
206 vconftool set -t int db/msg/mms_style/font_color/green 0
207 vconftool set -t int db/msg/mms_style/font_color/blue 0
208 vconftool set -t int db/msg/mms_style/font_color/hue 255
209 vconftool set -t int db/msg/mms_style/bg_color/red 255
210 vconftool set -t int db/msg/mms_style/bg_color/green 255
211 vconftool set -t int db/msg/mms_style/bg_color/blue 255
212 vconftool set -t int db/msg/mms_style/bg_color/hue 255
213 vconftool set -t int db/msg/mms_style/page_dur 2
214 vconftool set -t int db/msg/mms_style/page_custom_dur 0
215 vconftool set -t int db/msg/mms_style/page_dur_manual 0
216
217 # Push Msg Options
218 vconftool set -t bool db/msg/push_msg/recv_option 1
219 vconftool set -t int db/msg/push_msg/service_load 1
220
221 # CB Msg Options
222 vconftool set -t bool db/msg/cb_msg/receive 0
223 vconftool set -t bool db/msg/cb_msg/all_channel 0
224 vconftool set -t int db/msg/cb_msg/max_sim_count 0
225 vconftool set -t int db/msg/cb_msg/channel_count 0
226 vconftool set -t bool db/msg/cb_msg/language/0 0
227 vconftool set -t bool db/msg/cb_msg/language/1 0
228 vconftool set -t bool db/msg/cb_msg/language/2 0
229 vconftool set -t bool db/msg/cb_msg/language/3 0
230 vconftool set -t bool db/msg/cb_msg/language/4 0
231 vconftool set -t bool db/msg/cb_msg/language/5 0
232 vconftool set -t bool db/msg/cb_msg/language/6 0
233 vconftool set -t bool db/msg/cb_msg/language/7 0
234 vconftool set -t bool db/msg/cb_msg/language/8 0
235 vconftool set -t bool db/msg/cb_msg/language/9 0
236
237 # SOS Msg Options
238 vconftool set -t bool db/msg/sos_msg/send_option 0
239 vconftool set -t int db/msg/sos_msg/recipient_count 0
240 vconftool set -t int db/msg/sos_msg/repeat_count 0
241 vconftool set -t string db/msg/sos_msg/msg_text ""
242 vconftool set -t int db/msg/sos_msg/alert_type 0
243
244 # Voice Mail Options
245 vconftool set -t string db/msg/voice_mail/voice_mail_number "12345678"
246
247 # MMS Size Options
248 vconftool set -t int db/msg/size_opt/msg_size 300
249
250 vconftool set -t int db/badge/org.tizen.message 0
251
252 # Msg Count
253 vconftool set -t int db/msg/recv_sms 0 -u 0
254 vconftool set -t int db/msg/recv_mms 0 -u 0
255
256 %postun -p /sbin/ldconfig
257
258 %postun tools -p /sbin/ldconfig
259
260 %postun -n sms-plugin -p /sbin/ldconfig
261
262 %postun -n mms-plugin -p /sbin/ldconfig
263
264 %files
265 %defattr(-,root,root,-)
266 %dir /opt/data/msg-service
267 %{_libdir}/libmsg_plugin_manager.so
268 %{_libdir}/libmsg_mapi.so.*
269 %{_libdir}/libmsg_framework_handler.so
270 %{_libdir}/libmsg_transaction_manager.so
271 %{_libdir}/libmsg_utils.so
272 %{_libdir}/libmsg_transaction_proxy.so
273 %{_sysconfdir}/rc.d/init.d/msg-server
274 %{_sysconfdir}/rc.d/rc3.d/S70msg-server
275 %{_sysconfdir}/rc.d/rc5.d/S70msg-server
276
277 %files devel
278 %defattr(-,root,root,-)
279 %{_libdir}/libmsg_mapi.so
280 %{_libdir}/pkgconfig/msg-service.pc
281 %{_includedir}/msg-service/*
282
283
284 %files tools
285 %defattr(-,root,root,-)
286 %{_bindir}/msg-helper
287 %{_bindir}/msg-test-app
288 %{_bindir}/msg-server
289 %{_datadir}/media/Sherbet.wav
290 %attr(0644,root,root)/usr/share/msg-service/plugin.cfg
291 %attr(0644,root,root)/opt/etc/msg-service/Temp0_2.txt
292 %attr(0644,root,root)/opt/etc/msg-service/Temp1_0.txt
293 %attr(0644,root,root)/opt/etc/msg-service/audio.amr
294 %attr(0644,root,root)/opt/etc/msg-service/P091120_104633.jpg
295 %attr(0644,root,root)/opt/etc/msg-service/A.smi
296 %attr(0644,root,root)/opt/etc/msg-service/V091120_104905.3gp
297 %attr(0644,root,root)/opt/etc/msg-service/alert_on_call.mp3
298
299 %files -n sms-plugin
300 %defattr(-,root,root,-)
301 %{_libdir}/libmsg_sms_plugin.so
302
303 %files -n mms-plugin
304 %defattr(-,root,root,-)
305 %{_libdir}/libmsg_mms_plugin.so
306 %{_libdir}/libmsg_mms_language_pack.so