commenting if containing chsmack
[platform/core/messaging/msg-service.git] / packaging / msg-service.spec
1 Name:           msg-service
2 Version:        0.9.2
3 Release:        3
4 License:        Samsung
5 Summary:        Messaging Framework Library
6 Group:          System/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source101:      msg-service.service
9 Source1001:     msg-service.manifest
10
11 Requires(post): /usr/bin/sqlite3
12 Requires(post): /usr/bin/vconftool
13 Requires(post): /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15 Requires(post): systemd
16 Requires(postun): systemd
17 BuildRequires: cmake
18 BuildRequires: pkgconfig(alarm-service)
19 BuildRequires: pkgconfig(aul)
20 BuildRequires: pkgconfig(capi-appfw-application)
21 BuildRequires: pkgconfig(contacts-service2)
22 BuildRequires: pkgconfig(db-util)
23 BuildRequires: pkgconfig(dlog)
24 BuildRequires: pkgconfig(drm-client)
25 BuildRequires: pkgconfig(glib-2.0)
26 BuildRequires: pkgconfig(libcurl)
27 BuildRequires: pkgconfig(libsystemd-daemon)
28 BuildRequires: pkgconfig(libxml-2.0)
29 BuildRequires: pkgconfig(libwbxml2)
30 BuildRequires: pkgconfig(media-thumbnail)
31 BuildRequires: pkgconfig(mm-fileinfo)
32 BuildRequires: pkgconfig(mm-player)
33 BuildRequires: pkgconfig(mm-session)
34 BuildRequires: pkgconfig(mm-sound)
35 BuildRequires: pkgconfig(network)
36 BuildRequires: pkgconfig(notification)
37 BuildRequires: pkgconfig(pmapi)
38 BuildRequires: pkgconfig(mmutil-imgp)
39 BuildRequires: pkgconfig(mmutil-jpeg)
40 BuildRequires: pkgconfig(security-server)
41 BuildRequires: pkgconfig(sensor)
42 BuildRequires: pkgconfig(svi)
43 BuildRequires: pkgconfig(tapi)
44 BuildRequires: pkgconfig(vconf)
45 BuildRequires: pkgconfig(feedback)
46
47 %description
48 Description: Messaging Framework Library
49
50
51 %package devel
52 License:        Flora License v1.0
53 Summary:        Messaging Framework Library (development)
54 Requires:       %{name} = %{version}-%{release}
55 Group:          Development/Libraries
56
57 %description devel
58 Description: Messaging Framework Library (development)
59
60
61 %package tools
62 License:        Flora License v1.0
63 Summary:        Messaging server application
64 Requires:       %{name} = %{version}-%{release}
65 Group:          TO_BU / FILL_IN
66 Requires(post): /usr/bin/sqlite3
67 Requires(post): /usr/bin/vconftool
68 Requires(post): /sbin/ldconfig
69 Requires(postun): /sbin/ldconfig
70
71 %description tools
72 Description:  Messaging server application
73
74
75 %package -n sms-plugin
76 License:        Flora License v1.0
77 Summary:        SMS plugin library
78 Requires:       %{name} = %{version}-%{release}
79 Group:          System/Libraries
80 Requires(post): /sbin/ldconfig
81 Requires(postun): /sbin/ldconfig
82
83 %description -n sms-plugin
84 Description: SMS plugin library
85
86 %package -n mms-plugin
87 License:        Flora License v1.0
88 Summary:        MMS plugin library
89 Requires:       %{name} = %{version}-%{release}
90 Group:          System/Libraries
91 Requires(post): /sbin/ldconfig
92 Requires(postun): /sbin/ldconfig
93
94 %description -n mms-plugin
95 Description: MMS plugin library
96
97 %prep
98 %setup -q
99 cp %{SOURCE1001} .
100
101
102 %build
103 %cmake .
104 make %{?jobs:-j%jobs}
105
106 %install
107 rm -rf %{buildroot}
108 mkdir -p %{buildroot}/usr/share/license
109 mkdir -p %{buildroot}/etc/config
110
111 mkdir -p %{buildroot}/var/log/msgfw
112
113 %make_install
114
115 mkdir -p %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants
116 #install -m 0644 %SOURCE101 %{buildroot}%{_unitdir_user}/
117 ln -s ../msg-service.service %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants/msg-service.service
118 ln -s ../msg-service-log.service %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants/msg-service-log.service
119
120 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc3.d
121 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S70msg-server
122 mkdir -p  %{buildroot}%{_sysconfdir}/rc.d/rc5.d
123 ln -s %{_sysconfdir}/rc.d/init.d/msg-server  %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S70msg-server
124
125 mkdir -p %{buildroot}/opt/usr/data/msg-service
126
127 %if 0%{?simulator}
128 rm %{buildroot}/etc/config/sysinfo-message.xml
129 mv %{buildroot}/etc/config/sysinfo-message.emul.xml %{buildroot}/etc/config/sysinfo-message.xml
130 %else
131 rm %{buildroot}/etc/config/sysinfo-message.emul.xml
132 %endif
133
134
135 %post tools -p /sbin/ldconfig
136 %post -n sms-plugin -p /sbin/ldconfig
137 %post -n mms-plugin -p /sbin/ldconfig
138
139 %post
140 /sbin/ldconfig
141
142 if [ ! -f /opt/usr/dbspace/.msg_service.db ]
143 then
144     mkdir -p /opt/usr/dbspace/
145     sqlite3 /opt/usr/dbspace/.msg_service.db "PRAGMA journal_mode = PERSIST;
146
147     CREATE TABLE MSG_CONVERSATION_TABLE (
148         CONV_ID INTEGER PRIMARY KEY ,
149         UNREAD_CNT INTEGER DEFAULT 0 ,
150         SMS_CNT INTEGER DEFAULT 0 ,
151         MMS_CNT INTEGER DEFAULT 0 ,
152         MAIN_TYPE INTEGER DEFAULT 0 ,
153         SUB_TYPE INTEGER DEFAULT 0 ,
154         MSG_DIRECTION INTEGER DEFAULT 0 ,
155         DISPLAY_TIME DATETIME ,
156         DISPLAY_NAME TEXT ,
157         MSG_TEXT TEXT );
158
159     CREATE TABLE MSG_ADDRESS_TABLE (
160         ADDRESS_ID INTEGER PRIMARY KEY ,
161         CONV_ID INTEGER  NOT NULL ,
162         ADDRESS_TYPE INTEGER ,
163         RECIPIENT_TYPE INTEGER ,
164         ADDRESS_VAL TEXT ,
165         CONTACT_ID INTEGER ,
166         DISPLAY_NAME TEXT ,
167         FIRST_NAME TEXT ,
168         LAST_NAME TEXT ,
169         IMAGE_PATH TEXT ,
170         SYNC_TIME DATETIME ,
171         FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) );
172
173     CREATE TABLE MSG_FOLDER_TABLE (
174         FOLDER_ID INTEGER PRIMARY KEY ,
175         FOLDER_NAME TEXT NOT NULL ,
176         FOLDER_TYPE INTEGER DEFAULT 0 );
177
178     CREATE TABLE MSG_MESSAGE_TABLE (
179         MSG_ID INTEGER PRIMARY KEY ,
180         CONV_ID INTEGER NOT NULL ,
181         FOLDER_ID INTEGER NOT NULL ,
182         STORAGE_ID INTEGER NOT NULL ,
183         MAIN_TYPE INTEGER NOT NULL ,
184         SUB_TYPE INTEGER NOT NULL ,
185         DISPLAY_TIME DATETIME ,
186         DATA_SIZE INTEGER DEFAULT 0 ,
187         NETWORK_STATUS INTEGER DEFAULT 0 ,
188         READ_STATUS INTEGER DEFAULT 0 ,
189         PROTECTED INTEGER DEFAULT 0 ,
190         PRIORITY INTEGER DEFAULT 0 ,
191         MSG_DIRECTION INTEGER NOT NULL ,
192         SCHEDULED_TIME DATETIME ,
193         BACKUP INTEGER DEFAULT 0 ,
194         SUBJECT TEXT ,
195         MSG_DATA TEXT ,
196         THUMB_PATH TEXT ,
197         MSG_TEXT TEXT ,
198         ATTACHMENT_COUNT INTEGER DEFAULT 0 ,
199         FOREIGN KEY (CONV_ID) REFERENCES MSG_CONVERSATION_TABLE (CONV_ID) ,
200         FOREIGN KEY (FOLDER_ID) REFERENCES MSG_FOLDER_TABLE (FOLDER_ID) );
201
202     CREATE TABLE MSG_SIM_TABLE (
203         MSG_ID INTEGER PRIMARY KEY ,
204         SIM_ID INTEGER NOT NULL ,
205         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
206
207     CREATE TABLE MSG_PUSH_TABLE (
208         MSG_ID INTEGER PRIMARY KEY ,
209         ACTION INTEGER ,
210         CREATED INTEGER ,
211         EXPIRES INTEGER ,
212         ID TEXT ,
213         HREF TEXT ,
214         CONTENT TEXT ,
215         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
216
217     CREATE TABLE MSG_CBMSG_TABLE (
218         MSG_ID INTEGER PRIMARY KEY ,
219         CB_MSG_ID INTEGER NOT NULL ,
220         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
221
222     CREATE TABLE MSG_SYNCML_TABLE (
223         MSG_ID INTEGER PRIMARY KEY ,
224         EXT_ID INTEGER NOT NULL ,
225         PINCODE INTEGER NOT NULL ,
226         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
227
228     CREATE TABLE MSG_SCHEDULED_TABLE (
229         MSG_ID INTEGER PRIMARY KEY ,
230         ALARM_ID INTEGER NOT NULL ,
231         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
232
233     CREATE TABLE MSG_SMS_SENDOPT_TABLE (
234         MSG_ID INTEGER PRIMARY KEY ,
235         DELREP_REQ INTEGER NOT NULL ,
236         KEEP_COPY INTEGER NOT NULL ,
237         REPLY_PATH INTEGER NOT NULL ,
238         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
239
240     CREATE TABLE MSG_FILTER_TABLE (
241         FILTER_ID INTEGER PRIMARY KEY ,
242         FILTER_TYPE INTEGER NOT NULL ,
243         FILTER_VALUE TEXT NOT NULL ,
244         FILTER_ACTIVE INTEGER DEFAULT 0 );
245
246     CREATE TABLE MSG_MMS_MESSAGE_TABLE (
247         MSG_ID INTEGER PRIMARY KEY ,
248         TRANSACTION_ID TEXT ,
249         MESSAGE_ID TEXT ,
250         FWD_MESSAGE_ID TEXT ,
251         CONTENTS_LOCATION TEXT ,
252         FILE_PATH TEXT ,
253         VERSION INTEGER NOT NULL ,
254         DATA_TYPE INTEGER DEFAULT -1 ,
255         DATE DATETIME ,
256         HIDE_ADDRESS INTEGER DEFAULT 0 ,
257         ASK_DELIVERY_REPORT INTEGER DEFAULT 0 ,
258         REPORT_ALLOWED INTEGER DEFAULT 0 ,
259         READ_REPORT_ALLOWED_TYPE INTEGER DEFAULT 0 ,
260         ASK_READ_REPLY INTEGER DEFAULT 0 ,
261         READ INTEGER DEFAULT 0 ,
262         READ_REPORT_SEND_STATUS INTEGER DEFAULT 0 ,
263         READ_REPORT_SENT INTEGER DEFAULT 0 ,
264         PRIORITY INTEGER DEFAULT 0 ,
265         KEEP_COPY INTEGER DEFAULT 0 ,
266         MSG_SIZE INTEGER NOT NULL ,
267         MSG_CLASS INTEGER DEFAULT -1 ,
268         EXPIRY_TIME DATETIME ,
269         CUSTOM_DELIVERY_TIME INTEGER DEFAULT 0 ,
270         DELIVERY_TIME DATETIME ,
271         MSG_STATUS INTEGER DEFAULT -1 ,
272         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
273
274     CREATE TABLE MSG_MMS_PREVIEW_INFO_TABLE (
275         MSG_ID INTEGER NOT NULL ,
276         TYPE INTEGER,
277         VALUE TEXT,
278         COUNT INTEGER,
279         FOREIGN KEY(MSG_ID) REFERENCES MSG_MESSAGE_TABLE(MSG_ID) );
280
281     CREATE TABLE MSG_REPORT_TABLE (
282         MSG_ID INTEGER NOT NULL ,
283         ADDRESS_VAL TEXT ,
284         STATUS_TYPE INTEGER ,
285         STATUS INTEGER DEFAULT 0 ,
286         TIME DATETIME );
287
288     CREATE TABLE MSG_PUSHCFG_TABLE (
289         PUSH_ID INTEGER PRIMARY KEY ,
290         CONTENT_TYPE TEXT,
291         APP_ID TEXT,
292         PKG_NAME TEXT,
293         LAUNCH INTEGER,
294         APPCODE INTEGER,
295         SECURE INTEGER );
296
297     CREATE INDEX MSG_CONVERSATION_INDEX ON MSG_CONVERSATION_TABLE(CONV_ID);
298     CREATE INDEX MSG_FOLDER_INDEX ON MSG_FOLDER_TABLE(FOLDER_ID);
299     CREATE INDEX MSG_MESSAGE_INDEX ON MSG_MESSAGE_TABLE(MSG_ID, CONV_ID, FOLDER_ID);
300
301     INSERT INTO MSG_FOLDER_TABLE VALUES (1, 'INBOX', 1);
302     INSERT INTO MSG_FOLDER_TABLE VALUES (2, 'OUTBOX', 2);
303     INSERT INTO MSG_FOLDER_TABLE VALUES (3, 'SENTBOX', 2);
304     INSERT INTO MSG_FOLDER_TABLE VALUES (4, 'DRAFT', 3);
305     INSERT INTO MSG_FOLDER_TABLE VALUES (5, 'CBMSGBOX', 1);
306     INSERT INTO MSG_FOLDER_TABLE VALUES (6, 'SPAMBOX', 4);
307     INSERT INTO MSG_FOLDER_TABLE VALUES (7, 'SMS TEMPLATE', 5);
308     INSERT INTO MSG_FOLDER_TABLE VALUES (8, 'MMS TEMPLATE', 5);
309
310     INSERT INTO MSG_PUSHCFG_TABLE VALUES (1, 'text/vnd.wap.si', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 1, 0);
311     INSERT INTO MSG_PUSHCFG_TABLE VALUES (2, 'application/vnd.wap.sic', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 2, 0);
312     INSERT INTO MSG_PUSHCFG_TABLE VALUES (3, 'text/vnd.wap.sl', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 3, 0);
313         INSERT INTO MSG_PUSHCFG_TABLE VALUES (4, 'application/vnd.wap.slc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 4, 0);
314     INSERT INTO MSG_PUSHCFG_TABLE VALUES (5, 'text/vnd.wap.co', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 5, 0);
315
316     INSERT INTO MSG_PUSHCFG_TABLE VALUES (6, 'application/vnd.wap.coc', 'X-Wap-Application-Id: x-wap-application:wml.ua', '', 0, 6, 0);
317     INSERT INTO MSG_PUSHCFG_TABLE VALUES (7, 'application/vnd.wap.mms-message', 'X-Wap-Application-Id: x-wap-application:mms.ua', '', 0, 7, 0);
318     INSERT INTO MSG_PUSHCFG_TABLE VALUES (8, 'application/vnd.wap.sia', 'X-Wap-Application-Id: x-wap-application:push.sia', '', 0, 8, 0);
319     INSERT INTO MSG_PUSHCFG_TABLE VALUES (9, 'application/vnd.syncml.dm+wbxml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 9, 0);
320     INSERT INTO MSG_PUSHCFG_TABLE VALUES (10, 'application/vnd.syncml.dm+xml', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 10, 0);
321
322     INSERT INTO MSG_PUSHCFG_TABLE VALUES (11, 'application/vnd.syncml.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.dm', '', 0, 11, 0);
323     INSERT INTO MSG_PUSHCFG_TABLE VALUES (12, 'application/vnd.syncml.ds.notification', 'X-Wap-Application-Id: x-wap-application:push.syncml.ds', '', 0, 12, 0);
324     INSERT INTO MSG_PUSHCFG_TABLE VALUES (13, 'application/vnd.syncml+wbxml', 'X-Wap-Application-Id:x-wap-application:push.syncml', '', 0, 13, 0);
325     INSERT INTO MSG_PUSHCFG_TABLE VALUES (14, 'application/vnd.wap.locc+wbxml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 14, 0);
326     INSERT INTO MSG_PUSHCFG_TABLE VALUES (15, 'application/vnd.wap.loc+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 15, 0);
327
328     INSERT INTO MSG_PUSHCFG_TABLE VALUES (16, 'application/vnd.oma.dd+xml', 'X-Wap-Application-Id: x-wap-application:loc.ua', '', 0, 16, 0);
329     INSERT INTO MSG_PUSHCFG_TABLE VALUES (17, 'application/vnd.oma.drm.message', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 17, 0);
330     INSERT INTO MSG_PUSHCFG_TABLE VALUES (18, 'application/vnd.oma.drm.content', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 18, 0);
331     INSERT INTO MSG_PUSHCFG_TABLE VALUES (19, 'application/vnd.oma.drm.rights+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 19, 0);
332     INSERT INTO MSG_PUSHCFG_TABLE VALUES (20, 'application/vnd.oma.drm.rights+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 20, 0);
333
334     INSERT INTO MSG_PUSHCFG_TABLE VALUES (21, 'application/vnd.oma.drm.ro+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 21, 0);
335     INSERT INTO MSG_PUSHCFG_TABLE VALUES (22, 'application/vnd.oma.drm.roap-pdu+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 22, 0);
336     INSERT INTO MSG_PUSHCFG_TABLE VALUES (23, 'application/vnd.oma.drm.roap-trigger+xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 23, 0);
337     INSERT INTO MSG_PUSHCFG_TABLE VALUES (24, 'application/vnd.oma.drm.roap-trigger+wbxml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 24, 0);
338         INSERT INTO MSG_PUSHCFG_TABLE VALUES (25, 'text/vnd.wap.connectivity-xml', 'X-Wap-Application-Id: x-wap-application:drm.ua', '', 0, 26, 0);
339
340         INSERT INTO MSG_PUSHCFG_TABLE VALUES (26, 'application/vnd.wap.connectivity-wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 27, 0);
341         INSERT INTO MSG_PUSHCFG_TABLE VALUES (27, 'application/x-wap-prov.browser-settings', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 28, 0);
342         INSERT INTO MSG_PUSHCFG_TABLE VALUES (28, 'application/x-wap-prov.browser-bookmarks', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 29, 0);
343         INSERT INTO MSG_PUSHCFG_TABLE VALUES (29, 'application/x-wap-prov.syncset+xml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 30, 0);
344         INSERT INTO MSG_PUSHCFG_TABLE VALUES (30, 'application/x-wap-prov.syncset+wbxml', 'X-Wap-Application-Id: x-wap-samsung:provisioning.ua', '', 0, 31, 0);
345
346         INSERT INTO MSG_PUSHCFG_TABLE VALUES (31, 'text/vnd.wap.emn+xml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 32, 0);
347         INSERT INTO MSG_PUSHCFG_TABLE VALUES (32, 'application/vnd.wap.emn+wbxml', 'X-Wap-Application-Id: x-wap-application:emn.ua', '', 0, 33, 0);
348         INSERT INTO MSG_PUSHCFG_TABLE VALUES (33, 'application/vnd.wv.csp.cir', 'X-Wap-Application-Id: x-wap-application:wv.ua', '', 0, 34, 0);
349         INSERT INTO MSG_PUSHCFG_TABLE VALUES (34, 'application/vnd.omaloc-supl-init', 'X-Wap-Application-Id: x-oma-application:ulp.ua', '', 0, 44, 0);
350         INSERT INTO MSG_PUSHCFG_TABLE VALUES (35, 'application/vnd.wap.emn+wbxml', 'X-oma-docomo:xmd.mail.ua', '', 0, 45, 1);"
351 fi
352
353 chown :6011 /opt/usr/dbspace/.msg_service.db
354 chown :6011 /opt/usr/dbspace/.msg_service.db-journal
355 chmod 660 /opt/usr/dbspace/.msg_service.db
356 chmod 660 /opt/usr/dbspace/.msg_service.db-journal
357 mkdir -p /opt/usr/data/msg-service
358 chgrp db_msg_service /opt/usr/data/msg-service
359
360 #if [ -f %{_libdir}/rpm-plugins/msm.so ]
361 #then
362 #       chsmack -a 'msg-service::db' /opt/usr/dbspace/.msg_service.db*
363 #        chsmack -a "_" -e "_" /etc/rc.d/init.d/msg-server
364 #        chsmack -a "_" -e "_" /etc/rc.d/rc3.d/S70msg-server
365 #        chsmack -a "_" -e "_" /etc/rc.d/rc5.d/S70msg-server
366 #fi
367
368 ########## Setting Config Value (Internal keys) ##########
369 vcuid=5000
370 # Message Server Status
371 vconftool set -t bool memory/msg/ready 0 -i -g 5000 -u $vcuid
372
373 # SMS Send Options
374 vconftool set -t int db/msg/network_mode 2 -u $vcuid
375
376 # New Message Count
377 vconftool set -t int db/msg/recv_sms 0 -u $vcuid
378 vconftool set -t int db/msg/recv_mms 0 -u $vcuid
379
380 ########## Setting Config Value (Private keys) ##########
381 # General Options
382 vconftool set -t bool db/private/msg-service/general/keep_copy 1 -u $vcuid
383 vconftool set -t bool db/private/msg-service/general/auto_erase 0 -u $vcuid
384 vconftool set -t bool db/private/msg-service/general/block_msg 0 -u $vcuid
385 vconftool set -t int db/private/msg-service/general/contact_sync_time 0 -u $vcuid
386
387 # SMS Send Options
388 vconftool set -t int db/private/msg-service/sms_send/dcs 3 -u $vcuid
389 vconftool set -t bool db/private/msg-service/sms_send/reply_path 0 -u $vcuid
390 vconftool set -t bool db/private/msg-service/sms_send/delivery_report 0 -u $vcuid
391 vconftool set -t int db/private/msg-service/sms_send/save_storage 1 -u $vcuid
392
393 # SMSC
394 vconftool set -t int db/private/msg-service/smsc/total_count 1 -u $vcuid
395 vconftool set -t int db/private/msg-service/smsc/selected 0 -u $vcuid
396
397 vconftool set -t int db/private/msg-service/smsc/pid/0 1 -u $vcuid
398 vconftool set -t int db/private/msg-service/smsc/val_period/0 255 -u $vcuid
399 vconftool set -t string db/private/msg-service/smsc/name/0 "" -u $vcuid
400 vconftool set -t int db/private/msg-service/smsc/ton/0 1 -u $vcuid
401 vconftool set -t int db/private/msg-service/smsc/npi/0 1 -u $vcuid
402 vconftool set -t string db/private/msg-service/smsc/address/0 "" -u $vcuid
403
404 vconftool set -t int db/private/msg-service/smsc/pid/1 0 -u $vcuid
405 vconftool set -t int db/private/msg-service/smsc/val_period/1 0 -u $vcuid
406 vconftool set -t string db/private/msg-service/smsc/name/1 "" -u $vcuid
407 vconftool set -t int db/private/msg-service/smsc/ton/1 0 -u $vcuid
408 vconftool set -t int db/private/msg-service/smsc/npi/1 0 -u $vcuid
409 vconftool set -t string db/private/msg-service/smsc/address/1 "" -u $vcuid
410
411 vconftool set -t int db/private/msg-service/smsc/pid/2 0 -u $vcuid
412 vconftool set -t int db/private/msg-service/smsc/val_period/2 0 -u $vcuid
413 vconftool set -t string db/private/msg-service/smsc/name/2 "" -u $vcuid
414 vconftool set -t int db/private/msg-service/smsc/ton/2 0 -u $vcuid
415 vconftool set -t int db/private/msg-service/smsc/npi/2 0 -u $vcuid
416 vconftool set -t string db/private/msg-service/smsc/address/2 "" -u $vcuid
417
418 # MMS Send Options
419 vconftool set -t int db/private/msg-service/mms_send/msg_class 0 -u $vcuid
420 vconftool set -t int db/private/msg-service/mms_send/priority 1 -u $vcuid
421 vconftool set -t int db/private/msg-service/mms_send/expiry_time 0 -u $vcuid
422 vconftool set -t int db/private/msg-service/mms_send/custom_delivery 0 -u $vcuid
423 vconftool set -t bool db/private/msg-service/mms_send/sender_visibility 0 -u $vcuid
424 vconftool set -t bool db/private/msg-service/mms_send/delivery_report 1 -u $vcuid
425 vconftool set -t bool db/private/msg-service/mms_send/read_reply 1 -u $vcuid
426 vconftool set -t bool db/private/msg-service/mms_send/keep_copy 0 -u $vcuid
427 vconftool set -t bool db/private/msg-service/mms_send/body_replying 0 -u $vcuid
428 vconftool set -t bool db/private/msg-service/mms_send/hide_recipients 0 -u $vcuid
429 vconftool set -t bool db/private/msg-service/mms_send/report_allowed 1 -u $vcuid
430 vconftool set -t int db/private/msg-service/mms_send/reply_charging 0 -u $vcuid
431 vconftool set -t int db/private/msg-service/mms_send/reply_charging_deadline 0 -u $vcuid
432 vconftool set -t int db/private/msg-service/mms_send/reply_charging_size 0 -u $vcuid
433 vconftool set -t int db/private/msg-service/mms_send/delivery_time 0 -u $vcuid
434 vconftool set -t int db/private/msg-service/mms_send/creation_mode 2 -u $vcuid
435
436 # MMS Receive Options
437 vconftool set -t int db/private/msg-service/mms_recv/home_network 0 -u $vcuid
438 vconftool set -t int db/private/msg-service/mms_recv/abroad_network 0 -u $vcuid
439 vconftool set -t bool db/private/msg-service/mms_recv/read_receipt 1 -u $vcuid
440 vconftool set -t bool db/private/msg-service/mms_recv/delivery_receipt 1 -u $vcuid
441 vconftool set -t bool db/private/msg-service/mms_recv/reject_unknown 0 -u $vcuid
442 vconftool set -t bool db/private/msg-service/mms_recv/reject_advertisement 0 -u $vcuid
443
444 # MMS Receive Options
445 vconftool set -t int db/private/msg-service/mms_style/font_size 30 -u $vcuid
446 vconftool set -t bool db/private/msg-service/mms_style/font_style/bold 0 -u $vcuid
447 vconftool set -t bool db/private/msg-service/mms_style/font_style/italic 0 -u $vcuid
448 vconftool set -t bool db/private/msg-service/mms_style/font_style/underline 0 -u $vcuid
449 vconftool set -t int db/private/msg-service/mms_style/font_color/red 255 -u $vcuid
450 vconftool set -t int db/private/msg-service/mms_style/font_color/green 255 -u $vcuid
451 vconftool set -t int db/private/msg-service/mms_style/font_color/blue 255 -u $vcuid
452 vconftool set -t int db/private/msg-service/mms_style/font_color/hue 255 -u $vcuid
453 vconftool set -t int db/private/msg-service/mms_style/bg_color/red 0 -u $vcuid
454 vconftool set -t int db/private/msg-service/mms_style/bg_color/green 0 -u $vcuid
455 vconftool set -t int db/private/msg-service/mms_style/bg_color/blue 0 -u $vcuid
456 vconftool set -t int db/private/msg-service/mms_style/bg_color/hue 255 -u $vcuid
457 vconftool set -t int db/private/msg-service/mms_style/page_dur 2 -u $vcuid
458 vconftool set -t int db/private/msg-service/mms_style/page_custom_dur 0 -u $vcuid
459 vconftool set -t int db/private/msg-service/mms_style/page_dur_manual 0 -u $vcuid
460
461 # Push Msg Options
462 vconftool set -t bool db/private/msg-service/push_msg/recv_option 1 -u $vcuid
463 vconftool set -t int db/private/msg-service/push_msg/service_load 1 -u $vcuid
464
465 # CB Msg Options
466 vconftool set -t bool db/private/msg-service/cb_msg/receive 1 -f -u $vcuid
467 vconftool set -t bool db/private/msg-service/cb_msg/save 1 -f -u $vcuid
468 vconftool set -t int db/private/msg-service/cb_msg/max_sim_count 0 -u $vcuid
469 vconftool set -t int db/private/msg-service/cb_msg/channel_count 0 -u $vcuid
470 vconftool set -t bool db/private/msg-service/cb_msg/language/0 1 -f -u $vcuid
471 vconftool set -t bool db/private/msg-service/cb_msg/language/1 0 -u $vcuid
472 vconftool set -t bool db/private/msg-service/cb_msg/language/2 0 -u $vcuid
473 vconftool set -t bool db/private/msg-service/cb_msg/language/3 0 -u $vcuid
474 vconftool set -t bool db/private/msg-service/cb_msg/language/4 0 -u $vcuid
475 vconftool set -t bool db/private/msg-service/cb_msg/language/5 0 -u $vcuid
476 vconftool set -t bool db/private/msg-service/cb_msg/language/6 0 -u $vcuid
477 vconftool set -t bool db/private/msg-service/cb_msg/language/7 0 -u $vcuid
478 vconftool set -t bool db/private/msg-service/cb_msg/language/8 0 -u $vcuid
479 vconftool set -t bool db/private/msg-service/cb_msg/language/9 0 -u $vcuid
480
481 # Voice Mail Options
482 vconftool set -t string db/private/msg-service/voice_mail/voice_mail_number "5500" -f -u $vcuid
483 vconftool set -t int db/private/msg-service/voice_mail/voice_mail_count 0 -u $vcuid
484
485 # MMS Size Options
486 vconftool set -t int db/private/msg-service/size_opt/msg_size 300 -u $vcuid
487
488 # SIM message count
489 vconftool set -t int db/private/msg-service/sim_count/used_cnt 0 -u $vcuid
490 vconftool set -t int db/private/msg-service/sim_count/total_cnt 0 -u $vcuid
491
492 # SIM information
493 vconftool set -t int memory/private/msg-service/sim_changed 0 -i -u $vcuid
494 vconftool set -t string memory/private/msg-service/sim_imsi "" -i -u $vcuid
495 vconftool set -t bool memory/private/msg-service/national_sim 0 -i -u $vcuid
496 vconftool set -t string memory/private/msg-service/msisdn "" -i -u $vcuid
497
498 vconftool set -t int db/private/msg-service/notification_priv_id 0 -u $vcuid
499
500 /sbin/ldconfig
501 /bin/systemctl daemon-reload
502 if [ "$1" = "1" ]; then
503     systemctl stop msg-service.service
504 fi
505
506 %postun -p /sbin/ldconfig
507
508 %postun tools -p /sbin/ldconfig
509 %postun -n sms-plugin -p /sbin/ldconfig
510 %postun -n mms-plugin -p /sbin/ldconfig
511
512 %files
513 %manifest %{name}.manifest
514 %defattr(-,root,root,-)
515 %dir %attr(775,root,db_msg_service) /opt/usr/data/msg-service
516 %{_libdir}/libmsg_plugin_manager.so
517 %{_libdir}/libmsg_mapi.so.*
518 %{_libdir}/libmsg_framework_handler.so
519 %{_libdir}/libmsg_transaction_manager.so
520 %{_libdir}/libmsg_utils.so
521 %{_libdir}/libmsg_transaction_proxy.so
522 %{_libdir}/libmsg_vobject.so
523 /usr/share/license/msg-service/LICENSE.Flora
524
525 %files devel
526 %manifest %{name}.manifest
527 %defattr(-,root,root,-)
528 %{_libdir}/libmsg_mapi.so
529 %{_libdir}/pkgconfig/msg-service.pc
530 %{_includedir}/msg-service/*
531
532 %files tools
533 %manifest %{name}.manifest
534 %defattr(-,root,root,-)
535 %{_bindir}/msg-helper
536 %{_bindir}/msg-server
537 %{_datadir}/media/Sherbet.wav
538 %attr(0644,root,root)/usr/share/msg-service/plugin.cfg
539 %{_sysconfdir}/rc.d/init.d/msg-server
540 %{_sysconfdir}/rc.d/rc3.d/S70msg-server
541 %{_sysconfdir}/rc.d/rc5.d/S70msg-server
542 %{_unitdir_user}/msg-service.service
543 %{_unitdir_user}/msg-service-log.service
544 %{_unitdir_user}/tizen-middleware.target.wants/msg-service.service
545 %{_unitdir_user}/tizen-middleware.target.wants/msg-service-log.service
546 /usr/share/license/msg-service/LICENSE.Flora
547 /opt/etc/smack/accesses.d/msg-service.rule
548 /etc/config/sysinfo-message.xml
549
550 %attr(0755,app,app)/var/log/msgfw
551
552
553 %files -n sms-plugin
554 %manifest %{name}.manifest
555 %defattr(-,root,root,-)
556 %{_libdir}/libmsg_sms_plugin.so
557 /usr/share/license/msg-service/LICENSE.Flora
558
559 %files -n mms-plugin
560 %manifest %{name}.manifest
561 %defattr(-,root,root,-)
562 %{_libdir}/libmsg_mms_plugin.so
563 /usr/share/license/msg-service/LICENSE.Flora
564
565 %changelog
566 * Wed Oct 25 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
567 - New release version
568
569 * Wed Aug 8 2012 KeeBum Kim <keebum.kim@samsung.com>
570 - Apply New TAPI.
571 - Modify transaction data size of sos recipient list.
572
573 * Tue Aug 7 2012 KeeBum Kim <keebum.kim@samsung.com>
574 - Fix contact sync defect.
575 - New MessageFW API.
576
577 * Fri Jul 27 2012 KeeBum Kim <keebum.kim@samsung.com>
578 - Change devman_haptic.h to devman_managed.h.
579 - Modify to set MSG_SERVER_READY before sim status check.
580 - Fix bug in sim message save related operations.
581 - Limit sim related APIs not to work on sim not available status.
582 - Modify indicator icon image path & related.
583
584 * Tue Jul 17 2012 KeeBum Kim <keebum.kim@samsung.com>
585 - Modify MAX_SEGMENT_NUM to 15.
586 - Modify MMplayer related to support interrupted event.
587 - Fix bug in storage change callback which could cause on submit request.
588
589 * Fri Jun 29 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
590 - Modify vconf key path for sos sending option.
591
592 * Mon Jun 18 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
593 - Storage change callback for scheduled message
594 - code chage to support glib2-2.32
595 - Apply Backup && Restore of Mms Type
596
597 * Fri Jun 15 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
598 - Update display time for scheduled message when it is sent.
599
600 * Thu Jun 14 2012 Seunghwan Lee <sh.cat.lee@samsung.com>
601 - Comment the test app in CMakefile.
602 - Modify MMS BG color of vconf value.
603 - Bug fixed wrong query in MsgStoCheckReadReportIsSent
604 - Add '-i' option for vconf keys of memory type
605 - Add smsc vconf keys(default value).
606 - To avoid msg incoming sound and notification on SOS
607
608 * Fri Jun 8 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
609 - Add '-i' option for vconf keys of memory type.
610 - Add smsc vconf keys(default value).
611 - To avoid msg incoming sound and notification on SOS state.
612 - Change BGcolor to black && font colore to white.
613
614 * Wed May 31 2012 Keebum Kim <keebum.kim@samsung.com>
615 - Apply Mdm policy.
616 - SOS message.
617 - Fix horizontality development problem.
618 - Remove vconf key for new message count. (db/badge/com.samsung.message)
619 - Change vconf key path of "mms_send/msg_class" to private.
620
621 * Thu May 24 2012 Keebum Kim <keebum.kim@samsung.com>
622 - Add new MAPI.
623
624 * Fri May 18 2012 Sangkoo Kim <sangkoo.kim@samsung.com>
625 - Modify to support new DRM service.
626 - Rename private vconf keys.
627 - Modify .postinst and .spec file to pre-install used vconf keys.
628 - Remove compile warnings.
629 - Fix bug in manual retrieve operation.
630
631 * Fri May 11 2012 Jaeyun Jeong <jyjeong@samsung.com>
632 - Fix DB conflict which cause db lock.
633 - Fix bug in Find My Mobile function.
634 - Add '*' and '#' symbol as valid number.
635
636 * Wed May 9 2012 Keebum Kim <keebum.kim@samsung.com>
637 - Change mobile tracker related vconf key define values.
638 - Apply MDM policy for allowing text messaging.
639 - Fix bug for getting thumbnail path.
640 - Enable functionality of scheduled message.
641 - Change alarm setting of scheduled message from volatile type to non-volatile.
642 - Fix error in search query.
643
644 * Thu May 3 2012 Keebum Kim <keebum.kim@samsung.com>
645 - Change some thread list related APIs to support DB change.
646 - DB change to support multiple recipient.
647
648 * Thu Apr 19 2012 Keebum Kim <keebum.kim@samsung.com>
649 - Modify to manage contact sync time by vconf.
650 - Use g_idle_add() routine for updating unread message count(vconf values).
651 - apply try{}catch{} code for handling unexpected exception to avoid thread terminating.
652 - Fix bug for allocated size of replacing string.
653 - Resolve search problem for special characters.
654 - add xmlFree.
655
656 * Tue Apr 10 2012 Keebum Kim <keebum.kim@samsung.com>
657 - Remove unused vconf keys.
658 - Initialize SMSC selected_index.
659 - Remove systemd related.
660
661 * Thu Apr 05 2012 Jaeyun Jeong <jyjeong@samsung.com>
662 - Add notification property(NOTIFICATION_PROP_DISPLAY_ONLY_SIMMODE)
663 - Fix S1-2397/2417/2418/2419.
664 - Remove sent status callback check during submit request.
665 - Modify offset and limit operation on search.
666 - Remove invalid folder and file.
667 - Change browser launching API from aul to service-capi.
668 - Remove unused file.
669 - Invalid type checking is fixed.
670
671 * Fri Mar 16 2012 Jaeyun Jeong <jyjeong@samsung.com>
672 - Add #include <sys/stat.h> to support chmod related defines.
673 - Fix DRM content issue(unregistered mo content)
674
675 * Wed Mar 14 2012 Jaeyun Jeong <jyjeong@samsung.com>
676 - Modify plugin configuration file location for FOTA.
677 - Remove the db query which create sample data.
678
679 * Wed Feb 29 2012 Jaeyun Jeong <jyjeong@samsung.com>
680 - Update msg-service.spec for OBS.
681 - Fix TC execute failure.
682 - Fix S1-1419(Removed mms raw file issue after rebooting)