f2b76a54b1d8438b59787186e8168667da45b633
[platform/upstream/mpfr.git] / packaging / mpfr.spec
1 %define keepstatic 1
2 Name:           mpfr
3 Version:        3.1.1
4 Release:        0
5 License:        LGPL-3.0+
6 Summary:        The GNU multiple-precision floating-point library
7 Url:            http://www.mpfr.org/
8 Group:          Development/Libraries/C and C++
9 Source:         mpfr-%{version}.tar.bz2
10 Source2:        baselibs.conf
11 Source1001:     mpfr.manifest
12 BuildRequires:  gmp-devel
13
14 %description
15 The MPFR library is a C library for multiple-precision floating-point
16 computations with exact rounding (also called correct rounding). It is
17 based on the GMP multiple-precision library.
18
19 The main goal of MPFR is to provide a library for multiple-precision
20 floating-point computation which is both efficient and has a
21 well-defined semantics. It copies the good ideas from the ANSI/IEEE-754
22 standard for double-precision floating-point arithmetic (53-bit
23 mantissa).
24
25 %package -n libmpfr
26 Summary:        The GNU multiple-precision floating-point shared library
27 Group:          Development/Libraries/C and C++
28
29 %description -n libmpfr
30 The MPFR library is a C library for multiple-precision floating-point
31 computations with exact rounding (also called correct rounding). It is
32 based on the GMP multiple-precision library.
33
34 %package devel
35 Summary:        Development files for the GNU multiple-precision floating-point library
36 Group:          Development/Libraries/C and C++
37 Requires:       gmp-devel
38 Requires:       libmpfr = %{version}
39
40 %description devel
41 Development files for the GNU multiple-precision floating-point library.
42
43 The MPFR library is a C library for multiple-precision floating-point
44 computations with exact rounding (also called correct rounding). It is
45 based on the GMP multiple-precision library.
46
47 %prep
48 %setup -q
49 cp %{SOURCE1001} .
50
51 %build
52 %configure \
53         --enable-thread-safe \
54         --enable-shared
55 make %{?_smp_mflags}
56
57 %check
58 make check %{?_smp_mflags}
59
60 %install
61 %make_install
62
63 %remove_docs
64
65 %post -n libmpfr -p /sbin/ldconfig
66
67 %postun -n libmpfr -p /sbin/ldconfig
68
69
70 %files -n libmpfr
71 %manifest %{name}.manifest
72 %license COPYING.LESSER COPYING
73 %defattr(-,root,root)
74 %{_libdir}/libmpfr.so.4*
75
76 %files devel
77 %manifest %{name}.manifest
78 %defattr(-,root,root)
79 %{_libdir}/libmpfr.a
80 %{_libdir}/libmpfr.so
81 %{_includedir}/mpf2mpfr.h
82 %{_includedir}/mpfr.h
83