add packaging
[platform/upstream/mpc.git] / packaging / mpc.spec
1 %define keepstatic 1
2 Name:           mpc
3 Version:        1.0
4 Release:        0
5 License:        LGPL-3.0+
6 Summary:        MPC multiple-precision complex shared library
7 Url:            http://www.multiprecision.org/mpc/
8 Group:          Development/Libraries/C and C++
9 Source:         mpc-%{version}.tar.bz2
10 Source2:        baselibs.conf
11 BuildRequires:  gmp-devel
12 BuildRequires:  mpfr-devel
13
14 %description
15 MPC is a C library for the arithmetic of complex numbers with
16 arbitrarily high precision and correct rounding of the result. It is
17 built upon and follows the same principles as MPFR.
18
19 %package -n libmpc
20 Summary:        MPC multiple-precision complex shared library
21 Group:          Development/Libraries/C and C++
22
23 %description -n libmpc
24 MPC is a C library for the arithmetic of complex numbers with
25 arbitrarily high precision and correct rounding of the result. It is
26 built upon and follows the same principles as MPFR.
27
28 %package devel
29 Summary:        MPC multiple-precision complex library development files
30 Group:          Development/Libraries/C and C++
31 Requires:       libmpc = %{version}
32 Requires:       mpfr-devel
33
34 %description devel
35 MPC multiple-precision complex library development files.
36
37 %prep
38 %setup -q
39
40 %build
41 %configure
42 make %{?_smp_mflags}
43
44 %check
45 make check %{?_smp_mflags}
46
47 %install
48 %make_install
49
50 %post -n libmpc -p /sbin/ldconfig
51
52 %postun -n libmpc -p /sbin/ldconfig
53
54
55 %files -n libmpc
56 %defattr(-,root,root)
57 %{_libdir}/libmpc.so.3*
58
59 %files devel
60 %defattr(-,root,root)
61 %doc AUTHORS NEWS COPYING.LESSER
62 %doc %{_infodir}/mpc.info.gz
63 %{_libdir}/libmpc.a
64 %{_libdir}/libmpc.so
65 /usr/include/mpc.h
66
67 %changelog