packaging: enable static
[platform/upstream/mpc.git] / packaging / mpc.spec
1 %define keepstatic 1
2 Name:           mpc-static
3 Version:        1.0
4 Release:        0
5 License:        LGPL-3.0+
6 Summary:        MPC multiple-precision complex shared library
7 Url:            http://www.multiprecision.org/mpc/
8 Group:          Development/Libraries/C and C++
9 Source:         %{name}-%{version}.tar.bz2
10 Source2:        baselibs.conf
11 Source1001:     mpc.manifest
12 BuildRequires:  gmp-static
13 BuildRequires:  mpfr-static
14
15 %description
16 MPC is a C library for the arithmetic of complex numbers with
17 arbitrarily high precision and correct rounding of the result. It is
18 built upon and follows the same principles as MPFR.
19
20 %prep
21 %setup -q
22 cp %{SOURCE1001} .
23
24 %build
25 %configure \
26     --disable-shared \
27     --enable-static
28 make %{?_smp_mflags}
29
30 %check
31 make check %{?_smp_mflags}
32
33 %install
34 %make_install
35
36 %files
37 %manifest mpc.manifest
38 %defattr(-,root,root)
39 %doc AUTHORS NEWS COPYING.LESSER
40 %doc %{_infodir}/mpc.info.gz
41 %{_libdir}/libmpc.a
42 /usr/include/mpc.h
43
44 %changelog