17a56b9e89c3d4c081112beceddd760452b64003
[platform/upstream/mpc.git] / packaging / mpc.spec
1 %define keepstatic 1
2 Name:           mpc
3 Version:        1.0
4 Release:        0
5 License:        LGPL-3.0+
6 Summary:        MPC multiple-precision complex shared library
7 Url:            http://www.multiprecision.org/mpc/
8 Group:          Development/Libraries/C and C++
9 Source:         mpc-%{version}.tar.bz2
10 Source2:        baselibs.conf
11 Source1001:     mpc.manifest
12 BuildRequires:  gmp-devel
13 BuildRequires:  mpfr-devel
14
15 %description
16 MPC is a C library for the arithmetic of complex numbers with
17 arbitrarily high precision and correct rounding of the result. It is
18 built upon and follows the same principles as MPFR.
19
20 %package -n libmpc
21 Summary:        MPC multiple-precision complex shared library
22 Group:          Development/Libraries/C and C++
23
24 %description -n libmpc
25 MPC is a C library for the arithmetic of complex numbers with
26 arbitrarily high precision and correct rounding of the result. It is
27 built upon and follows the same principles as MPFR.
28
29 %package devel
30 Summary:        MPC multiple-precision complex library development files
31 Group:          Development/Libraries/C and C++
32 Requires:       libmpc = %{version}
33 Requires:       mpfr-devel
34
35 %description devel
36 MPC multiple-precision complex library development files.
37
38 %prep
39 %setup -q
40 cp %{SOURCE1001} .
41
42 %build
43 %configure
44 make %{?_smp_mflags}
45
46 %check
47 make check %{?_smp_mflags}
48
49 %install
50 %make_install
51
52 %post -n libmpc -p /sbin/ldconfig
53
54 %postun -n libmpc -p /sbin/ldconfig
55
56
57 %files -n libmpc
58 %manifest %{name}.manifest
59 %defattr(-,root,root)
60 %{_libdir}/libmpc.so.3*
61
62 %files devel
63 %manifest %{name}.manifest
64 %defattr(-,root,root)
65 %doc AUTHORS NEWS COPYING.LESSER
66 %doc %{_infodir}/mpc.info.gz
67 %{_libdir}/libmpc.a
68 %{_libdir}/libmpc.so
69 /usr/include/mpc.h
70
71 %changelog