Revert "Remove Profile Build Dependency"
[platform/adaptation/emulator/model-config-emulator.git] / packaging / model-config-emulator.spec
1 %define debug_package %{nil}
2
3 Name:           model-config-emulator
4 Summary:        A Model configuration
5 Version:        0.0.2
6 Release:        0
7 Group:          System/Configuration
8 License:        Apache-2.0
9 Source0:        %{name}-%{version}.tar.gz
10
11 %description
12 Model configuration data package
13
14 %prep
15 %setup -q -n %{name}-%{version}
16
17 %build
18
19 %install
20 rm -rf %{buildroot}
21 mkdir -p %{buildroot}%{_sysconfdir}/config
22
23 %define config_xml model-config_mobile.xml
24
25 %if "%{?profile}" == "wearable"
26 %define config_xml model-config_wearable.xml
27 %endif
28
29 %if "%{?profile}" == "tv"
30 %define config_xml model-config_tv.xml
31 %endif
32
33 %if "%{?profile}" == "mobile"
34 %ifarch x86_64
35 %define config_xml model-config_mobile64.xml
36 %else
37 %define config_xml model-config_mobile.xml
38 %endif
39 %endif
40
41 cp -f %{config_xml} %{buildroot}%{_sysconfdir}/config/model-config.xml
42
43 %files
44 %config %{_sysconfdir}/config/model-config.xml
45 %manifest model-config.manifest
46 %license LICENSE.Apache-2.0