Update for tizen_2.1
[framework/connectivity/mobileap-agent.git] / packaging / mobileap-agent.spec
1 Name:       mobileap-agent
2 Summary:    Mobile AP daemon for setting tethering environments
3 Version:    0.1.87
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Flora License
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires: pkgconfig(dlog)
9 BuildRequires: pkgconfig(dbus-glib-1)
10 BuildRequires: pkgconfig(glib-2.0)
11 BuildRequires: pkgconfig(gthread-2.0)
12 BuildRequires: pkgconfig(pmapi)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(notification)
15 BuildRequires: pkgconfig(libssl)
16 BuildRequires: pkgconfig(secure-storage)
17 BuildRequires: pkgconfig(capi-network-connection)
18 BuildRequires: pkgconfig(capi-network-bluetooth)
19 BuildRequires: cmake
20 Requires(post): /usr/bin/vconftool
21 Requires: iptables
22 Requires: dnsmasq
23 %description
24 Mobile AP daemon for setting tethering environments
25
26 %prep
27 %setup -q
28
29 %build
30 %cmake .
31 make %{?jobs:-j%jobs}
32
33 %install
34 %make_install
35
36 %post
37 /usr/bin/vconftool set -t int memory/mobile_hotspot/connected_device "0" -u 0 -i -f
38 /usr/bin/vconftool set -t int memory/mobile_hotspot/mode "0" -u 0 -i -f
39 /usr/bin/vconftool set -t int db/mobile_hotspot/security "0" -u 0 -f
40 /usr/bin/vconftool set -t int db/mobile_hotspot/hide "0" -u 0 -f
41
42 %files
43 %manifest mobileap-agent.manifest
44 %defattr(-,root,root,-)
45 /usr/share/dbus-1/services/org.tizen.tethering.service
46 %{_bindir}/mobileap-agent
47
48 %changelog
49 * Tue Apr 09 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.86-1
50 - Fix the multiple notification issue
51 - Support i80211n
52 - Channel is changed to 6
53 - Implement status notification for bluetooth visibility
54 - Change the power manager api
55 - Implement connection timer
56 - Reference count is used
57 - Support Mobile AP
58
59 * Sat Feb 16 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.85-2
60 - Function return value is checked
61 - Private SSID is considered
62 - Build option clean-up and g_type_init is deprecated from glib 2.35
63
64 * Thu Feb 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.84-1
65 - User is specified in service file for Dbus auto activation
66
67 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.83-1
68 - Remove unrequired log
69
70 * Thu Jan 24 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.82-1
71 - Indications for Wi-Fi tethering setting change are added
72 - DNS Forward and Use of Tethering cellular profile are removed
73 - Dbus service / interface / object names are changed
74
75 * Mon Jan 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.81-1
76 - dhcp lease delete is handled based on IP Address
77 - DNS Forward by netfilter is implemented
78 - Vconf key for flight mode is changed
79
80 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.80-1
81 - Notification API's usage is changed
82 - Duplicated station information issue is fixed
83 - Improper notification type is used
84 - Timeout(Auto disconnection) feature is implemented
85 - Notification for timeout event is implemented
86
87 * Thu Nov 08 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.79-1
88 - Notification's API usage is changed
89
90 * Tue Nov 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.78-1
91 - Unnecessary BT API is removed
92
93 * Sat Nov 03 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.77-1
94 - Prevent issues are fixed
95
96 * Tue Oct 30 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.76-1
97 - Vconf enum is changed (SETTING_USB_MOBILE_HOTSPOT -> SETTING_USB_TETHERING_MODE)
98 - Private code is separated
99
100 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.75-1
101 - Code clean-up and path for notification icon is changed
102
103 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.74-1
104 - License is added
105
106 * Thu Oct 11 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.73-1
107 - Source package name is changed (libmobileap -> mobileap-agent)
108
109 * Thu Oct 11 2012 Injun Yang <injun.yang@samsung.com> 0.1.72-1
110 - Launch kcp-agent
111
112 * Fri Sep 28 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.71-1
113 - Fix memory corruption
114
115 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.70-1
116 - Manifest file is added for SMACK
117
118 * Wed Sep 19 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.69-1
119 - The code for Legacy APIs is removed
120
121 * Wed Sep 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.68-1
122 - Bluetooth PAN Managed APIs are applied
123 - MDM Phase 2 implementation
124
125 * Wed Sep 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.67-1
126 - Connection Managed APIs are applied
127 - Network status is not checked in agent
128
129 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.66-1
130 - Wi-Fi tethering setting values are managed here
131 - Deprecated APIs from glib-2.3.0 are replaced
132 - Notification Icon is changed
133
134 * Fri Jul 13 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.65-1
135 - Wi-Fi tethering disable / enable issues are fixed
136
137 * Fri Jul 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.64-1
138 - Unnecessary dependency is removed
139
140 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.63-1
141 - Data usage is fixed
142
143 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.62-1
144 - Wi-Fi tethering security is implemented
145 - API for getting USB interface information is implemented
146
147 * Wed May 23 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.61-1
148 - Tethering app. dependency is added
149
150 * Tue May 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.60-1
151 - Wi-Fi interface name is changed from eth0 to wlan0
152
153 * Tue May 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.59-1
154 - Below changes are applied
155 - Ignore mdm failure case
156 - CAPI bugs are fixed
157 - Bug of _remove_station_info_all() is fixed
158 - Launch tethering applicatoin from notification
159
160 * Tue May 08 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.58-1
161 - Hostapd control interface is implemented
162
163 * Mon Apr 09 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.57-1
164 - Unused vconfkey is removed
165
166 * Wed Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.56-1
167 - Export API's are changed
168
169 * Mon Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.55-2
170 - Fix build error
171
172 * Mon Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.55-1
173 - Test code is modified
174 - Code clean-up
175 - Notification is implemented
176 - MDM bug fix