User is specified in service file for Dbus auto activation
[framework/connectivity/mobileap-agent.git] / packaging / mobileap-agent.spec
1 Name:       mobileap-agent
2 Summary:    Mobile AP daemon for setting tethering environments
3 Version:    0.1.84
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Apache License Version 2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires: pkgconfig(dlog)
9 BuildRequires: pkgconfig(dbus-glib-1)
10 BuildRequires: pkgconfig(glib-2.0)
11 BuildRequires: pkgconfig(gthread-2.0)
12 BuildRequires: pkgconfig(pmapi)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(notification)
15 BuildRequires: pkgconfig(libssl)
16 BuildRequires: pkgconfig(secure-storage)
17 BuildRequires: pkgconfig(capi-network-connection)
18 BuildRequires: pkgconfig(capi-network-bluetooth)
19 BuildRequires: cmake
20 Requires(post): /usr/bin/vconftool
21 Requires: iptables
22 Requires: dnsmasq
23 %description
24 Mobile AP daemon for setting tethering environments
25
26 %prep
27 %setup -q
28
29 %build
30 export CFLAGS+=" -fpie"
31 CFLAGS="${CFLAGS}" cmake . -DCMAKE_INSTALL_PREFIX="%{_prefix}"
32 make %{?jobs:-j%jobs}
33
34 %install
35 rm -rf %{buildroot}
36 %make_install
37
38 %post
39 /usr/bin/vconftool set -t int memory/mobile_hotspot/connected_device "0" -u 0 -i -f
40 /usr/bin/vconftool set -t int memory/mobile_hotspot/mode "0" -u 0 -i -f
41 /usr/bin/vconftool set -t int db/mobile_hotspot/security "0" -u 0 -f
42 /usr/bin/vconftool set -t int db/mobile_hotspot/hide "0" -u 0 -f
43
44 %files
45 %manifest mobileap-agent.manifest
46 %defattr(-,root,root,-)
47 /usr/share/dbus-1/services/org.tizen.tethering.service
48 %{_bindir}/mobileap-agent
49
50 %changelog
51 * Thu Feb 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.84-1
52 - User is specified in service file for Dbus auto activation
53
54 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.83-1
55 - Remove unrequired log
56
57 * Thu Jan 24 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.82-1
58 - Indications for Wi-Fi tethering setting change are added
59 - DNS Forward and Use of Tethering cellular profile are removed
60 - Dbus service / interface / object names are changed
61
62 * Mon Jan 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.81-1
63 - dhcp lease delete is handled based on IP Address
64 - DNS Forward by netfilter is implemented
65 - Vconf key for flight mode is changed
66
67 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.80-1
68 - Notification API's usage is changed
69 - Duplicated station information issue is fixed
70 - Improper notification type is used
71 - Timeout(Auto disconnection) feature is implemented
72 - Notification for timeout event is implemented
73
74 * Thu Nov 08 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.79-1
75 - Notification's API usage is changed
76
77 * Tue Nov 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.78-1
78 - Unnecessary BT API is removed
79
80 * Sat Nov 03 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.77-1
81 - Prevent issues are fixed
82
83 * Tue Oct 30 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.76-1
84 - Vconf enum is changed (SETTING_USB_MOBILE_HOTSPOT -> SETTING_USB_TETHERING_MODE)
85 - Private code is separated
86
87 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.75-1
88 - Code clean-up and path for notification icon is changed
89
90 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.74-1
91 - License is added
92
93 * Thu Oct 11 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.73-1
94 - Source package name is changed (libmobileap -> mobileap-agent)
95
96 * Thu Oct 11 2012 Injun Yang <injun.yang@samsung.com> 0.1.72-1
97 - Launch kcp-agent
98
99 * Fri Sep 28 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.71-1
100 - Fix memory corruption
101
102 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.70-1
103 - Manifest file is added for SMACK
104
105 * Wed Sep 19 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.69-1
106 - The code for Legacy APIs is removed
107
108 * Wed Sep 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.68-1
109 - Bluetooth PAN Managed APIs are applied
110 - MDM Phase 2 implementation
111
112 * Wed Sep 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.67-1
113 - Connection Managed APIs are applied
114 - Network status is not checked in agent
115
116 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.66-1
117 - Wi-Fi tethering setting values are managed here
118 - Deprecated APIs from glib-2.3.0 are replaced
119 - Notification Icon is changed
120
121 * Fri Jul 13 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.65-1
122 - Wi-Fi tethering disable / enable issues are fixed
123
124 * Fri Jul 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.64-1
125 - Unnecessary dependency is removed
126
127 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.63-1
128 - Data usage is fixed
129
130 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.62-1
131 - Wi-Fi tethering security is implemented
132 - API for getting USB interface information is implemented
133
134 * Wed May 23 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.61-1
135 - Tethering app. dependency is added
136
137 * Tue May 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.60-1
138 - Wi-Fi interface name is changed from eth0 to wlan0
139
140 * Tue May 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.59-1
141 - Below changes are applied
142 - Ignore mdm failure case
143 - CAPI bugs are fixed
144 - Bug of _remove_station_info_all() is fixed
145 - Launch tethering applicatoin from notification
146
147 * Tue May 08 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.58-1
148 - Hostapd control interface is implemented
149
150 * Mon Apr 09 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.57-1
151 - Unused vconfkey is removed
152
153 * Wed Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.56-1
154 - Export API's are changed
155
156 * Mon Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.55-2
157 - Fix build error
158
159 * Mon Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.55-1
160 - Test code is modified
161 - Code clean-up
162 - Notification is implemented
163 - MDM bug fix