4b97ee4a3fc085530ed13ab86c2b850bc110e262
[framework/connectivity/mobileap-agent.git] / packaging / mobileap-agent.spec
1 Name:       mobileap-agent
2 Summary:    Mobile AP daemon for setting tethering environments
3 Version:    0.1.80
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Apache License Version 2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires: pkgconfig(dlog)
9 BuildRequires: pkgconfig(dbus-glib-1)
10 BuildRequires: pkgconfig(glib-2.0)
11 BuildRequires: pkgconfig(gthread-2.0)
12 BuildRequires: pkgconfig(pmapi)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(notification)
15 BuildRequires: pkgconfig(libssl)
16 BuildRequires: pkgconfig(secure-storage)
17 BuildRequires: pkgconfig(capi-network-connection)
18 BuildRequires: pkgconfig(capi-network-bluetooth)
19 BuildRequires: cmake
20 Requires(post): /usr/bin/vconftool
21 Requires: iptables
22 Requires: dnsmasq
23 %description
24 Mobile AP daemon for setting tethering environments
25
26 %prep
27 %setup -q
28
29 %build
30 export CFLAGS+=" -fpie"
31 CFLAGS="${CFLAGS}" cmake . -DCMAKE_INSTALL_PREFIX="%{_prefix}"
32 make %{?jobs:-j%jobs}
33
34 %install
35 rm -rf %{buildroot}
36 %make_install
37
38 %post
39 /usr/bin/vconftool set -t int memory/mobile_hotspot/connected_device "0" -u 0 -i -f
40 /usr/bin/vconftool set -t int memory/mobile_hotspot/mode "0" -u 0 -i -f
41 /usr/bin/vconftool set -t int db/mobile_hotspot/security "0" -u 0 -f
42 /usr/bin/vconftool set -t int db/mobile_hotspot/hide "0" -u 0 -f
43
44 %files
45 %manifest mobileap-agent.manifest
46 %defattr(-,root,root,-)
47 /usr/share/dbus-1/services/com.samsung.mobileap.service
48 %{_bindir}/mobileap-agent
49
50 %changelog
51 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.80-1
52 - Notification API's usage is changed
53 - Duplicated station information issue is fixed
54 - Improper notification type is used
55 - Timeout(Auto disconnection) feature is implemented
56 - Notification for timeout event is implemented
57
58 * Thu Nov 08 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.79-1
59 - Notification's API usage is changed
60
61 * Tue Nov 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.78-1
62 - Unnecessary BT API is removed
63
64 * Sat Nov 03 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.77-1
65 - Prevent issues are fixed
66
67 * Tue Oct 30 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.76-1
68 - Vconf enum is changed (SETTING_USB_MOBILE_HOTSPOT -> SETTING_USB_TETHERING_MODE)
69 - Private code is separated
70
71 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.75-1
72 - Code clean-up and path for notification icon is changed
73
74 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.74-1
75 - License is added
76
77 * Thu Oct 11 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.73-1
78 - Source package name is changed (libmobileap -> mobileap-agent)
79
80 * Thu Oct 11 2012 Injun Yang <injun.yang@samsung.com> 0.1.72-1
81 - Launch kcp-agent
82
83 * Fri Sep 28 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.71-1
84 - Fix memory corruption
85
86 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.70-1
87 - Manifest file is added for SMACK
88
89 * Wed Sep 19 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.69-1
90 - The code for Legacy APIs is removed
91
92 * Wed Sep 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.68-1
93 - Bluetooth PAN Managed APIs are applied
94 - MDM Phase 2 implementation
95
96 * Wed Sep 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.67-1
97 - Connection Managed APIs are applied
98 - Network status is not checked in agent
99
100 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.66-1
101 - Wi-Fi tethering setting values are managed here
102 - Deprecated APIs from glib-2.3.0 are replaced
103 - Notification Icon is changed
104
105 * Fri Jul 13 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.65-1
106 - Wi-Fi tethering disable / enable issues are fixed
107
108 * Fri Jul 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.64-1
109 - Unnecessary dependency is removed
110
111 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.63-1
112 - Data usage is fixed
113
114 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.62-1
115 - Wi-Fi tethering security is implemented
116 - API for getting USB interface information is implemented
117
118 * Wed May 23 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.61-1
119 - Tethering app. dependency is added
120
121 * Tue May 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.60-1
122 - Wi-Fi interface name is changed from eth0 to wlan0
123
124 * Tue May 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.59-1
125 - Below changes are applied
126 - Ignore mdm failure case
127 - CAPI bugs are fixed
128 - Bug of _remove_station_info_all() is fixed
129 - Launch tethering applicatoin from notification
130
131 * Tue May 08 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.58-1
132 - Hostapd control interface is implemented
133
134 * Mon Apr 09 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.57-1
135 - Unused vconfkey is removed
136
137 * Wed Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.56-1
138 - Export API's are changed
139
140 * Mon Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.55-2
141 - Fix build error
142
143 * Mon Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.55-1
144 - Test code is modified
145 - Code clean-up
146 - Notification is implemented
147 - MDM bug fix