Clean up spec file for packaging
[profile/ivi/mlite.git] / packaging / mlite.spec
1 %define buildwayland 1 
2 %if %{buildwayland}
3 %define backend wayland
4 %else
5 %define backend xlib
6 %endif
7
8 Name:       mlite-%{backend}
9 Summary:    Touchscreen classes for UX-IVI support
10 Version:    0.1.2
11 Release:    1
12 Group:      System/Libraries
13 License:    LGPL v2.1
14 URL:        http://www.tizen.org
15 Source0:    %{name}-%{version}.tar.bz2
16
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19 BuildRequires:  pkgconfig(gconf-2.0)
20 BuildRequires:  pkgconfig(QtCore-%{backend})
21 BuildRequires:  pkgconfig(QtOpenGL-%{backend})
22
23 %description
24 Select set of useful classes to support touchscreen for UX-IVI support.
25
26
27 %package devel
28 Summary:    mlite development package
29 Group:      System/Libraries
30 Requires:   %{name} = %{version}-%{release}
31
32 %description devel
33 Development files needed for using the mlite library
34
35
36 %prep
37 %setup -q -n %{name}-%{version}
38
39 %build
40
41 %qmake CONFIG+=%{backend}
42
43 make %{?jobs:-j%jobs}
44
45 %install
46 rm -rf %{buildroot}
47 %qmake_install
48
49 %post -p /sbin/ldconfig
50 %postun -p /sbin/ldconfig
51
52 %files
53 %defattr(-,root,root,-)
54 /usr/lib/*.so.*
55
56 %files devel
57 %defattr(-,root,root,-)
58 /usr/include/mlite-%{backend}
59 /usr/lib/pkgconfig/*.pc
60 /usr/lib/*.so
61