Fix spec
[profile/ivi/mingetty.git] / packaging / mingetty.spec
1 #specfile originally created for Fedora, modified for Moblin Linux
2 Summary: A compact getty program for virtual consoles only
3 Name: mingetty
4 Version: 1.08
5 License: GPLv2+
6 Release: 3.9
7 Group: System/Base
8 URL: http://sourceforge.net/projects/mingetty/
9 Source: %{name}-%{version}.tar.bz2
10 Patch1: mingetty-1.00-opt.patch
11 BuildRoot: %{_tmppath}/%{name}-root
12
13 %description
14 The mingetty program is a lightweight, minimalist getty program for
15 use only on virtual consoles.  Mingetty is not suitable for serial
16 lines (you should use the mgetty program in that case).
17
18 %prep
19 %setup -q -n %{name}-%{version}
20 %patch1 -p1
21
22 %build
23 make "RPM_OPTS=$RPM_OPT_FLAGS"
24
25 %install
26 rm -rf $RPM_BUILD_ROOT
27 mkdir -p $RPM_BUILD_ROOT/{sbin,%{_mandir}/man8}
28
29 install -m 0755 mingetty $RPM_BUILD_ROOT/sbin/
30 install -m 0644 mingetty.8 $RPM_BUILD_ROOT/%{_mandir}/man8/
31
32 %clean
33 rm -rf $RPM_BUILD_ROOT
34
35 %files
36 %defattr(-,root,root)
37 %doc COPYING
38 /sbin/mingetty
39 %doc %{_mandir}/man8/mingetty.*