Bump up to 0.24.3
[platform/upstream/mic.git] / packaging / mic.spec
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3 %define rc_version 0
4
5 %if 0%{?rc_version}
6 %define release_prefix 0.rc%{rc_version}.
7 %endif
8
9 Name:       mic
10 Summary:    Image Creator for Linux Distributions
11 Version:    0.24.3
12 Release:    %{?release_prefix}%{?opensuse_bs:<CI_CNT>.<B_CNT>}%{!?opensuse_bs:0}
13 Group:      Development/Tools
14 License:    GPLv2
15 BuildArch:  noarch
16 URL:        http://www.tizen.org
17 Source0:    %{name}_%{version}.tar.gz
18
19 Requires:   python >= 2.6
20 Requires:   python-urlgrabber >= 3.9.0
21 %if 0%{?tizen_version:1}
22 Requires:   python-rpm
23 %else
24 Requires:   rpm-python
25 %endif
26
27 Requires:   cpio
28 # not neccessary
29 Requires:   gzip
30 Requires:   bzip2
31
32 BuildRequires:  python-devel
33 %if ! 0%{?tizen_version:1}
34 BuildRequires:  python-docutils
35 %endif
36
37 Obsoletes:  mic2
38
39 BuildRoot:  %{_tmppath}/%{name}_%{version}-build
40
41 %description
42 The tool mic is used to create and manipulate images for Linux distributions.
43 It is composed of three subcommand\: create, convert, chroot. Subcommand create
44 is used to create images with different types; subcommand convert is used to
45 convert an image to a specified type; subcommand chroot is used to chroot into
46 an image.
47
48 %package native
49 Summary:    Native support for mic
50 Requires:   util-linux
51 Requires:   coreutils
52 Requires:   psmisc
53 Requires:   e2fsprogs
54 Requires:   dosfstools >= 2.11
55 Requires:   kpartx
56 Requires:   parted
57 Requires:   device-mapper
58 Requires:   syslinux >= 3.82
59 %if ! 0%{?suse_version}
60 Requires:   syslinux-extlinux >= 3.82
61 %endif
62
63 %if 0%{?suse_version} || 0%{?tizen_version:1}
64 Requires:   squashfs >= 4.0
65 Requires:   python-m2crypto
66 %else
67 Requires:   squashfs-tools >= 4.0
68 Requires:   m2crypto
69 %endif
70
71 %if 0%{?suse_version} || 0%{?tizen_version:1}
72 Requires:   /usr/bin/qemu-arm
73 %else
74 Requires:   qemu-arm-static
75 %endif
76
77 %if ! 0%{?tizen_version:1}
78 Requires:   isomd5sum
79 Requires:   /usr/bin/genisoimage
80 %endif
81
82 Requires:   yum >= 3.2.24
83 %if 0%{?tizen_version:1}
84 Requires:   python-zypp
85 %else
86 Requires:   python-zypp-tizen
87 %endif
88
89 Requires:   mic
90
91 #%if 0%{?suse_version}
92 #Requires:   btrfsprogs
93 #%else
94 #Requires:   btrfs-progs
95 #%endif
96
97 %description native
98 The native support package for mic, it includes all requirements
99 for mic native running.
100
101 %prep
102 %setup -q -n %{name}-%{version}
103
104 %build
105 CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
106 make man
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 %if 0%{?suse_version}
111 %{__python} setup.py install --root=$RPM_BUILD_ROOT --prefix=%{_prefix}
112 %else
113 %{__python} setup.py install --root=$RPM_BUILD_ROOT -O1
114 %endif
115
116 # install man page
117 mkdir -p %{buildroot}/%{_prefix}/share/man/man1
118 install -m644 doc/mic.1 %{buildroot}/%{_prefix}/share/man/man1
119
120 # install bash completion
121 install -d -m0755 %{buildroot}/%{_sysconfdir}/bash_completion.d/
122 install -Dp -m0755 etc/bash_completion.d/%{name}.sh %{buildroot}/%{_sysconfdir}/bash_completion.d/
123
124 # install zsh completion
125 install -d -m0755 %{buildroot}/%{_sysconfdir}/zsh_completion.d/
126 install -Dp -m0755 etc/zsh_completion.d/_%{name} %{buildroot}/%{_sysconfdir}/zsh_completion.d/
127
128 install -Dp -m0755 tools/mic %{buildroot}/%{_bindir}/mic-native
129
130 %files
131 %defattr(-,root,root,-)
132 %doc doc/*
133 %doc README.rst AUTHORS COPYING ChangeLog
134 %if ! 0%{?tizen_version:1}
135 %{_mandir}/man1/*
136 %endif
137 %dir %{_sysconfdir}/%{name}
138 %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
139 %{python_sitelib}/*
140 %dir %{_prefix}/lib/%{name}
141 %{_prefix}/lib/%{name}/*
142 %{_bindir}/mic
143 %{_sysconfdir}/bash_completion.d
144 %{_sysconfdir}/zsh_completion.d
145
146 %files native
147 %{_bindir}/mic-native