Fix TFDF-1769,TFDF-1768 ASAN issues
[platform/core/location/maps-plugin-here.git] / packaging / maps-plugin-here.spec
1 Name:       maps-plugin-here
2 Summary:    Tizen HERE Maps Plug-in Library
3 Version:    0.4.2
4 Release:    1
5 Group:      Location/Libraries
6 License:    Apache-2.0 and HERE
7 Source0:    %{name}-%{version}.tar.gz
8 ExclusiveArch:  %ix86 x86_64 %arm aarch64
9
10 BuildRequires: cmake
11 # for here plugin
12 BuildRequires: pkgconfig(glib-2.0)
13 BuildRequires: pkgconfig(gio-2.0)
14 BuildRequires: pkgconfig(gio-unix-2.0)
15 BuildRequires: pkgconfig(gmodule-2.0)
16 BuildRequires: pkgconfig(libxml-2.0)
17 BuildRequires: pkgconfig(dlog)
18 BuildRequires: pkgconfig(capi-maps-service)
19 BuildRequires: capi-maps-service-plugin-devel
20 BuildRequires: pkgconfig(capi-network-connection)
21 BuildRequires: pkgconfig(capi-appfw-app-manager)
22 BuildRequires: pkgconfig(capi-appfw-application)
23 BuildRequires: pkgconfig(capi-system-info)
24 BuildRequires: pkgconfig(efl-extension)
25 BuildRequires: pkgconfig(elementary)
26 BuildRequires: pkgconfig(vconf)
27 BuildRequires: pkgconfig(appcore-efl)
28 BuildRequires: pkgconfig(ecore)
29 BuildRequires: pkgconfig(evas)
30 BuildRequires: pkgconfig(edje)
31 BuildRequires: gettext-tools
32 BuildRequires: edje-bin
33 # for here engine
34 BuildRequires: pkgconfig(libcurl)
35 BuildRequires: pkgconfig(json-c)
36 BuildRequires: pkgconfig(libpng)
37 BuildRequires: pkgconfig(cairo)
38 BuildRequires: boost-devel
39 BuildRequires: capi-maps-service-devel
40 BuildRequires: elementary-devel
41 BuildRequires: pkgconfig(ecore-evas)
42 #
43 Requires(post): /sbin/ldconfig
44 Requires(postun): /sbin/ldconfig
45
46 %ifarch %arm
47 %define ARCH armv7l
48 %endif
49
50 %ifarch aarch64
51 %define ARCH aarch64
52 %endif
53
54 %ifarch %ix86
55 %define ARCH i586
56 %endif
57
58 %ifarch x86_64
59 %define ARCH x86_64
60 %endif
61
62 %description
63 This package provides Plugin APIs capsulating HERE Maps Engine Library for Maps Service Library.
64
65 %prep
66 %setup -q
67
68 %build
69
70 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
71 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DMAJORVER=${MAJORVER} -DFULLVER=%{version} -DLIBDIR=%{_libdir} -DARCH=%{ARCH} -DSYSCONF_DIR=%{_sysconfdir}
72 make %{?jobs:-j%jobs}
73
74 %install
75 rm -rf %{buildroot}
76 %make_install
77
78 cp -a lib/%{ARCH}/libheremaps-engine.so* %{buildroot}%{_libdir}/
79
80 %post
81 /sbin/ldconfig
82
83 %postun
84 /sbin/ldconfig
85
86 %files
87 %manifest maps-plugin-here.manifest
88 %license LICENSE
89 %defattr(-,root,root,-)
90 %{_libdir}/maps/plugins/libmaps-plugin-here.so*
91 %{_libdir}/libheremaps-engine.so*
92
93
94 %package -n org.tizen.heremaps-uc
95 Summary:    HereMaps UC popup
96 Requires:   %{name} = %{version}-%{release}
97
98 %description -n org.tizen.heremaps-uc
99 This package provides UI interface to get consents from users to the HERE platform Service.
100
101 %files -n org.tizen.heremaps-uc
102 %manifest heremaps-uc/org.tizen.heremaps-uc.manifest
103 %license LICENSE
104 %defattr(-,root,root,-)
105 /usr/apps/org.tizen.heremaps-uc/bin/*
106 /usr/apps/org.tizen.heremaps-uc/res/locale
107 /usr/apps/org.tizen.heremaps-uc/res/edje/*.edj
108 /usr/share/packages/org.tizen.heremaps-uc.xml
109
110
111 %package -n heremaps-uc-launcher
112 Summary:    HereMpas-UC Launcher deamon
113 Requires:   %{name} = %{version}-%{release}
114
115 %description -n heremaps-uc-launcher
116 This package is for launching the org.tizen.heremaps-uc application.
117
118 %files -n heremaps-uc-launcher
119 %manifest heremaps-uc-launcher/heremaps-uc-launcher.manifest
120 %license LICENSE
121 %defattr(-,root,root,-)
122 /usr/bin/heremaps-uc-launcher
123 /usr/share/dbus-1/services/org.tizen.lbs.Providers.HereMapsUCLauncher.service
124 %config %{_sysconfdir}/dbus-1/session.d/heremaps-uc-launcher.conf