tizen 2.4 release
[framework/location/maps-plugin-here.git] / packaging / maps-plugin-here.spec
1 Name:       maps-plugin-here
2 Summary:    Tizen HERE Maps Plug-in Library
3 Version:    0.1.4
4 Release:    1
5 Group:      Location/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires: cmake
10 BuildRequires: pkgconfig(glib-2.0)
11 BuildRequires: pkgconfig(gmodule-2.0)
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(capi-maps-service)
14 BuildRequires: capi-maps-service-plugin-devel
15 BuildRequires: pkgconfig(heremaps-engine)
16 BuildRequires: pkgconfig(capi-network-connection)
17 BuildRequires: pkgconfig(capi-appfw-app-manager)
18 Requires(post): /sbin/ldconfig
19 Requires(postun): /sbin/ldconfig
20
21 %description
22 This packages provides Plugin APIs capsulating HERE Maps Engine Library for Maps Service Library.
23
24 %prep
25 %setup -q
26
27 %build
28 %if 0%{?tizen_build_binary_release_type_eng}
29 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE -g"
30 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE -g"
31 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
32 %endif
33
34 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
35 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DMAJORVER=${MAJORVER} -DFULLVER=%{version} -DLIBDIR=%{_libdir}
36 make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41
42 mkdir -p %{buildroot}/usr/share/license
43 cp LICENSE %{buildroot}/usr/share/license/%{name}
44
45 %post
46 /sbin/ldconfig
47
48 %postun
49 /sbin/ldconfig
50
51 %files
52 %manifest maps-plugin-here.manifest
53 %defattr(-,root,root,-)
54 %{_libdir}/maps/plugins/libmaps-plugin-here.so*
55 /usr/share/license/maps-plugin-here