28cfc5689d894dee009a937054ec0f2d8dd57c48
[platform/core/location/maps-plugin-here.git] / packaging / maps-plugin-here.spec
1 Name:       maps-plugin-here
2 Summary:    Tizen HERE Maps Plug-in Library
3 Version:    0.3.5
4 Release:    1
5 Group:      Location/Libraries
6 License:    Apache-2.0 and HERE
7 Source0:    %{name}-%{version}.tar.gz
8 ExclusiveArch:  %ix86 x86_64 %arm aarch64
9
10 BuildRequires: cmake
11 # for here plugin
12 BuildRequires: pkgconfig(glib-2.0)
13 BuildRequires: pkgconfig(gio-2.0)
14 BuildRequires: pkgconfig(gio-unix-2.0)
15 BuildRequires: pkgconfig(gmodule-2.0)
16 BuildRequires: pkgconfig(libxml-2.0)
17 BuildRequires: pkgconfig(dlog)
18 BuildRequires: pkgconfig(capi-maps-service)
19 BuildRequires: capi-maps-service-plugin-devel
20 BuildRequires: pkgconfig(capi-network-connection)
21 BuildRequires: pkgconfig(capi-appfw-app-manager)
22 BuildRequires: pkgconfig(capi-appfw-application)
23 BuildRequires: pkgconfig(capi-system-info)
24 BuildRequires: pkgconfig(efl-extension)
25 BuildRequires: pkgconfig(elementary)
26 BuildRequires: pkgconfig(vconf)
27 BuildRequires: pkgconfig(appcore-efl)
28 BuildRequires: pkgconfig(ecore)
29 BuildRequires: pkgconfig(evas)
30 BuildRequires: gettext-tools
31 # for here engine
32 BuildRequires: pkgconfig(libcurl)
33 BuildRequires: pkgconfig(json-c)
34 BuildRequires: pkgconfig(libpng)
35 BuildRequires: pkgconfig(cairo)
36 BuildRequires: boost-devel
37 BuildRequires: capi-maps-service-devel
38 BuildRequires: elementary-devel
39 BuildRequires: pkgconfig(ecore-evas)
40 #
41 Requires(post): /sbin/ldconfig
42 Requires(postun): /sbin/ldconfig
43
44 %ifarch %arm
45 %define ARCH arm
46 %endif
47
48 %ifarch aarch64
49 %define ARCH aarch64
50 %endif
51
52 %ifarch %ix86
53 %define ARCH i586
54 %endif
55
56 %ifarch x86_64
57 %define ARCH x86_64
58 %endif
59
60 %description
61 This package provides Plugin APIs capsulating HERE Maps Engine Library for Maps Service Library.
62
63 %prep
64 %setup -q
65
66 %build
67
68 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
69 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DMAJORVER=${MAJORVER} -DFULLVER=%{version} -DLIBDIR=lib -DARCH=%{ARCH} -DSYSCONF_DIR=%{_sysconfdir}
70 make %{?jobs:-j%jobs}
71
72 %install
73 rm -rf %{buildroot}
74 %make_install
75
76 mkdir -p %{buildroot}/usr/share/license
77 cp LICENSE %{buildroot}/usr/share/license/%{name}
78 cp -a lib/%{ARCH}/libheremaps-engine.so* %{buildroot}%{_prefix}/lib/
79
80 %post
81 /sbin/ldconfig
82
83 %postun
84 /sbin/ldconfig
85
86 %files
87 %manifest maps-plugin-here.manifest
88 %defattr(-,root,root,-)
89 %{_prefix}/lib/maps/plugins/libmaps-plugin-here.so*
90 %{_prefix}/lib/libheremaps-engine.so*
91 /usr/share/license/maps-plugin-here
92
93
94 %package -n org.tizen.heremaps-uc
95 Summary:    HereMaps UC popup
96 Requires:   %{name} = %{version}-%{release}
97
98 %description -n org.tizen.heremaps-uc
99 This package provides UI interface to get consents from users to the HERE platform Service.
100
101 %files -n org.tizen.heremaps-uc
102 %manifest heremaps-uc/org.tizen.heremaps-uc.manifest
103 %defattr(-,root,root,-)
104 /usr/apps/org.tizen.heremaps-uc/bin/*
105 /usr/apps/org.tizen.heremaps-uc/res/locale
106 /usr/share/packages/org.tizen.heremaps-uc.xml
107
108
109 %package -n heremaps-uc-launcher
110 Summary:    HereMpas-UC Launcher deamon
111 Requires:   %{name} = %{version}-%{release}
112
113 %description -n heremaps-uc-launcher
114 This package is for launching the org.tizen.heremaps-uc application.
115
116 %files -n heremaps-uc-launcher
117 %manifest heremaps-uc-launcher/heremaps-uc-launcher.manifest
118 %defattr(-,root,root,-)
119 /usr/bin/heremaps-uc-launcher
120 /usr/share/dbus-1/services/org.tizen.lbs.Providers.HereMapsUCLauncher.service
121 %config %{_sysconfdir}/dbus-1/session.d/heremaps-uc-launcher.conf