packaging: Set up stack overflow checks values
[platform/upstream/m4.git] / packaging / m4.spec
1 Name:           m4
2 Version:        1.4.17
3 Release:        0
4 License:        GPL-3.0+
5 Summary:        GNU m4
6 Url:            http://www.gnu.org/software/m4/
7 Group:          Development/Languages/Other
8 Source:         http://ftp.gnu.org/pub/gnu/m4/%{name}-%{version}.tar.bz2
9 Source1001:     m4.manifest
10 Provides:       base:/usr/bin/m4
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
12
13 %description
14 GNU m4 is an implementation of the traditional Unix macro processor.
15
16 %prep
17 %setup -q
18 cp %{SOURCE1001} .
19
20 %build
21 %configure \
22             --without-included-regex \
23             gl_cv_func_isnanl_works=yes \
24             gl_cv_func_printf_directive_n=yes \
25             ac_cv_sys_stack_overflow_works=yes \
26             ac_cv_sys_xsi_stack_overflow_heuristic=yes
27
28 make %{?_smp_mflags}
29
30 %check
31 make %{?_smp_mflags} check || true
32
33 %install
34 %make_install
35
36 %files
37 %manifest %{name}.manifest
38 %defattr(-,root,root)
39 %doc COPYING
40 %{_bindir}/*
41 %doc %{_infodir}/*.gz
42 %{_mandir}/*/*