Apply patch for packaging: liblzma-tool
[platform/upstream/lzma-sdk.git] / packaging / lzma-sdk.spec
1 Name:           lzma-sdk
2 Url:            https://www.7-zip.org/sdk.html
3 Summary:        The SDK for LZMA Compression
4 Version:        9.20
5 Release:        1
6 Group:          System
7 License:        PD
8 Source0:        %{name}-%{version}.tar.gz
9
10 BuildRequires:  cmake
11
12 %define keepstatic 1
13
14 %description
15 LZMA SDK provides the documentation, samples, header files, libraries,
16 and tools you need to develop applications that use LZMA compression
17
18 %package -n liblzma-tool
19 Summary:        LZMA tool library package
20
21 %description -n liblzma-tool
22 LZMA tool shared library
23
24 %package -n liblzma-tool-devel
25 Summary:        LZMA tool library for (devel)
26
27 %description -n liblzma-tool-devel
28 LZMA tool library package for (devel)
29
30 %prep
31 %setup -q
32
33 %build
34 %cmake . \
35         -DCMAKE_INSTALL_PREFIX=%{_prefix}
36 make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41
42 %files -n liblzma-tool
43 %defattr(-,root,root,-)
44 %{_libdir}/liblzma-tool.so.*
45
46 %files -n liblzma-tool-devel
47 %defattr(-,root,root,-)
48 %{_includedir}/lzma-tool/*.h
49 %{_libdir}/liblzma-tool.so
50 %{_libdir}/liblzma-tool-static.a
51 %{_libdir}/pkgconfig/liblzma-tool.pc