986acd2fabf4e65e9d6831b98e74f26f016c09ce
[external/ltrace.git] / packaging / ltrace.spec
1 #sbs-git:slp/pkgs/l/ltrace ltrace 0.5.3 8b9a04c3142617c3019ee9e6eae64eda9a32c4ee
2 Name:       ltrace
3 Summary:    Tracks runtime library calls in dynamically linked programs
4 Version:    0.5.3
5 Release:    4
6 Group:      utils
7 License:    GPLv1
8 Source0:    ltrace-0.5.3.tar.gz
9 Source1001:     %{name}.manifest
10 BuildRequires:  binutils-devel
11 BuildRequires:  elfutils-libelf-devel
12
13
14 %description
15 Tracks runtime library calls in dynamically linked programs
16  ltrace is a debugging program which runs a specified command until it
17  exits.  While the command is executing, ltrace intercepts and records
18  the dynamic library calls which are called by
19  the executed process and the signals received by that process.
20  It can also intercept and print the system calls executed by the program.
21  .
22  The program to be traced need not be recompiled for this, so you can
23  use it on binaries for which you don't have the source handy.
24  .
25  You should install ltrace if you need a sysadmin tool for tracking the
26  execution of processes..
27
28 %prep
29 %setup -q
30
31 %build
32 cp %{SOURCE1001} .
33 %configure --disable-static
34 make
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39 rm -rf %{buildroot}%{_prefix}/share/doc/ltrace
40
41 mkdir -p $RPM_BUILD_ROOT%{_datadir}/license
42 for keyword in LICENSE COPYING COPYRIGHT;
43 do
44         for file in `find %{_builddir} -name $keyword`;
45         do
46                 cat $file >> $RPM_BUILD_ROOT%{_datadir}/license/%{name};
47                 echo "";
48         done;
49 done
50
51 %files
52 %manifest %{name}.manifest
53 %defattr(-,root,root,-)
54 %doc README COPYING
55 %{_datadir}/license/%{name}
56 %{_sysconfdir}/ltrace.conf
57 %{_bindir}/ltrace
58 %{_mandir}/man1/ltrace.1.gz