Git init
[external/ltrace.git] / packaging / ltrace.spec
1 Name:       ltrace
2 Summary:    Tracks runtime library calls in dynamically linked programs
3 Version:    0.5.3
4 Release:    1
5 Group:      utils
6 License:    GPLv1
7 Source0:    ltrace-0.5.3.tar.gz
8 BuildRequires:  binutils-devel
9 BuildRequires:  elfutils-libelf-devel
10
11
12 %description
13 Tracks runtime library calls in dynamically linked programs
14  ltrace is a debugging program which runs a specified command until it
15  exits.  While the command is executing, ltrace intercepts and records
16  the dynamic library calls which are called by
17  the executed process and the signals received by that process.
18  It can also intercept and print the system calls executed by the program.
19  .
20  The program to be traced need not be recompiled for this, so you can
21  use it on binaries for which you don't have the source handy.
22  .
23  You should install ltrace if you need a sysadmin tool for tracking the
24  execution of processes..
25
26 %prep
27 %setup -q
28
29 %build
30
31 %configure --disable-static
32 make %{?jobs:-j%jobs}
33
34 %install
35 rm -rf %{buildroot}
36 %make_install
37 rm -rf %{buildroot}%{_prefix}/share/doc/ltrace
38
39 %files
40 %defattr(-,root,root,-)
41 %doc README COPYING
42 %{_sysconfdir}/ltrace.conf
43 %{_bindir}/ltrace
44 %{_mandir}/man1/ltrace.1.gz