lottie: remove hardcoding pathes in pkgconfig file. (.pc)
[platform/core/uifw/lottie-player.git] / packaging / lottie-player.spec
1 Name:       lottie-player
2 Summary:    lottie player library
3 Version:    0.0.1
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache-2.0
7 URL:        http://www.tizen.org/
8 Source0:    %{name}-%{version}.tar.gz
9 BuildRequires:  cmake
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12
13 %description
14 lottie player library
15
16
17 %package devel
18 Summary:    lottie player library (devel)
19 Group:      Development/Libraries
20 Requires:   %{name} = %{version}-%{release}
21
22
23 %description devel
24 lottie player library (devel)
25
26
27 %prep
28 %setup -q
29
30
31 %build
32 export CFLAGS+=" -fvisibility=hidden -fPIC -Wall -O2"
33 export LDFLAGS+=" "
34
35
36 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
37         -DLIB_INSTALL_DIR:PATH=%{_libdir}
38
39
40 make %{?jobs:-j%jobs}
41
42 %install
43 %make_install
44
45 mkdir -p %{buildroot}/%{_datadir}/license
46 cp %{_builddir}/%{buildsubdir}/LICENSE %{buildroot}/%{_datadir}/license/%{name}
47
48
49 %post -p /sbin/ldconfig
50 echo "INFO: System should be restarted or execute: systemctl --user daemon-reload from user session to finish service installation."
51 %postun -p /sbin/ldconfig
52
53
54 %files
55 %defattr(-,root,root,-)
56 %{_libdir}/liblottie-player.so.*
57 %{_datadir}/license/%{name}
58 %manifest %{name}.manifest
59
60 %files devel
61 %defattr(-,root,root,-)
62 %{_includedir}/*.h
63 %{_libdir}/liblottie-player.so
64 %{_libdir}/cmake/lottie-player/*.cmake
65 %{_libdir}/pkgconfig/lottie-player.pc
66
67
68