lottie/parser: fix a crash when the color string is empty.
[platform/core/uifw/lottie-player.git] / packaging / lottie-player.spec
1 Name:       lottie-player
2 Summary:    lottie player library
3 Version:    0.0.1
4 Release:    1
5 Group:      UI Framework/Services
6 License:    LGPL-v2.1
7 URL:        http://www.tizen.org/
8 Source0:    %{name}-%{version}.tar.gz
9 BuildRequires:  cmake
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12
13 %description
14 lottie player library
15
16
17 %package devel
18 Summary:    lottie player library (devel)
19 Group:      Development/Libraries
20 Requires:   %{name} = %{version}-%{release}
21
22
23 %description devel
24 lottie player library (devel)
25
26
27 %prep
28 %setup -q
29
30
31 %build
32 export CFLAGS+=" -fvisibility=hidden -fPIC -Wall -O2"
33 export LDFLAGS+=" "
34
35 %ifarch %{arm}
36 export CXXFLAGS+=" -D_ARCH_ARM_ -mfpu=neon"
37 %endif
38
39
40 %ifarch %{arm}
41 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
42         -DLIB_INSTALL_DIR:PATH=%{_libdir} \
43         -DARCH="arm"
44 %else
45 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
46         -DLIB_INSTALL_DIR:PATH=%{_libdir}
47 %endif
48
49
50 make %{?jobs:-j%jobs}
51
52 %install
53 %make_install
54
55 %files
56 %defattr(-,root,root,-)
57 %{_libdir}/liblottie-player.so.*
58 %manifest %{name}.manifest
59 %license COPYING licenses/COPYING*
60
61 %files devel
62 %defattr(-,root,root,-)
63 %{_includedir}/*.h
64 %{_libdir}/liblottie-player.so
65 %{_libdir}/cmake/lottie-player/*.cmake
66 %{_libdir}/pkgconfig/lottie-player.pc