packaging: correct lmdb naming for Tizen
[platform/upstream/lmdb.git] / packaging / lmdb.spec
1 %define lname   liblmdb
2 %define prefix  %{_prefix}
3 %define libdir  %{_libdir}
4
5 Name:           lmdb
6 Summary:        Lightning Memory-Mapped Database Manager
7 License:        OLDAP-2.8
8 Group:          Productivity/Databases/Tools
9 Version:        0.9.17
10 Release:        0
11 Url:            http://symas.com/mdb/
12 Source0:        %{name}-%{version}.tar.gz
13 # Source99:       baselibs.conf
14
15 # BuildRequires:  autoconf
16 BuildRequires:  automake >= 1.10
17 BuildRequires:  libtool >= 2
18
19 %description
20 LMDB is a Btree-based database management library with an API similar
21 to BerkeleyDB. The library is thread-aware and supports concurrent
22 read/write access from multiple processes and threads. The DB
23 structure is multi-versioned, and data pages use a copy-on-write
24 strategy, which also provides resistance to corruption and eliminates
25 the need for any recovery procedures. The database is exposed in a
26 memory map, requiring no page cache layer of its own.
27
28 %package -n %lname
29 Summary:        Shared library for Lightning Memory-Mapped Database (LMDB)
30 Group:          System/Libraries
31
32 %description -n %lname
33 LMDB is a Btree-based database management library with an API similar
34 to BerkeleyDB. The library is thread-aware and supports concurrent
35 read/write access from multiple processes and threads. The DB
36 structure is multi-versioned, and data pages use a copy-on-write
37 strategy, which also provides resistance to corruption and eliminates
38 the need for any recovery procedures. The database is exposed in a
39 memory map, requiring no page cache layer of its own.
40
41 This package contains the shared library.
42
43 %package devel
44 Summary:        Development package for lmdb
45 Group:          Development/Libraries/C and C++
46 Requires:       %lname = %version
47
48 %description devel
49 LMDB is a Btree-based database management library with an API similar
50 to BerkeleyDB. The library is thread-aware and supports concurrent
51 read/write access from multiple processes and threads. The DB
52 structure is multi-versioned, and data pages use a copy-on-write
53 strategy, which also provides resistance to corruption and eliminates
54 the need for any recovery procedures. The database is exposed in a
55 memory map, requiring no page cache layer of its own.
56  
57 This package contains the files needed to compile programs that use
58 the liblmdb library.
59
60 %prep
61 %setup
62
63 %build
64 cd libraries/liblmdb
65 make PREFIX=%{prefix} LIBDIR=%{libdir}
66
67 %install
68 cd libraries/liblmdb
69 # make install DESTDIR="%buildroot"
70 make install prefix=$RPM_BUILD_ROOT%{prefix} LIBDIR=$RPM_BUILD_ROOT%{libdir} install
71
72 rm -rf %{buildroot}%{_mandir}
73
74 %post   -n %lname -p /sbin/ldconfig
75 %postun -n %lname -p /sbin/ldconfig
76
77 %files
78 %defattr(-,root,root)
79 %{_bindir}/*
80
81 %files -n %lname
82 %defattr(-,root,root)
83 %{libdir}/*.so*
84
85 %files devel
86 %defattr(-,root,root)
87 %_includedir/*
88 %{libdir}/*.a
89
90 %changelog