[Release] livebox.web-provider-1.1-2
[platform/framework/web/web-provider.git] / packaging / livebox.web-provider.spec
1 Name: livebox.web-provider
2 Summary: web framework for livebox 
3 Version: 1.1
4 Release: 2
5 Group: main/app
6 License: Apache License, Version 2.0
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: cmake, gettext-tools
9 BuildRequires: pkgconfig(aul)
10 BuildRequires: pkgconfig(appcore-efl)
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(bundle)
13 BuildRequires: pkgconfig(eina)
14 BuildRequires: pkgconfig(ecore)
15 BuildRequires: pkgconfig(ecore-x)
16 BuildRequires: pkgconfig(evas)
17 BuildRequires: pkgconfig(ecore-evas)
18 BuildRequires: pkgconfig(elementary)
19 BuildRequires: pkgconfig(ewebkit2)
20 BuildRequires: pkgconfig(wrt-core)
21 BuildRequires: pkgconfig(xmlsec1)
22 BuildRequires: pkgconfig(dpl-efl)
23 BuildRequires: pkgconfig(provider)
24 BuildRequires: pkgconfig(livebox-service)
25 BuildRequires: pkgconfig(glib-2.0)
26 BuildRequires: pkgconfig(json-glib-1.0)
27
28 # requires for smack
29 Requires(post): sys-assert 
30 Requires(post): busybox-symlinks-sysklogd
31 Requires(post): data-provider-master
32 Requires(post): isf
33
34 %description
35 This is web framework responsible to manage liveboxes that consist of web contents
36
37 %package devel
38 Summary: Files for web provider devel.
39 Group: Development/Libraries
40 Requires: %{name} = %{version}-%{release}
41
42 %description devel
43 Web Provider library (dev)
44
45 %prep
46 %setup -q
47
48 %build
49 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DCMAKE_PROJECT_VERSION=%{version}
50 #-fpie  LDFLAGS="${LDFLAGS} -pie -O3"
51 CFLAGS="${CFLAGS} -Wall -Winline -Werror -fno-builtin-malloc" make %{?jobs:-j%jobs}
52
53 %install
54 rm -rf %{buildroot}
55 %make_install
56
57 %post
58 killall -9 web-provider
59 echo "create web livebox DB..."
60 /usr/bin/web_provider_reset_db.sh
61
62 if [ -f /usr/lib/rpm-plugins/msm.so ]; then
63         echo "smack setting..."
64         chsmack -a 'livebox.web-provider::db' /opt/dbspace/.web_provider.db
65         chsmack -a 'livebox.web-provider::db' /opt/dbspace/.web_provider.db-journal
66 fi
67
68 %files -n livebox.web-provider
69 %manifest livebox.web-provider.manifest
70 %defattr(-,root,root,-)
71 %{_libdir}/*.so*
72 %{_libdir}/web-provider/*.so*
73 %{_libdir}/web-provider/*.json
74 %{_datadir}/web-provider/*
75 %attr(755,root,root) %{_bindir}/web_provider_reset_db.sh
76 %{_prefix}/apps/livebox.web-provider/bin/web-provider
77 %{_datarootdir}/packages/livebox.web-provider.xml
78
79 %files devel
80 %defattr(-,root,root,-)
81 %{_includedir}/web-provider/*
82 %{_libdir}/pkgconfig/*.pc
83