resetting manifest requested domain to floor
[platform/upstream/libzio.git] / packaging / libzio.spec
1 Name:           libzio
2 Version:        0.99
3 Release:        0
4 License:        GPL-2.0+
5 Summary:        A Library for Accessing Compressed Text Files
6 Group:          System/Libraries
7 Source:         %{name}-%{version}.tar.bz2
8 Source2:        baselibs.conf
9 Source1001:     libzio.manifest
10 BuildRequires:  bzip2-devel
11 BuildRequires:  xz
12 BuildRequires:  xz-devel
13 BuildRequires:  zlib-devel
14
15 %description
16 Libzio provides a wrapper function for reading or writing gzip or bzip2
17 files with FILE streams.
18
19 %package        devel
20 Summary:        Libzio development files
21 Group:          Development/Libraries/C and C++
22 Requires:       libzio = %{version}
23
24 %description    devel
25 Libzio development files including zio.h, the manual page fzopen(3),
26 and static library.
27
28 %prep
29 %setup -q
30 cp %{SOURCE1001} .
31
32 %build
33 make %{?_smp_mflags} noweak
34
35 %check
36 make testt
37 make tests
38 for comp in gzip bzip2 lzma xz
39 do
40     $comp -c < fzopen.3.in > fzopen.test
41     ./testt fzopen.test | cmp fzopen.3.in -
42     cat fzopen.test | ./tests ${comp:0:1} | cmp fzopen.3.in -
43 done
44
45 %install
46 make DESTDIR=%{buildroot} install libdir=%{_libdir} mandir=%{_mandir}
47
48 %post -p /sbin/ldconfig
49
50 %postun -p /sbin/ldconfig
51
52 %files
53 %manifest %{name}.manifest
54 %defattr(-,root,root)
55 %{_libdir}/libzio.so.0
56 %{_libdir}/libzio.so.%{version}
57
58 %files devel
59 %manifest %{name}.manifest
60 %defattr(-,root,root)
61 %doc README COPYING
62 %{_libdir}/libzio.a
63 %{_libdir}/libzio.so
64 %{_mandir}/man3/fzopen.3*
65 /usr/include/zio.h
66
67 %changelog