add files for packaging
[platform/upstream/libXshmfence.git] / packaging / libxshmfence.spec
1 %bcond_with x
2
3 Name:           libxshmfence
4 Version:        1.1
5 Release:        1
6 License:        MIT
7 Summary:        X Fixes library
8 Url:            http://www.x.org
9 Group:          Graphics/X Window System
10 Source:         %{name}-%{version}.tar.bz2
11 Source1001:     libxshmfence.manifest
12
13 BuildRequires:  pkgconfig(xorg-macros)
14 BuildRequires:  pkgconfig(xproto)
15
16 %if !%{with x}
17 ExclusiveArch:
18 %endif
19
20 %description
21 X Fixes library.
22
23 %package devel
24 Summary:        Development files for %{name}
25 Group:          Development/Libraries
26 Requires:       %{name} = %{version}
27 Requires:       pkgconfig
28
29 %description devel
30 libxshmfence development package
31
32 %prep
33 %setup -q
34 cp %{SOURCE1001} .
35
36 %build
37 %autogen --disable-static
38 make %{?_smp_mflags}
39
40 %install
41 %make_install
42 %remove_docs
43
44 %post -p /sbin/ldconfig
45
46 %postun -p /sbin/ldconfig
47
48 %files
49 %manifest %{name}.manifest
50 %defattr(-,root,root,-)
51 %license COPYING
52 %{_libdir}/libxshmfence.so.1
53 %{_libdir}/libxshmfence.so.1.0.0
54
55 %files devel
56 %manifest %{name}.manifest
57 %defattr(-,root,root,-)
58 %{_includedir}/X11/xshmfence.h
59 %{_libdir}/libxshmfence.so
60 %{_libdir}/pkgconfig/xshmfence.pc