packaging: update packaging file to install license file via %license macro
[platform/upstream/libxkbcommon.git] / packaging / libxkbcommon.spec
1 Name:           libxkbcommon
2 Version:        0.4.3
3 Release:        0
4 License:        MIT
5 Summary:        Wayland libxkbcommon library
6 Url:            http://wayland.freedesktop.org/
7 Group:          Development/Libraries
8
9 Source:         %{name}-%{version}.tar.xz
10 #X-Vcs-Url:     https://github.com/xkbcommon/libxkbcommon.git
11 Source1001:     libxkbcommon.manifest
12 BuildRequires:  autoconf >= 2.60
13 BuildRequires:  automake
14 BuildRequires:  bison
15 BuildRequires:  flex
16 BuildRequires:  libtool >= 2
17 BuildRequires:  pkgconfig(xorg-macros) >= 1.8
18 BuildRequires:  python
19 BuildRequires:  xkb-tizen-data
20
21 %global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
22
23 %description
24 Keyboard handling library using XKB data.
25
26 %package devel
27 Summary:        Development files for the Wayland libxkbcommon library
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 Keyboard handling library using XKB data.
33
34 This package contains the development headers for the library found
35 in %{name}.
36
37 %prep
38 %setup -q
39 cp %{SOURCE1001} .
40
41 # Generate tizen keymap header
42 export TZ_SYS_RO_SHARE="%{TZ_SYS_RO_SHARE}"
43 chmod a+x ./make_tizen_keymap.sh
44 ./make_tizen_keymap.sh
45 chmod a+x ./gen_tables.sh
46 ./gen_tables.sh
47
48 %build
49 %autogen --disable-static --disable-x11
50 %__make %{?_smp_mflags} V=1;
51
52 %install
53 %make_install
54
55 %post  -p /sbin/ldconfig
56
57 %postun  -p /sbin/ldconfig
58
59 %files
60 %manifest %{name}.manifest
61 %defattr(-,root,root)
62 %license COPYING
63 %{_libdir}/libxkbcommon.so.0*
64
65 %files devel
66 %manifest %{name}.manifest
67 %defattr(-,root,root)
68 %{_includedir}/xkbcommon
69 %{_libdir}/libxkbcommon.so
70 %{_libdir}/pkgconfig/xkbcommon.pc
71