Remove the exception for tizen common in .spec file
[platform/upstream/libxkbcommon.git] / packaging / libxkbcommon.spec
1 Name:           libxkbcommon
2 Version:        0.4.3
3 Release:        0
4 License:        MIT
5 Summary:        Wayland libxkbcommon library
6 Url:            http://wayland.freedesktop.org/
7 Group:          Development/Libraries
8
9 Source:         %{name}-%{version}.tar.xz
10 #X-Vcs-Url:     https://github.com/xkbcommon/libxkbcommon.git
11 Source1001:     libxkbcommon.manifest
12 BuildRequires:  autoconf >= 2.60
13 BuildRequires:  automake
14 BuildRequires:  bison
15 BuildRequires:  flex
16 BuildRequires:  libtool >= 2
17 BuildRequires:  pkgconfig(xorg-macros) >= 1.8
18 BuildRequires:  python
19 BuildRequires:  xkb-tizen-data
20
21 %global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
22
23 %description
24 Keyboard handling library using XKB data.
25
26 %package devel
27 Summary:        Development files for the Wayland libxkbcommon library
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 Keyboard handling library using XKB data.
33
34 This package contains the development headers for the library found
35 in %{name}.
36
37 %prep
38 %setup -qn %{name}
39 cp %{SOURCE1001} .
40
41 # Generate tizen keymap header
42 export TIZEN_PROFILE="%{?profile}"
43 export TZ_SYS_RO_SHARE="%{TZ_SYS_RO_SHARE}"
44 chmod a+x ./make_tizen_keymap.sh
45 ./make_tizen_keymap.sh
46 chmod a+x ./gen_tables.sh
47 ./gen_tables.sh
48
49 %build
50 %autogen --disable-static --disable-x11 --with-tizen-profile="%{?profile}"
51 %__make %{?_smp_mflags} V=1;
52
53 %install
54 %make_install
55
56 #for license notification
57 mkdir -p %{buildroot}/%{TZ_SYS_RO_SHARE}/license
58 cp -a %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/%{TZ_SYS_RO_SHARE}/license/%{name}
59
60 %post  -p /sbin/ldconfig
61
62 %postun  -p /sbin/ldconfig
63
64 %files
65 %manifest %{name}.manifest
66 %defattr(-,root,root)
67 %{TZ_SYS_RO_SHARE}/license/%{name}
68 %{_libdir}/libxkbcommon.so.0*
69
70 %files devel
71 %manifest %{name}.manifest
72 %defattr(-,root,root)
73 %{_includedir}/xkbcommon
74 %{_libdir}/libxkbcommon.so
75 %{_libdir}/pkgconfig/xkbcommon.pc
76