update for beta universally
[framework/uifw/xorg/xcb/libxcb.git] / packaging / libxcb.spec
1 Name:       libxcb
2 Summary:    A C binding to the X11 protocol
3 Version:    1.7
4 Release:    3.3
5 Group:      System/Libraries
6 License:    MIT
7 URL:        http://xcb.freedesktop.org/
8 Source0:    http://xcb.freedesktop.org/dist/%{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  pkgconfig(xorg-macros)
12 BuildRequires:  pkgconfig(pthread-stubs)
13 BuildRequires:  pkgconfig(xcb-proto)
14 BuildRequires:  pkgconfig(xau)
15 BuildRequires:  pkgconfig(xproto)
16 BuildRequires:  libxslt
17 BuildRequires:  python-xml, python-devel
18
19
20 %description
21 Description: %{summary}
22
23
24 %package devel
25 Summary:    Development files for %{name}
26 Group:      Development/Libraries
27 Requires:   %{name} = %{version}-%{release}
28 Requires:   libpthread-stubs
29 Requires:   libXau-devel
30
31 %description devel
32 Description: %{summary}
33
34 %package doc
35 Summary:    Documentation for %{name}
36 Group:      Documentation
37 Requires:   %{name} = %{version}-%{release}
38
39 %description doc
40 Description: %{summary}
41
42
43 %prep
44 %setup -q
45
46
47 %build
48
49 %reconfigure \
50     --disable-build-docs \
51     CFLAGS="-D_F_ENABLE_XI2_SENDEVENT_" \
52     LDFLAGS="-Wl,--hash-style=both -Wl,--as-needed"
53     
54
55 make %{?jobs:-j%jobs}
56
57 %install
58 rm -rf %{buildroot}
59 %make_install 
60
61
62
63
64 %post -p /sbin/ldconfig
65
66 %postun -p /sbin/ldconfig
67
68
69
70
71
72
73
74
75 %files
76 %defattr(-,root,root,-)
77 %{_libdir}/*.so.*
78
79
80 %files devel
81 %defattr(-,root,root,-)
82 %{_includedir}/xcb
83 %{_libdir}/*.so
84 %{_libdir}/pkgconfig/*.pc
85
86 %files doc
87 %defattr(-,root,root,-)
88 %{_datadir}/doc/%{name}
89