a7bcf3d9ac3df7f97b183ee5e276b7b7f7bb95b2
[platform/upstream/libwlmessage.git] / packaging / libwlmessage.spec
1 %bcond_with wayland
2
3 Name:           libwlmessage
4 Version:        0.1
5 Release:        0
6 Summary:        A library to display interactive dialog boxes under Wayland
7 License:        MIT
8 Group:          Graphics & UI Framework/Wayland Window System
9 Url:            https://github.com/Tarnyko/libwlmessage.git
10
11 Source0:        %name-%version.tar.xz
12 Source1:        %name.manifest
13 BuildRequires:  autoconf >= 2.64, automake >= 1.11
14 BuildRequires:  libtool >= 2.2
15 BuildRequires:  libjpeg-devel
16 BuildRequires:  xz
17 BuildRequires:  pkgconfig
18 BuildRequires:  pkgconfig(libpng)
19 BuildRequires:  pkgconfig(xkbcommon)
20 BuildRequires:  pkgconfig(wayland-client)
21 BuildRequires:  pkgconfig(wayland-cursor)
22 BuildRequires:  pkgconfig(wayland-egl)
23 BuildRequires:  pkgconfig(egl)
24 BuildRequires:  pkgconfig(glesv2)
25 BuildRequires:  pkgconfig(pixman-1)
26 BuildRequires:  pkgconfig(cairo)
27 BuildRequires:  pkgconfig(cairo-egl)
28 BuildRequires:  pkgconfig(cairo-glesv2)
29 BuildRequires:  pkgconfig(glib-2.0)
30 BuildRequires:  pkgconfig(gio-2.0)
31
32 %if !%{with wayland}
33 ExclusiveArch:
34 %endif
35
36 %description
37 libwlmessage is a very tiny and toolkit-independent library, able to display interactive dialog boxes under Wayland.
38
39 %package devel
40 Summary:        Development components for the %{name} package
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}
43
44 %description devel
45 Development files for %{name}
46
47 %prep
48 %setup -q
49 cp %{SOURCE1} .
50
51 %build
52 %reconfigure
53 make %{?_smp_mflags}
54
55 %install
56 %make_install
57
58 %post -p /sbin/ldconfig
59 %postun -p /sbin/ldconfig
60
61 %files
62 %manifest %{name}.manifest
63 %defattr(-,root,root)
64 %license COPYING
65 %{_libdir}/*.so.*
66
67 %files devel
68 %manifest %{name}.manifest
69 %defattr(-,root,root)
70 %{_includedir}/libwlmessage.h
71 %{_libdir}/*.so
72 %{_libdir}/pkgconfig/*.pc
73
74 %changelog