Release version 1.7.30
[platform/core/appfw/widget-viewer.git] / packaging / libwidget_viewer.spec
1 %bcond_with wayland
2
3 Name: libwidget_viewer
4 Summary: Library for developing the application
5 Version: 1.7.30
6 Release: 1
7 Group: Applications/Core Applications
8 License: Flora-1.1 and Apache-2.0
9 Source0: %{name}-%{version}.tar.gz
10 Source1001: %{name}_evas.manifest
11 Source1003: org.tizen.widget_viewer_sdk.manifest
12 Source1004: watch-control.manifest
13 Source1005: frame-broker.manifest
14 Source1006: frame-provider.manifest
15 Source1007: watch-holder.manifest
16 Source1008: ambient-viewer.manifest
17 BuildRequires: cmake, gettext-tools, coreutils, edje-bin
18 BuildRequires: pkgconfig(dlog)
19 BuildRequires: pkgconfig(aul)
20 BuildRequires: pkgconfig(glib-2.0)
21 BuildRequires: pkgconfig(gio-2.0)
22 BuildRequires: pkgconfig(sqlite3)
23 BuildRequires: pkgconfig(db-util)
24 BuildRequires: pkgconfig(widget_service)
25 BuildRequires: pkgconfig(vconf)
26 BuildRequires: pkgconfig(elementary)
27 BuildRequires: pkgconfig(pkgmgr-info)
28 BuildRequires: pkgconfig(capi-appfw-application)
29 BuildRequires: pkgconfig(appcore-efl)
30 BuildRequires: pkgconfig(capi-system-info)
31 BuildRequires: pkgconfig(efl-extension)
32 BuildRequires: pkgconfig(wayland-client)
33 BuildRequires: pkgconfig(libtbm)
34 BuildRequires: pkgconfig(libtzplatform-config)
35 BuildRequires: pkgconfig(cynara-client)
36 BuildRequires: pkgconfig(appsvc)
37 BuildRequires: pkgconfig(ecore-wl2)
38 BuildRequires: pkgconfig(wayland-tbm-client)
39 BuildRequires: pkgconfig(screen_connector_watcher_evas)
40 BuildRequires: pkgconfig(capi-system-device)
41 BuildRequires: pkgconfig(gmock)
42 BuildRequires: pkgconfig(screen_connector_launcher_service)
43 BuildRequires: pkgconfig(screen_connector_shared_widget_launch)
44 %if 0%{?gcov:1}
45 BuildRequires:  lcov
46 BuildRequires:  zip
47 %endif
48
49 %description
50 API for creating a new instance of the widget and managing its life-cycle.
51
52 %prep
53 %setup -q
54 cp %{SOURCE1001} .
55 cp %{SOURCE1003} .
56 cp %{SOURCE1004} .
57 cp %{SOURCE1005} .
58 cp %{SOURCE1006} .
59 cp %{SOURCE1007} .
60 cp %{SOURCE1008} .
61
62 %build
63 export CFLAGS+=" -DEFL_BETA_API_SUPPORT "
64 export CXXFLAGS+=" -DEFL_BETA_API_SUPPORT "
65 %if 0%{?gcov:1}
66 export CFLAGS+=" -fprofile-arcs -ftest-coverage"
67 export CXXFLAGS+=" -fprofile-arcs -ftest-coverage"
68 export FFLAGS+=" -fprofile-arcs -ftest-coverage"
69 export LDFLAGS+=" -lgcov"
70 %endif
71
72 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
73 %cmake -DWIDGET_ENABLED=On \
74         -DTZ_SYS_SHARE=/usr/share \
75         -DFULLVER=%{version} \
76         -DMAJORVER=${MAJORVER} \
77         .
78 make %{?jobs:-j%jobs}
79
80 %if 0%{?gcov:1}
81 mkdir -p gcov-obj
82 find . -name '*.gcno' -exec cp '{}' gcov-obj ';'
83 %endif
84
85 %check
86 ctest -V
87 %if 0%{?gcov:1}
88 lcov -c --ignore-errors graph --no-external -q -d . -o widget-viewer.info
89 genhtml widget-viewer.info -o widget-viewer.out
90 zip -r widget-viewer.zip widget-viewer.out
91 install -m 0644 widget-viewer.zip %{buildroot}%{_datadir}/gcov/
92 %endif
93
94 %install
95 rm -rf %{buildroot}
96 %make_install
97
98 %if 0%{?gcov:1}
99 mkdir -p %{buildroot}%{_datadir}/gcov/obj
100 install -m 0644 gcov-obj/* %{buildroot}%{_datadir}/gcov/obj
101 %endif
102
103 %post -n %{name} -p /sbin/ldconfig
104 %postun -n %{name} -p /sbin/ldconfig
105
106 #################################################
107 # libwidget_viewer_evas
108 %package -n %{name}_evas
109 Summary: Library for developing the widget viewer evas
110 Group: Applications/Core Applications
111 License: Flora-1.1
112
113 %description -n %{name}_evas
114 Provider APIs to develop the widget viewer EFL application.
115
116 %package -n %{name}_evas-devel
117 Summary: Widget provider application development library (dev) (EFL version)
118 Group: Development/Libraries
119 Requires: %{name}_evas
120
121 %description -n %{name}_evas-devel
122 Header & package configuration files to support development of the widget viewer applications. (for EFL app)
123
124 %post -n %{name}_evas -p /sbin/ldconfig
125 %postun -n %{name}_evas -p /sbin/ldconfig
126
127 #################################################
128 # org.tizen.widget_viewer_sdk
129 %package -n org.tizen.widget_viewer_sdk
130 Summary: The widget viewer for development using SDK(IDE)
131 Version: 0.0.1
132 Group: Development/Tools
133 License: Flora-1.1
134 Requires: %{name}_evas
135
136 %description -n org.tizen.widget_viewer_sdk
137 While developing the widget applications, this viewer will load it and execute it to help you to see it on the screen.
138
139 %post -n org.tizen.widget_viewer_sdk -p /sbin/ldconfig
140 %postun -n org.tizen.widget_viewer_sdk -p /sbin/ldconfig
141
142 #################################################
143 # widget-viewer_unittests
144 #################################################
145 %package -n widget-viewer_unittests
146 Summary:    GTest for widget-viewer
147 Group:      Development/Libraries
148
149 %description -n widget-viewer_unittests
150 GTest for widget-viewer
151
152 %files -n widget-viewer_unittests
153 %{_bindir}/widget-viewer_unittests
154
155 #################################################
156 # widget-viewer-gcov
157 #################################################
158 %if 0%{?gcov:1}
159 %package gcov
160 Summary:    Simple string key-val dictionary ADT (gcov)
161 Group:      Application Framework/Testing
162
163 %description gcov
164 Simple string key-val dictionary ADT gcov objects
165 %endif
166
167 %if 0%{?gcov:1}
168 %files gcov
169 %{_datadir}/gcov/*
170 %endif
171
172 ################################################
173 # libwatch_control
174 %package -n watch-control
175 Summary: APIs to control watch applications
176 Version: 0.0.1
177 License: Flora-1.1
178 Group: Applications/Core Applications
179
180 %description -n watch-control
181 A set of APIs to control watch applications
182
183 %package -n watch-control-devel
184 Summary: APIs to control watch applications
185 Group: Development/Libraries
186 Requires: watch-control
187
188 %description -n watch-control-devel
189 Header & package configuration of watch-control
190
191 %post -n watch-control -p /sbin/ldconfig
192 %postun -n watch-control -p /sbin/ldconfig
193
194 ################################################
195 # libwatch_holder
196 %package -n watch-holder
197 Summary: APIs to control watch applications
198 Version: 0.0.1
199 License: Flora-1.1
200 Group: Applications/Core Applications
201
202 %description -n watch-holder
203 A set of APIs to control watch applications
204
205 %package -n watch-holder-devel
206 Summary: APIs to control watch applications
207 Group: Development/Libraries
208 Requires: watch-holder
209
210 %description -n watch-holder-devel
211 Header & package configuration of watch-holder
212
213 %post -n watch-holder -p /sbin/ldconfig
214 %postun -n watch-holder -p /sbin/ldconfig
215
216
217 ################################################
218 # libframe-broker
219 ################################################
220 %package -n frame-broker
221 Summary: APIs to handle launching images for the launcher
222 License: Apache-2.0
223 Group: Applications/Core Applications
224
225 %description -n frame-broker
226 A set of APIs to handle launching images for the launcher
227
228 %package -n frame-broker-devel
229 Summary: APIs to handle launching images for the launcher
230 Group: Development/Libraries
231 Requires: frame-broker
232
233 %description -n frame-broker-devel
234 Header & package configuration of launcher service
235
236 %post -n frame-broker -p /sbin/ldconfig
237 %postun -n frame-broker -p /sbin/ldconfig
238
239 ################################################
240 # libframe-provider
241 ################################################
242 %package -n frame-provider
243 Summary: APIs to handle launching images for the callee
244 License: Apache-2.0
245 Group: Applications/Core Applications
246
247 %description -n frame-provider
248 A set of APIs to handle launching images for the callee
249
250 %package -n frame-provider-devel
251 Summary: APIs to handle launching images for the callee (devel)
252 Group: Development/Libraries
253 Requires: frame-provider
254
255 %description -n frame-provider-devel
256 Header & package configuration for the callee (devel)
257
258 %post -n frame-provider -p /sbin/ldconfig
259 %postun -n frame-provider -p /sbin/ldconfig
260
261 ################################################
262 # libambient-viewer
263 ################################################
264 %package -n ambient-viewer
265 Summary: APIs to control ambient viewer
266 Version: 0.0.1
267 License: apache-2.0
268 Group: Applications/Core Applications
269
270 %description -n ambient-viewer
271 A set of APIs to control viewer applications
272
273 %package -n ambient-viewer-devel
274 Summary: APIs to control watch applications
275 Group: Development/Libraries
276 Requires: ambient-viewer
277
278 %description -n ambient-viewer-devel
279 Header & package configuration of ambient-viewer
280
281 %post -n ambient-viewer -p /sbin/ldconfig
282 %postun -n ambient-viewer -p /sbin/ldconfig
283
284 ################################################
285 # files
286 ################################################
287 %files -n %{name}_evas
288 %manifest %{name}_evas.manifest
289 %attr(0644,root,root) %{_libdir}/%{name}_evas.so.*
290 %license LICENSE.Flora-1.1 LICENSE.Apache-2.0
291 /usr/share/widget_viewer_evas/res/edje/widget_viewer_evas.edj
292 /usr/share/widget_viewer_evas/res/image/*.png
293 /usr/share/widget_viewer_evas/res/locale/*/LC_MESSAGES/*
294 %{_bindir}/widget-mgr
295
296 %files -n %{name}_evas-devel
297 %{_includedir}/widget_viewer_evas/widget_viewer_evas.h
298 %{_includedir}/widget_viewer_evas/widget_viewer_evas_extension.h
299 %{_libdir}/pkgconfig/widget_viewer_evas.pc
300 %attr(0644,root,root) %{_libdir}/%{name}_evas.so
301
302 %files -n org.tizen.widget_viewer_sdk
303 %manifest org.tizen.widget_viewer_sdk.manifest
304 %{_datarootdir}/packages/org.tizen.widget_viewer_sdk.xml
305 %license LICENSE.Flora-1.1 LICENSE.Apache-2.0
306 %{_prefix}/apps/org.tizen.widget_viewer_sdk/*
307
308 %files -n watch-control
309 %manifest watch-control.manifest
310 %license LICENSE.Flora-1.1 LICENSE.Apache-2.0
311 %{_libdir}/libwatch-control.so.*
312
313 %files -n watch-control-devel
314 %{_includedir}/watch-control/*.h
315 %{_libdir}/pkgconfig/watch-control.pc
316 %{_libdir}/libwatch-control.so
317
318 %files -n watch-holder
319 %manifest watch-holder.manifest
320 %license LICENSE.Flora-1.1 LICENSE.Apache-2.0
321 %{_libdir}/libwatch-holder.so.*
322
323 %files -n watch-holder-devel
324 %{_includedir}/watch-holder/*.h
325 %{_includedir}/watch-holder/*.hh
326 %{_libdir}/pkgconfig/watch-holder.pc
327 %{_libdir}/libwatch-holder.so
328
329
330 %files -n frame-broker
331 %manifest frame-broker.manifest
332 %{_libdir}/libframe-broker.so.*
333
334 %files -n frame-broker-devel
335 %{_includedir}/frame-broker/*.h
336 %{_libdir}/pkgconfig/frame-broker.pc
337 %{_libdir}/libframe-broker.so
338
339 %files -n frame-provider
340 %manifest frame-provider.manifest
341 %{_libdir}/libframe-provider.so.*
342
343 %files -n frame-provider-devel
344 %{_includedir}/frame-provider/*.h
345 %{_libdir}/pkgconfig/frame-provider.pc
346 %{_libdir}/libframe-provider.so
347
348 %files -n ambient-viewer
349 %manifest ambient-viewer.manifest
350 %{_libdir}/libambient-viewer.so.*
351
352 %files -n ambient-viewer-devel
353 %{_includedir}/ambient-viewer/*.h
354 %{_includedir}/ambient-viewer/*.hh
355 %{_libdir}/pkgconfig/ambient-viewer.pc
356 %{_libdir}/libambient-viewer.so
357 # End of a file