Bump up to v1.10.0
[platform/upstream/libvpx.git] / packaging / libvpx.spec
1 Name:           libvpx
2 Version:        1.10.0
3 Release:        0
4 License:        BSD-3-Clause
5 Summary:        VP8 codec library
6 Url:            http://www.webmproject.org/
7 #X-Vc-Url:      https://chromium.googlesource.com/webm/libvpx
8 Group:          Multimedia/Libraries
9 Source0:        http://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
10 Source1001:     libvpx.manifest
11 BuildRequires:  yasm
12
13 %description
14 WebM is an open, royalty-free, media file format designed for the web.
15
16 WebM defines the file container structure, video and audio formats.
17 WebM files consist of video streams compressed with the VP8 video codec
18 and audio streams compressed with the Vorbis audio codec.
19 The WebM file structure is based on the Matroska container.
20
21 %package -n vpx-tools
22 Summary:        VP8 codec library - Utilities
23
24 %description -n vpx-tools
25 This package contains utilities around the vp8 codec sdk.
26
27 WebM is an open, royalty-free, media file format designed for the web.
28
29 WebM defines the file container structure, video and audio formats.
30 WebM files consist of video streams compressed with the VP8 video codec
31 and audio streams compressed with the Vorbis audio codec.
32 The WebM file structure is based on the Matroska container.
33 %package devel
34 Summary:        VP8 codec library - Development headers
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Development headers and library
39
40 WebM is an open, royalty-free, media file format designed for the web.
41
42 WebM defines the file container structure, video and audio formats.
43 WebM files consist of video streams compressed with the VP8 video codec
44 and audio streams compressed with the Vorbis audio codec.
45 The WebM file structure is based on the Matroska container.
46
47 %prep
48 %setup -q -n %name-v%version
49 cp %{SOURCE1001} .
50
51 %build
52 cd build
53 export CFLAGS="%{optflags}"
54 # It is only an emulation of autotools configure; the macro does not work
55
56 # libvpx default enable NEON support on ARMv7, unfortunately some ARMv7
57 # CPU doesn't have NEON, e.g. NVIDIA Tegra 2.
58 # So, we still set -mfpu=neon when build libvpx rpm, but also enable
59 # runtime-cpu-detect for runtime detect NEON.
60 ../configure \
61     --prefix=%{_prefix} \
62     --libdir=%{_libdir} \
63     --enable-debug \
64     --enable-shared \
65 %ifarch armv7l armv7hl
66     --target=armv7-linux-gcc \
67     --enable-runtime-cpu-detect \
68 %endif
69     --enable-pic
70
71 %__make %{?_smp_mflags}
72
73 %install
74 cd build
75 %make_install
76
77 %post -n %{name} -p /sbin/ldconfig
78
79 %postun -n %{name} -p /sbin/ldconfig
80
81 %files -n vpx-tools
82 %manifest %{name}.manifest
83 %defattr(-,root,root)
84 %{_bindir}/*
85
86 %files
87 %manifest %{name}.manifest
88 %defattr(-, root, root)
89 %license LICENSE
90 %{_libdir}/libvpx.so.*
91
92 %files devel
93 %manifest %{name}.manifest
94 %defattr(-,root,root)
95 %{_includedir}/vpx/
96 %{_libdir}/pkgconfig/vpx.pc
97 %{_libdir}/libvpx.so