resetting manifest requested domain to floor
[platform/upstream/libvorbis.git] / packaging / libvorbis.spec
1 Name:           libvorbis
2 Version:        1.3.3
3 Release:        0
4 License:        BSD-3-Clause
5 Summary:        The Vorbis General Audio Compression Codec
6 Url:            http://www.vorbis.com/
7 Group:          Multimedia/Audio
8 Source:         %{name}-%{version}.tar.xz
9 Source2:        baselibs.conf
10 Source1001:     libvorbis.manifest
11 BuildRequires:  fdupes
12 BuildRequires:  libogg-devel
13 BuildRequires:  libtool
14 BuildRequires:  pkgconfig
15
16 %description
17 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
18 general-purpose compressed audio format for audio and music at fixed
19 and variable bit rates from 16 to 128 kbps/channel.
20
21 The native bitstream format of Vorbis is libogg (Ogg). Alternatively,
22 libmatroska (matroska) can also be used.
23
24
25 %package -n libvorbisenc
26
27 Summary:        The Vorbis General Audio Compression Codec
28 Group:          Multimedia/Audio
29
30 %description -n libvorbisenc
31 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
32 general-purpose compressed audio format for audio and music at fixed
33 and variable bit rates from 16 to 128 kbps/channel.
34
35 The native bitstream format of Vorbis is libogg (Ogg). Alternatively,
36 libmatroska (matroska) can also be used.
37
38 %package -n libvorbisfile
39
40 Summary:        The Vorbis General Audio Compression Codec
41 Group:          Multimedia/Audio
42
43 %description -n libvorbisfile
44 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
45 general-purpose compressed audio format for audio and music at fixed
46 and variable bit rates from 16 to 128 kbps/channel.
47
48 The native bitstream format of Vorbis is libogg (Ogg). Alternatively,
49 libmatroska (matroska) can also be used.
50
51 %package devel
52 Summary:        Include Files and Libraries mandatory for Ogg Vorbis Development
53 Group:          Development/Libraries
54 Requires:       glibc-devel
55 Requires:       libogg-devel
56 Requires:       libvorbis = %{version}
57 Requires:       libvorbisenc = %{version}
58 Requires:       libvorbisfile = %{version}
59
60 %description devel
61 This package contains all necessary include files and libraries needed
62 to compile and develop applications that use libvorbis.
63
64 %prep
65 %setup -q
66 cp %{SOURCE1001} .
67
68 %build
69 # Fix optimization level
70 sed -i s,-O20,-O3,g configure.ac
71
72 autoreconf -fiv
73 %configure --disable-examples --disable-static
74 make %{?_smp_mflags}
75
76 %check
77 make check
78
79 %install
80 %make_install
81 mkdir -p %{buildroot}%{_docdir}/%{name}
82 mv %{buildroot}%{_datadir}/doc/libvorbis-* %{buildroot}%{_docdir}/%{name}
83 install -c -m 0644 doc/Vorbis_I_spec.* %{buildroot}%{_docdir}/%{name}
84
85 %remove_docs
86
87 %post  -p /sbin/ldconfig
88
89 %postun -p /sbin/ldconfig
90
91 %post -n libvorbisenc -p /sbin/ldconfig
92
93 %postun -n libvorbisenc -p /sbin/ldconfig
94
95 %post -n libvorbisfile -p /sbin/ldconfig
96
97 %postun -n libvorbisfile -p /sbin/ldconfig
98
99 %files 
100 %manifest %{name}.manifest
101 %defattr(0644,root,root,0755)
102 %license COPYING 
103 %{_libdir}/libvorbis.so.0*
104
105 %files -n libvorbisenc
106 %manifest %{name}.manifest
107 %defattr(0644,root,root,0755)
108 %license COPYING 
109 %{_libdir}/libvorbisenc.so.2*
110
111 %files -n libvorbisfile
112 %manifest %{name}.manifest
113 %defattr(0644,root,root,0755)
114 %license COPYING 
115 %{_libdir}/libvorbisfile.so.3*
116
117 %files devel
118 %manifest %{name}.manifest
119 %defattr(-,root,root)
120 %license COPYING 
121 %{_datadir}/aclocal/*.m4
122 %{_includedir}/vorbis
123 %{_libdir}/lib*.so
124 %{_libdir}/pkgconfig/*.pc
125
126 %changelog