Merge tag 'v1.3.7' into tizen
[platform/upstream/libvorbis.git] / packaging / libvorbis.spec
1 Name:           libvorbis
2 Version:        1.3.7
3 Release:        0
4 License:        BSD-2.0
5 Summary:        The Vorbis General Audio Compression Codec
6 Url:            http://www.vorbis.com/
7 Group:          Multimedia/Audio
8 Source:         %{name}-%{version}.tar.xz
9 BuildRequires:  fdupes
10 BuildRequires:  libogg-devel
11 BuildRequires:  libtool
12 BuildRequires:  pkgconfig
13
14 %description
15 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
16 general-purpose compressed audio format for audio and music at fixed
17 and variable bit rates from 16 to 128 kbps/channel.
18
19 The native bitstream format of Vorbis is libogg (Ogg). Alternatively,
20 libmatroska (matroska) can also be used.
21
22
23 %package -n libvorbisenc
24
25 Summary:        The Vorbis General Audio Compression Codec
26 Group:          Multimedia/Audio
27
28 %description -n libvorbisenc
29 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
30 general-purpose compressed audio format for audio and music at fixed
31 and variable bit rates from 16 to 128 kbps/channel.
32
33 The native bitstream format of Vorbis is libogg (Ogg). Alternatively,
34 libmatroska (matroska) can also be used.
35
36 %package -n libvorbisfile
37
38 Summary:        The Vorbis General Audio Compression Codec
39 Group:          Multimedia/Audio
40
41 %description -n libvorbisfile
42 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
43 general-purpose compressed audio format for audio and music at fixed
44 and variable bit rates from 16 to 128 kbps/channel.
45
46 The native bitstream format of Vorbis is libogg (Ogg). Alternatively,
47 libmatroska (matroska) can also be used.
48
49 %package devel
50 Summary:        Include Files and Libraries mandatory for Ogg Vorbis Development
51 Group:          Development/Libraries
52 Requires:       glibc-devel
53 Requires:       libogg-devel
54 Requires:       libvorbis = %{version}-%{release}
55 Requires:       libvorbisenc = %{version}-%{release}
56 Requires:       libvorbisfile = %{version}-%{release}
57
58 %description devel
59 This package contains all necessary include files and libraries needed
60 to compile and develop applications that use libvorbis.
61
62 %prep
63 %setup -q
64
65 %build
66 # Fix optimization level
67 sed -i s,-O20,-O3,g configure.ac
68
69 %autogen --disable-examples --disable-static
70 %__make %{?_smp_mflags}
71
72 %check
73 %__make check
74
75 %install
76 %make_install
77 mkdir -p %{buildroot}%{_docdir}/%{name}
78 mv %{buildroot}%{_datadir}/doc/libvorbis-* %{buildroot}%{_docdir}/%{name}
79 install -c -m 0644 doc/Vorbis_I_spec.* %{buildroot}%{_docdir}/%{name}
80
81 %remove_docs
82
83 %post  -p /sbin/ldconfig
84
85 %postun -p /sbin/ldconfig
86
87 %post -n libvorbisenc -p /sbin/ldconfig
88
89 %postun -n libvorbisenc -p /sbin/ldconfig
90
91 %post -n libvorbisfile -p /sbin/ldconfig
92
93 %postun -n libvorbisfile -p /sbin/ldconfig
94
95 %files 
96 %manifest %{name}.manifest
97 %defattr(0644,root,root,0755)
98 %license COPYING 
99 %{_libdir}/libvorbis.so.0*
100
101 %files -n libvorbisenc
102 %manifest %{name}.manifest
103 %defattr(0644,root,root,0755)
104 %license COPYING 
105 %{_libdir}/libvorbisenc.so.2*
106
107 %files -n libvorbisfile
108 %manifest %{name}.manifest
109 %defattr(0644,root,root,0755)
110 %license COPYING 
111 %{_libdir}/libvorbisfile.so.3*
112
113 %files devel
114 %manifest %{name}.manifest
115 %defattr(-,root,root)
116 %license COPYING 
117 %{_datadir}/aclocal/*.m4
118 %{_includedir}/vorbis
119 %{_libdir}/lib*.so
120 %{_libdir}/pkgconfig/*.pc