[CVE-2018-10393] heap buffer overflow
[platform/upstream/libvorbis.git] / packaging / libvorbis.spec
1 Name:           libvorbis
2 Version:        1.3.4
3 Release:        0
4 License:        BSD-2.0
5 Summary:        The Vorbis General Audio Compression Codec
6 Url:            http://www.vorbis.com/
7 Group:          Multimedia/Audio
8 Source:         %{name}-%{version}.tar.xz
9 Source2:        baselibs.conf
10 Source1001:     libvorbis.manifest
11 BuildRequires:  fdupes
12 BuildRequires:  libogg-devel
13 BuildRequires:  libtool
14 BuildRequires:  pkgconfig
15
16 %description
17 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
18 general-purpose compressed audio format for audio and music at fixed
19 and variable bit rates from 16 to 128 kbps/channel.
20
21 The native bitstream format of Vorbis is libogg (Ogg). Alternatively,
22 libmatroska (matroska) can also be used.
23
24
25 %package -n libvorbisenc
26
27 Summary:        The Vorbis General Audio Compression Codec
28 Group:          Multimedia/Audio
29
30 %description -n libvorbisenc
31 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
32 general-purpose compressed audio format for audio and music at fixed
33 and variable bit rates from 16 to 128 kbps/channel.
34
35 The native bitstream format of Vorbis is libogg (Ogg). Alternatively,
36 libmatroska (matroska) can also be used.
37
38 %package -n libvorbisfile
39
40 Summary:        The Vorbis General Audio Compression Codec
41 Group:          Multimedia/Audio
42
43 %description -n libvorbisfile
44 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
45 general-purpose compressed audio format for audio and music at fixed
46 and variable bit rates from 16 to 128 kbps/channel.
47
48 The native bitstream format of Vorbis is libogg (Ogg). Alternatively,
49 libmatroska (matroska) can also be used.
50
51 %package devel
52 Summary:        Include Files and Libraries mandatory for Ogg Vorbis Development
53 Group:          Development/Libraries
54 Requires:       glibc-devel
55 Requires:       libogg-devel
56 Requires:       libvorbis = %{version}-%{release}
57 Requires:       libvorbisenc = %{version}-%{release}
58 Requires:       libvorbisfile = %{version}-%{release}
59
60 %description devel
61 This package contains all necessary include files and libraries needed
62 to compile and develop applications that use libvorbis.
63
64 %prep
65 %setup -q
66 cp %{SOURCE1001} .
67
68 %build
69 # Fix optimization level
70 sed -i s,-O20,-O3,g configure.ac
71
72 %autogen --disable-examples --disable-static
73 %__make %{?_smp_mflags}
74
75 %check
76 %__make check
77
78 %install
79 %make_install
80 mkdir -p %{buildroot}%{_docdir}/%{name}
81 mv %{buildroot}%{_datadir}/doc/libvorbis-* %{buildroot}%{_docdir}/%{name}
82 install -c -m 0644 doc/Vorbis_I_spec.* %{buildroot}%{_docdir}/%{name}
83
84 %remove_docs
85
86 %post  -p /sbin/ldconfig
87
88 %postun -p /sbin/ldconfig
89
90 %post -n libvorbisenc -p /sbin/ldconfig
91
92 %postun -n libvorbisenc -p /sbin/ldconfig
93
94 %post -n libvorbisfile -p /sbin/ldconfig
95
96 %postun -n libvorbisfile -p /sbin/ldconfig
97
98 %files 
99 %manifest %{name}.manifest
100 %defattr(0644,root,root,0755)
101 %license COPYING 
102 %{_libdir}/libvorbis.so.0*
103
104 %files -n libvorbisenc
105 %manifest %{name}.manifest
106 %defattr(0644,root,root,0755)
107 %license COPYING 
108 %{_libdir}/libvorbisenc.so.2*
109
110 %files -n libvorbisfile
111 %manifest %{name}.manifest
112 %defattr(0644,root,root,0755)
113 %license COPYING 
114 %{_libdir}/libvorbisfile.so.3*
115
116 %files devel
117 %manifest %{name}.manifest
118 %defattr(-,root,root)
119 %license COPYING 
120 %{_datadir}/aclocal/*.m4
121 %{_includedir}/vorbis
122 %{_libdir}/lib*.so
123 %{_libdir}/pkgconfig/*.pc