Fixed package groups
[platform/upstream/libvorbis.git] / packaging / libvorbis.spec
1 Name:           libvorbis
2 Version:        1.3.3
3 Release:        0
4 License:        BSD-3-Clause
5 Summary:        The Vorbis General Audio Compression Codec
6 Url:            http://www.vorbis.com/
7 Group:          Multimedia/Audio
8 Source:         %{name}-%{version}.tar.xz
9 Source2:        baselibs.conf
10 BuildRequires:  fdupes
11 BuildRequires:  libogg-devel
12 BuildRequires:  libtool
13 BuildRequires:  pkgconfig
14
15 %description
16 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
17 general-purpose compressed audio format for audio and music at fixed
18 and variable bit rates from 16 to 128 kbps/channel.
19
20 The native bitstream format of Vorbis is libogg (Ogg). Alternatively,
21 libmatroska (matroska) can also be used.
22
23
24 %package -n libvorbisenc
25
26 Summary:        The Vorbis General Audio Compression Codec
27 Group:          Multimedia/Audio
28
29 %description -n libvorbisenc
30 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
31 general-purpose compressed audio format for audio and music at fixed
32 and variable bit rates from 16 to 128 kbps/channel.
33
34 The native bitstream format of Vorbis is libogg (Ogg). Alternatively,
35 libmatroska (matroska) can also be used.
36
37 %package -n libvorbisfile
38
39 Summary:        The Vorbis General Audio Compression Codec
40 Group:          Multimedia/Audio
41
42 %description -n libvorbisfile
43 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
44 general-purpose compressed audio format for audio and music at fixed
45 and variable bit rates from 16 to 128 kbps/channel.
46
47 The native bitstream format of Vorbis is libogg (Ogg). Alternatively,
48 libmatroska (matroska) can also be used.
49
50 %package devel
51 Summary:        Include Files and Libraries mandatory for Ogg Vorbis Development
52 Group:          Development/Libraries
53 Requires:       glibc-devel
54 Requires:       libogg-devel
55 Requires:       libvorbis = %{version}
56 Requires:       libvorbisenc = %{version}
57 Requires:       libvorbisfile = %{version}
58
59 %description devel
60 This package contains all necessary include files and libraries needed
61 to compile and develop applications that use libvorbis.
62
63 %prep
64 %setup -q
65
66 %build
67 # Fix optimization level
68 sed -i s,-O20,-O3,g configure.ac
69
70 autoreconf -fiv
71 %configure --disable-examples --disable-static
72 make %{?_smp_mflags}
73
74 %check
75 make check
76
77 %install
78 %make_install
79 mkdir -p %{buildroot}%{_docdir}/%{name}
80 mv %{buildroot}%{_datadir}/doc/libvorbis-* %{buildroot}%{_docdir}/%{name}
81 install -c -m 0644 doc/Vorbis_I_spec.* %{buildroot}%{_docdir}/%{name}
82
83 %remove_docs
84
85 %post  -p /sbin/ldconfig
86
87 %postun -p /sbin/ldconfig
88
89 %post -n libvorbisenc -p /sbin/ldconfig
90
91 %postun -n libvorbisenc -p /sbin/ldconfig
92
93 %post -n libvorbisfile -p /sbin/ldconfig
94
95 %postun -n libvorbisfile -p /sbin/ldconfig
96
97 %files 
98 %defattr(0644,root,root,0755)
99 %license COPYING 
100 %{_libdir}/libvorbis.so.0*
101
102 %files -n libvorbisenc
103 %defattr(0644,root,root,0755)
104 %license COPYING 
105 %{_libdir}/libvorbisenc.so.2*
106
107 %files -n libvorbisfile
108 %defattr(0644,root,root,0755)
109 %license COPYING 
110 %{_libdir}/libvorbisfile.so.3*
111
112 %files devel
113 %defattr(-,root,root)
114 %license COPYING 
115 %{_datadir}/aclocal/*.m4
116 %{_includedir}/vorbis
117 %{_libdir}/lib*.so
118 %{_libdir}/pkgconfig/*.pc
119
120 %changelog