usbhost api: remove profile dependency
[platform/upstream/libusb.git] / packaging / libusb.spec
1 %define TIZEN_FEATURE_USBHOST_API on
2
3 Name:           libusb
4 Version:        1.0.19
5 Release:        0
6 License:        LGPL-2.1+
7 Summary:        USB Library
8 Url:            http://www.libusb.org/
9 Group:          Base/Device Management
10 Source:         %{name}-%{version}.tar.bz2
11 Source1:        baselibs.conf
12 Source1001:     libusb.manifest
13 BuildRequires:  pkg-config
14 BuildRequires:  systemd-devel
15 %if %{?TIZEN_FEATURE_USBHOST_API} == on
16 BuildRequires:  pkgconfig(dbus-1)
17 %endif
18
19 %description
20 Libusb is a library that allows userspace access to USB devices.
21
22 %package devel
23 Summary:        USB Library
24 Group:          Development/Libraries
25 Requires:       glibc-devel
26 Requires:       libusb = %{version}
27
28 %description devel
29 Libusb is a library that allows userspace access to USB devices.
30
31 %prep
32 %setup -q
33 cp %{SOURCE1001} .
34
35 %build
36 %reconfigure\
37         --with-pic\
38 %if %{?TIZEN_FEATURE_USBHOST_API} == on
39         --enable-usbhost-api \
40 %endif
41         --disable-static
42 make %{?_smp_mflags}
43
44 %install
45 %make_install
46
47 %post  -p /sbin/ldconfig
48
49 %postun  -p /sbin/ldconfig
50
51 %files
52 %manifest %{name}.manifest
53 %defattr(-,root,root)
54 %license COPYING
55 %{_libdir}/*.so.*
56
57 %files devel
58 %manifest %{name}.manifest
59 %defattr(-,root,root)
60 %{_includedir}/libusb-1.0
61 %{_libdir}/*.so
62 %{_libdir}/pkgconfig/*.pc
63
64 %changelog