Use deviced instead of USB Security Daemon
[platform/upstream/libusb.git] / packaging / libusb.spec
1 Name:           libusb
2 Version:        1.0.19
3 Release:        0
4 License:        LGPL-2.1+
5 Summary:        USB Library
6 Url:            http://www.libusb.org/
7 Group:          Base/Device Management
8 Source:         %{name}-%{version}.tar.bz2
9 Source1:        baselibs.conf
10 Source1001:     libusb.manifest
11 BuildRequires:  pkg-config
12 BuildRequires:  systemd-devel
13 BuildRequires:  pkgconfig(deviced)
14
15 %description
16 Libusb is a library that allows userspace access to USB devices.
17
18 %package devel
19 Summary:        USB Library
20 Group:          Development/Libraries
21 Requires:       glibc-devel
22 Requires:       libusb = %{version}
23
24 %description devel
25 Libusb is a library that allows userspace access to USB devices.
26
27 %prep
28 %setup -q
29 cp %{SOURCE1001} .
30
31 %build
32 %reconfigure\
33         --with-pic\
34         --disable-static\
35         --enable-deviced
36 make %{?_smp_mflags}
37
38 %install
39 %make_install
40
41 %post  -p /sbin/ldconfig
42
43 %postun  -p /sbin/ldconfig
44
45 %files
46 %manifest %{name}.manifest
47 %defattr(-,root,root)
48 %license COPYING
49 %{_libdir}/*.so.*
50
51 %files devel
52 %manifest %{name}.manifest
53 %defattr(-,root,root)
54 %{_includedir}/libusb-1.0
55 %{_libdir}/*.so
56 %{_libdir}/pkgconfig/*.pc
57
58 %changelog