Modify ua.h to ua_types.h for integrating header with tota-ua
[platform/core/system/libtota.git] / packaging / libtota.spec
1 Name:           libtota
2 Summary:        fota update library
3 Version:        1.0.0
4 Release:        0
5 Group:          System
6 License:        Apache-2.0 and BSD-2-Clause and BSD-3-Clause and PD
7 Source0:        %{name}-%{version}.tar.gz
8
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(libsmack)
11 BuildRequires:  pkgconfig(lib7zip)
12 BuildRequires:  pkgconfig(libdivsufsort)
13
14 %description
15 Fota update agent which update firmware using delta files
16
17 %package devel
18 License:        Apache-2.0 and BSD-2-Clause and BSD-3-Clause and PD
19 Summary:        libtota library (development)
20 Requires:       libtota = %{version}
21 Group:          Development/Libraries
22
23 %description devel
24 Description: libfactory library (development)
25
26 %package -n tota-bsdiff
27 Summary:       bsdiff / bspatch tools for TOTA
28
29 %description -n tota-bsdiff
30 bsdiff / bspatch are tools for building and applying patches to binary files.
31 This package offers these tools for TOTA.
32
33 %prep
34 %setup -q
35
36
37 %build
38 export LDFLAGS+="-Wl,--rpath=%{_prefix}/lib -Wl,--as-needed"
39 mkdir cmake_tmp
40 cd cmake_tmp
41 LDFLAGS="$LDFLAGS"
42 %cmake .. \
43         -DCMAKE_INSTALL_PREFIX=%{_prefix}
44
45 make %{?jobs:-j%jobs}
46
47 %install
48 cd cmake_tmp
49 %make_install
50 #mkdir -p %{buildroot}/usr/lib/
51 cp libtota.a %{buildroot}%{_libdir}/libtota.a
52 %post
53
54
55 %files
56 %defattr(-,root,root,-)
57 %license LICENSE.Apache-2.0
58 %license LICENSE.BSD-2-Clause
59 %license LICENSE.BSD-3-Clause
60 %{_libdir}/libtota.so.*
61 #%manifest fota.manifest
62
63 %files devel
64 %defattr(-,root,root,-)
65 %{_libdir}/libtota.so
66 %{_libdir}/libtota.a
67 %{_libdir}/pkgconfig/tota.pc
68 %{_includedir}/fota_common.h
69 %{_includedir}/fota_log.h
70 %{_includedir}/fota_tar.h
71 %{_includedir}/SS_Common.h
72 %{_includedir}/SS_Engine_Errors.h
73 %{_includedir}/SS_Engine_Update.h
74 %{_includedir}/SS_FSUpdate.h
75 %{_includedir}/SS_ImageUpdate.h
76 %{_includedir}/SS_MultiProcessUpdate.h
77 %{_includedir}/SS_Nand.h
78 %{_includedir}/SS_UPI.h
79 %{_includedir}/ua_types.h
80
81 %files -n tota-bsdiff
82 %{_bindir}/ss_bsdiff
83 %{_bindir}/ss_bspatch