Add default Smack manifest for libtool.spec
[toolchains/libtool.git] / packaging / libtool.spec
1 #
2 # Please submit bugfixes or comments via http://bugs.meego.com/
3 #
4
5 Name:           libtool
6 Version:        2.2.6b
7 Release:        1
8 License:        GPLv2+ and LGPLv2+ and GFDL
9 Summary:        The GNU Portable Library Tool
10 Url:            http://www.gnu.org/software/libtool/
11 Group:          Development/Tools
12 Source:         http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.gz
13 Source1001: packaging/libtool.manifest 
14 Patch0:         no-host-name.patch
15 Patch1:         fix-AC_LANG_PROGRAM.patch
16
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake >= 1.9.2
19
20 Requires:       autoconf >= 2.58
21 Requires:       automake >= 1.4
22 Requires:       sed
23
24 %description
25 GNU Libtool is a set of shell scripts which automatically configure UNIX and
26 UNIX-like systems to generically build shared libraries. Libtool provides a
27 consistent, portable interface which simplifies the process of using shared
28 libraries.
29
30 If you are developing programs which will use shared libraries, but do not use
31 the rest of the GNU Autotools (such as GNU Autoconf and GNU Automake), you
32 should install the libtool package.
33
34 The libtool package also includes all files needed to integrate the GNU
35 Portable Library Tool (libtool) and the GNU Libtool Dynamic Module Loader
36 (ltdl) into a package built using the GNU Autotools (including GNU Autoconf
37 and GNU Automake).
38
39 %package ltdl
40 License:        LGPLv2+
41 Summary:        Runtime libraries for GNU Libtool Dynamic Module Loader
42 Group:          System/Libraries
43 Provides:       %{name}-libs = %{version}
44 Requires(post):  /sbin/ldconfig
45 Requires(postun):  /sbin/ldconfig
46
47 %description ltdl
48 The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
49 library that provides a consistent, portable interface which simplifies the
50 process of using dynamic modules.
51
52 These runtime libraries are needed by programs that link directly to the
53 system-installed ltdl libraries; they are not needed by software built using
54 the rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
55
56 %package ltdl-devel
57 License:        LGPLv2+
58 Summary:        Tools needed for development using the GNU Libtool Dynamic Module Loader
59 Group:          Development/Libraries
60 Requires:       %{name}-ltdl = %{version}
61
62 %description ltdl-devel
63 Static libraries and header files for development with ltdl.
64
65 %prep
66 %setup -n libtool-%{version} -q
67 %patch0 -p1
68 %patch1 -p1
69
70 %build
71 cp %{SOURCE1001} .
72
73 ./bootstrap
74
75 export CC=gcc
76 export CXX=g++
77 export F77=gfortran
78 export CFLAGS="%{optflags} -fPIC"
79 # don't conflict with libtool-1.5, use own directory:
80 sed -e 's/pkgdatadir="\\${datadir}\/\$PACKAGE"/pkgdatadir="\\${datadir}\/\${PACKAGE}"/' configure > configure.tmp; mv -f configure.tmp configure; chmod a+x configure
81 ./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
82 # build not smp safe:
83 make 
84
85
86 %install
87 %make_install
88 rm -rf %{buildroot}%{_infodir}
89
90 %check
91 #make check VERBOSE=yes > make_check.log 2>&1 || (cat make_check.log && false)
92
93
94 %clean
95 rm -rf %{buildroot}
96
97 %post ltdl -p /sbin/ldconfig
98
99 %postun ltdl -p /sbin/ldconfig
100
101 %files
102 %manifest libtool.manifest
103 %defattr(-,root,root)
104 %doc AUTHORS COPYING  THANKS 
105 %{_bindir}/libtool
106 %{_bindir}/libtoolize
107 %{_datadir}/aclocal/*.m4
108 %exclude %{_datadir}/libtool/libltdl
109 %{_datadir}/libtool
110
111 %files ltdl
112 %manifest libtool.manifest
113 %defattr(-,root,root)
114 %doc libltdl/COPYING.LIB libltdl/README
115 %{_libdir}/libltdl.so.*
116
117 %files ltdl-devel
118 %manifest libtool.manifest
119 %defattr(-,root,root)
120 %{_datadir}/libtool/libltdl
121 %{_libdir}/libltdl.so
122 %{_includedir}/ltdl.h
123 %{_includedir}/libltdl
124
125
126