packaging: keep static
[platform/upstream/libtool.git] / packaging / libtool.spec
1 %define keepstatic 1
2 Name:           libtool
3 Summary:        A Tool to Build Shared Libraries
4 License:        GPL-2.0+
5 Group:          Development/Tools
6 Version:        2.4.6
7 Release:        0
8 Url:            http://www.gnu.org/software/libtool/
9 Source:         http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.gz
10 Source2:        baselibs.conf
11 Source3:        libtool-rpmlintrc
12 Source1001:     libtool.manifest
13
14 BuildRequires:  automake
15 BuildRequires:  gcc-c++
16 BuildRequires:  lzma
17 BuildRequires:  zlib-devel
18 BuildRequires:  makeinfo
19
20 Requires:       automake > 1.4
21 Requires:       tar
22 Requires:       libltdl = %{version}
23
24 Provides:       libltdl-devel
25 # fedora name
26 Provides:       libtool-ltdl-devel
27
28 %description
29 GNU libtool is a set of shell scripts to automatically configure UNIX
30 architectures to build shared libraries in a generic fashion.
31
32 %package -n libltdl
33 Summary:        Libtool Runtime Library
34 Group:          System/Libraries
35
36 %description -n libltdl
37 Library needed by programs that use the ltdl interface of GNU libtool.
38
39 %prep
40 %setup -q -n libtool-%{version}
41 cp %{SOURCE1001} .
42
43 %build
44 %_configure CFLAGS="$RPM_OPT_FLAGS" \
45    --prefix=/usr --infodir=%{_infodir} --libdir=%{_libdir}
46
47 # force rebuild with non-broken makeinfo
48 rm -f doc/libtool.info
49 %__make %{?_smp_mflags}
50
51
52 %install
53 make install DESTDIR=$RPM_BUILD_ROOT
54 %remove_docs
55
56 %post -n libltdl -p /sbin/ldconfig
57
58 %postun -n libltdl -p /sbin/ldconfig
59
60 %files
61 %manifest %{name}.manifest
62 %license COPYING
63 %{_bindir}/libtool
64 %{_bindir}/libtoolize
65 %{_includedir}/libltdl
66 %{_includedir}/ltdl.h
67 %{_libdir}/libltdl.so
68 %{_libdir}/libltdl.a
69 %attr(644, root, root) %{_libdir}/libltdl.la
70 %{_datadir}/aclocal/*.m4
71 %{_datadir}/libtool
72
73 %files -n libltdl
74 %manifest %{name}.manifest
75 %license COPYING
76 %{_libdir}/libltdl.so.*
77
78 %changelog