Change license name BSD-3-Clause to BSD-2.0
[platform/upstream/libtheora.git] / packaging / libtheora.spec
1 Name:           libtheora
2 Version:        1.1.1
3 Release:        14
4 License:        BSD-2.0
5 Summary:        Free Video Codec
6 Url:            http://www.theora.org/
7 Group:          Multimedia/Video
8 %define pkg_version %{version}
9 Source:         %{name}-%{version}.tar.bz2
10 Source2:        baselibs.conf
11 Source1001:     libtheora.manifest
12 BuildRequires:  gcc-c++
13 BuildRequires:  libogg-devel
14 BuildRequires:  libtool
15 BuildRequires:  libvorbis-devel
16 BuildRequires:  pkg-config
17 BuildRequires:  python
18
19 %description
20 Theora is a free video codec based on VP3. The package contains the
21 library that can decode and encode Theora streams. Theora is also able
22 to playback VP3 streams.
23
24 %package devel
25 License:        BSD-3-Clause
26 Summary:        Free Video Codec
27 Group:          Development/Libraries
28 Requires:       libogg-devel
29 Requires:       libtheora = %{version}
30
31 %description devel
32 Theora is a free video codec based on VP3. The package contains the
33 library that can decode and encode Theora streams. Theora is also able
34 to playback VP3 streams.
35
36 %prep
37 %setup -q -n %{name}-%{pkg_version}
38 cp %{SOURCE1001} .
39
40 %build
41 ACLOCAL="aclocal -I m4" autoreconf -f -i
42 %configure --disable-examples \
43     --disable-static \
44     --with-pic
45 make %{?_smp_mflags} docdir=%{_docdir}/%{name}
46
47 %check
48 make check
49
50 %install
51 %make_install
52 install -d %{buildroot}%{_bindir}
53
54 rm -rf %{buildroot}/%{_datadir}/doc/%{name}-%{version}/*
55
56 %post  -p /sbin/ldconfig
57
58 %postun  -p /sbin/ldconfig
59
60 %files
61 %manifest %{name}.manifest
62 %defattr(-,root,root)
63 %doc COPYING LICENSE
64 %{_libdir}/libtheora.so.0*
65 %{_libdir}/libtheoradec.so.1*
66 %{_libdir}/libtheoraenc.so.1*
67
68 %files devel
69 %manifest %{name}.manifest
70 %defattr(-,root,root)
71 %{_includedir}/theora
72 %{_libdir}/*.so
73 %{_libdir}/pkgconfig/theoradec.pc
74 %{_libdir}/pkgconfig/theoraenc.pc
75 %{_libdir}/pkgconfig/theora.pc