install the license file
[platform/core/uifw/libtdm.git] / packaging / libtdm.spec
1 Name:           libtdm
2 Version:        1.1.0
3 Release:        0
4 Summary:        User Library of Tizen Display Manager
5 Group:          Development/Libraries
6 License:        MIT
7 Source0:        %{name}-%{version}.tar.gz
8 Source1001:         %{name}.manifest
9 BuildRequires:  pkgconfig(pthread-stubs)
10 BuildRequires:  pkgconfig(libtbm)
11 BuildRequires:  pkgconfig(libpng)
12 BuildRequires:  pkgconfig(ttrace)
13
14 %description
15 Common user library of Tizen Display Manager : libtdm front-end library
16
17 %package devel
18 Summary:        Devel of Tizen Display Manager Library
19 Group:          Development/Libraries
20 Requires:       libtdm = %{version}
21 Requires:       pkgconfig(libtbm)
22
23 %description devel
24 This supports frontend & backend library header and so
25
26 %global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
27
28 %prep
29 %setup -q
30 cp %{SOURCE1001} .
31
32 %build
33 %reconfigure --disable-static \
34              CFLAGS="${CFLAGS} -Wall -Werror" \
35              LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
36 make %{?_smp_mflags}
37
38 %install
39 rm -rf %{buildroot}
40 mkdir -p %{buildroot}/%{TZ_SYS_RO_SHARE}/license
41 cp -af COPYING %{buildroot}/%{TZ_SYS_RO_SHARE}/license/%{name}
42 %make_install
43
44 %remove_docs
45
46 %post -p /sbin/ldconfig
47 %postun -p /sbin/ldconfig
48
49
50 %files
51 %manifest %{name}.manifest
52 %defattr(-,root,root,-)
53 %{TZ_SYS_RO_SHARE}/license/%{name}
54 %{_libdir}/libtdm.so.*
55
56 %files devel
57 %manifest %{name}.manifest
58 %defattr(-,root,root,-)
59 %{_includedir}/*
60 %{_libdir}/pkgconfig/*
61 %{_libdir}/libtdm.so
62
63 %changelog