4d7c1bd89c247b0d98cfbadb541292b379bb4314
[framework/telephony/libtcore.git] / packaging / libtcore.spec
1 #sbs-git:slp/pkgs/l/libtcore
2 Name: libtcore
3 Summary: Telephony-core library
4 Version: 0.1.61
5 Release:    1
6 Group:      System/Libraries
7 License:    Apache
8 Source0:    libtcore-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(gudev-1.0)
15
16 %description
17 Telephony-core library
18
19 %package devel
20 Summary:        Telephony-core library (Development)
21 Requires:       %{name} = %{version}
22 Group:          Development/Libraries
23
24 %description devel
25 Telephony-core library (Development)
26
27 %prep
28 %setup -q
29
30 %build
31 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
32 make %{?jobs:-j%jobs}
33
34 %post
35 /sbin/ldconfig
36
37 %postun -p /sbin/ldconfig
38
39 %install
40 rm -rf %{buildroot}
41 %make_install
42
43 %files
44 %defattr(-,root,root,-)
45 #%doc COPYING
46 %{_libdir}/libtcore*
47 #%{_bindir}/*
48
49 %files devel
50 %defattr(-,root,root,-)
51 %{_includedir}/*
52 %{_libdir}/pkgconfig/tcore.pc