g_dbus connection timeout value added in tel_select_network_automatic() - timout...
[platform/core/telephony/libtapi.git] / packaging / libtapi.spec
1 Name: libtapi
2 Summary: Telephony dbus client library
3 Version: 0.6.70
4 Release:    2
5 Group:      System/Libraries
6 License:    Apache-2.0
7 Source0:    libtapi-%{version}.tar.gz
8 Source1001:     libtapi.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(glib-2.0)
11 BuildRequires:  pkgconfig(gobject-2.0)
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(security-server)
14
15 %description
16 Telephony client API library
17
18 %package devel
19 Summary:    Telephony client API (devel)
20 Group:      Development/Libraries
21 Requires:   %{name} = %{version}-%{release}
22
23 %description devel
24 Telephony client API library (devel)
25
26
27 %prep
28 %setup -q
29 cp %{SOURCE1001} .
30
31
32 %build
33 %cmake .
34
35
36 make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41
42 rm -rf %{buildroot}/usr/include/telephony/tapi/.gitignore
43 mkdir -p %{buildroot}/usr/share/license
44
45 %post -p /sbin/ldconfig
46
47 %postun -p /sbin/ldconfig
48
49
50 %files
51 %manifest %{name}.manifest
52 %defattr(-,root,root,-)
53 %{_libdir}/*.so.*
54 /usr/share/license/libtapi
55
56 %files devel
57 %manifest %{name}.manifest
58 %defattr(-,root,root,-)
59 %{_includedir}/telephony-client/*.h
60 %{_libdir}/pkgconfig/*.pc
61 %{_libdir}/*.so