Revert manifest to default one
[profile/ivi/libsvi.git] / packaging / libsvi.spec
1 Name:       libsvi
2 Summary:    SVI
3 Version:    0.1.2
4 Release:    8
5 Group:      System/Libraries
6 License:    Apache License, Version 2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(vconf)
13 BuildRequires:  pkgconfig(devman_haptic)
14 BuildRequires:  pkgconfig(mm-keysound)
15 BuildRequires:  pkgconfig(devman)
16
17 %description
18
19 %package devel
20 Summary:    SVI
21 Group:      Development/Libraries
22 Requires:   %{name} = %{version}-%{release}
23
24 %description devel
25
26 %prep
27 %setup -q 
28
29 %build
30 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
31 make
32
33 %install
34 rm -rf %{buildroot}
35 %make_install
36
37 %post -p /sbin/ldconfig
38
39 %postun -p /sbin/ldconfig
40
41 %files
42 %defattr(-,root,root,-)
43 %{_bindir}/svi_test
44 %{_libdir}/libsvi.so.*
45
46 %files devel
47 %defattr(-,root,root,-)
48 %{_includedir}/svi/*.h
49 %{_libdir}/libsvi.so
50 %{_libdir}/pkgconfig/svi.pc
51
52 %changelog
53 * Thu Sep 06 2012 - Jiyoung Yun <jy910.yun@samsung.com>
54 - if there isnt' haptic resource, it plays monotone
55 - Tag : libsvi_0.1.2-8
56
57 * Mon Aug 20 2012 - Jiyoung Yun <jy910.yun@samsung.com>
58 - Re-uploaded because prev commit is not supply on tizen_build project
59 - Tag : libsvi_0.1.2-7
60
61 * Fri Aug 17 2012 - Jiyoung Yun <jy910.yun@samsung.com>
62 - separate 2.0_beta branch from master
63 - Remove code regarding led notification that is product feature
64 - Tag : libsvi_0.1.2-6
65
66 * Tue Aug 14 2012 - Jiyoung Yun <jy910.yun@samsung.com>
67 - led bug fix
68 - svi_play_led function is called twice
69 - Tag : libsvi_0.1.2-5
70
71 * Tue Aug 14 2012 - Jiyoung Yun <jy910.yun@samsung.com>
72 - Code merge from old git
73 - Tag : libsvi_0.1.2-4
74
75 * Mon Aug 06 2012 - Jiyoung Yun <jy910.yun@samsung.com>
76 - Add new code for support LED notification
77 - Add svi-led.c file to convert ivt to led file
78 - Change SVI_VIB_OPERATION_FULLYCHARGED to SVI_VIB_OPERATION_FULLCHARGED enum value
79 - Tag : libsvi_0.1.2-3
80
81 * Fri Aug 03 2012 - Jiyoung Yun <jy910.yun@samsung.com>
82 - Change SVI_VIB_OPERATION_LOTBATT to SVI_VIB_OPERATION_LOWBATT value
83 - Tag : libsvi_0.1.2-2
84
85 * Fri Jul 13 2012 - Hyungdeuk Kim <hd3.kim@samsung.com>
86 - Add 2 new enum type defined by ux 0627 document
87 - remove temp code for error handling