Get Ringtone path from system setting api
[platform/core/system/libstorage.git] / packaging / libstorage.spec
1 Name:       libstorage
2 Summary:    Library to get storage information
3 Version:    0.1.0
4 Release:    0
5 Group:      System/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    %{name}.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(capi-base-common)
12 BuildRequires:  pkgconfig(vconf)
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(libtzplatform-config)
15 BuildRequires:  pkgconfig(capi-system-system-settings)
16
17 %description
18 development package of library to get storage
19
20 %package devel
21 Summary:        Get storage information (devel)
22 Group:          Development/Libraries
23 Requires:       %{name} = %{version}-%{release}
24
25 %description devel
26 Library to get storage information (devel)
27
28
29 %prep
30 %setup -q
31 cp %{SOURCE1} .
32
33 %build
34 %cmake .
35 make %{?jobs:-j%jobs}
36
37 %install
38 %make_install
39
40 %post -p /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44 %files
45 %{_libdir}/*.so.*
46 %{_sysconfdir}/storage/libstorage.conf
47 %license LICENSE
48 %manifest %{name}.manifest
49
50 %files devel
51 %{_includedir}/storage/*.h
52 %{_libdir}/*.so
53 %{_libdir}/pkgconfig/*.pc