add missing slash in %configure
[platform/upstream/libsoup.git] / packaging / libsoup.spec
1 %bcond_with gnome
2
3 Name:           libsoup
4 Version:        2.40.1
5 Release:        2.1
6 License:        LGPL-2.1+
7 Summary:        HTTP client/server library for GNOME
8 Url:            http://www.gnome.org
9 Group:          Development/Libraries/GNOME
10 Source:         http://download.gnome.org/sources/libsoup/2.40/%{name}-%{version}.tar.xz
11 Source99:       baselibs.conf
12 # Patches auto-generated by git-buildpackage:
13 BuildRequires:  gettext-tools
14 BuildRequires:  glib-networking
15 %if %{with gnome}
16 BuildRequires:  gobject-introspection-devel
17 BuildRequires:  pkgconfig(gnome-keyring-1)
18 %endif
19 BuildRequires:  intltool >= 0.35.0
20 BuildRequires:  sqlite3-devel
21 BuildRequires:  pkgconfig(glib-2.0) >= 2.31.7
22 BuildRequires:  gnome-common
23 BuildRequires:  pkgconfig(libxml-2.0)
24
25 %description
26 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
27 and the glib main loop, to integrate well with GNOME applications.
28
29 Features:
30   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
31   * Automatically caches connections
32   * SSL Support using GnuTLS
33   * Proxy support, including authentication and SSL tunneling
34   * Client support for Digest, NTLM, and Basic authentication
35   * Server support for Digest and Basic authentication
36   * XML-RPC support
37
38 %package -n typelib-Soup
39 Summary:        HTTP client/server library for GNOME -- Introspection bindings
40 Group:          System/Libraries
41
42 %description -n typelib-Soup
43 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
44 and the glib main loop, to integrate well with GNOME applications.
45
46 This package provides the GObject Introspection bindings for libsoup.
47
48 %package devel
49 Summary:        HTTP client/server library for GNOME - Development Files
50 Group:          Development/Libraries/GNOME
51 Requires:       %{name} = %{version}
52 Requires:       typelib-Soup = %{version}
53
54 %description devel
55 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
56 and the glib main loop, to integrate well with GNOME applications.
57
58 Features:
59   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
60   * Automatically caches connections
61   * SSL Support using GnuTLS
62   * Proxy support, including authentication and SSL tunneling
63   * Client support for Digest, NTLM, and Basic authentication
64   * Server support for Digest and Basic authentication
65   * XML-RPC support
66
67 %prep
68 %setup -q
69
70 %build
71 %autogen\
72 %if %{with gnome}
73      --with-gnome \
74      --enable-introspection \
75 %else
76      --without-gnome \
77      --enable-sqllite=yes \
78     --disable-tls-check \
79 %endif
80     --disable-static 
81 make %{?_smp_mflags}
82
83 %install
84 %make_install
85
86 %find_lang %{name}
87
88 %post -p /sbin/ldconfig
89
90 %postun -p /sbin/ldconfig
91
92 %lang_package
93
94 %files
95 %defattr(-, root, root)
96 %license  COPYING
97 %{_libdir}/*.so.*
98
99 %files -n typelib-Soup
100 %defattr(-,root,root)
101 %if %{with gnome}
102 %{_libdir}/girepository-1.0/Soup-2.4.typelib
103 %{_libdir}/girepository-1.0/SoupGNOME-2.4.typelib
104 %endif
105
106 %files devel
107 %defattr(-,root,root)
108 %{_includedir}/libsoup-2.4
109 %{_libdir}/*.so
110 %{_libdir}/pkgconfig/*.pc
111 %if %{with gnome}
112 %{_datadir}/gir-1.0/Soup-2.4.gir
113 %{_datadir}/gir-1.0/SoupGNOME-2.4.gir
114 %{_includedir}/libsoup-gnome-2.4
115 %endif